Ticket #169: email2trac-1.0.0.ebuild

File email2trac-1.0.0.ebuild, 599 bytes (added by John Lowry <johnlowry@…>, 14 years ago)

Gentoo ebuild that builds and has been tested.

Line 
1# Copyright 1999-2009 Gentoo Foundation
2# Distributed under the terms of the GNU General Public License v2
3# $Header: $
4EAPI="2"
5inherit python
6
7DESCRIPTION="Utilites to convert emails into trac objects"
8HOMEPAGE="https://subtrac.sara.nl/oss/email2trac/"
9SRC_URI="ftp://ftp.sara.nl/pub/outgoing/email2trac.tar.gz"
10
11LICENSE="GPL-2"
12SLOT="0"
13KEYWORDS="amd64"
14IUSE="doc"
15
16DEPEND=""
17RDEPEND=""
18
19src_compile()
20{
21        econf                                                   \
22                --sysconfdir=/etc/${PN}/        \
23                --with-trac_user=apache         \
24                --with-MTA_user=nobody
25
26        return
27}
28
29src_install()
30{
31        emake DESTDIR="${D}" install || die "Install failed"
32        return
33 }