Custom Query (332 matches)

Filters
 
Or
 
  
 
Columns

Show under each result:


Results (157 - 159 of 332)

Ticket Resolution Summary Owner Reporter
#404 fixed Missing attachments bas magda@…
Description

I am trying to set up email2trac in our multi-project trac environment by piping incoming mails through a php script which then calls email2trac with the correct project id. The only problem: email attachments are not being attached to tickets. Adding an attachments to a ticket manually works. Executing email2trac with debug option reveals that attachments of mails are being parsed and created in the tmp folder.

Last log entry lines:

2016-11-17 13:17:33,867 email2trac 182: writing body to /tmp/182xZk6af.email2trac.body

2016-11-17 13:17:33,867 email2trac 182: function debug_attachments

2016-11-17 13:17:33,867 email2trac 182:          part0: Content-Type: application/pdf

2016-11-17 13:17:33,867 email2trac 182: writing /tmp/182xZk6af.email2trac.part1.pdf: filename: st-oktober.pdf

The file exists and is readable by the apache user (which is executing the email2trac command)

But the ticket itself has no attachment and the link in the description points to an invalid/missing attachments. Looking at the projects db, the attachment table doesn't contain an entry for the attachment.

Any ideas/suggestions where or what the problem might be?

#15 fixed Milestone Handling bas Garrett McGrath <gmcgrath@…>
Description
To whom it may concern:
    I'm looking at modifying the email2trac script to enable it to
handle a 'category' flag.  Specifically we are using Trac as a data
portal for our users and are exploring using the ticket system to
track
help requests to make life easier for our users (quick referrence to
past issues and etc.).  I'm thinking that the milestones system would
be
an easy way to segregate our emailed tickets automatically.  eg. if we
get a feature request for our calendar that goes to 1 email, and
general
help to a second email address, these simply populate the same ticket
system in trac but with different milestones attached to them (or
components as that would be nice to split things up with as well).  So
my question is has anyone does this before, and do I just need to
modify
the email2trac.py program or do the .c and .h files get modified as
well.
-Garrett McGrath
#60 fixed mailto_trac + german umlaut problem bas alex@…
Description

Hi,

if i set mailto_link in email2trac.config to 1 and receive a email with a german Umlaut (ä,ü,ö) in the subject, i get the following error:

May 14 14:53:00 localhost email2trac: Traceback (most recent call last):
May 14 14:53:00 localhost email2trac:   File "/usr/local/bin/email2trac", line 1140, in ?     tktparser.parse(sys.stdin)
May 14 14:53:00 localhost email2trac:   File "/usr/local/bin/email2trac", line 728, in parse     self.new_ticket(m, component)
May 14 14:53:00 localhost email2trac:   File "/usr/local/bin/email2trac", line 674, in new_ticket     mailto = self.html_mailto_link(tkt['summary'], ticket_id, body_text)
May 14 14:53:00 localhost email2trac:   File "/usr/local/bin/email2trac", line 894, in html_mailto_link     str = 'mailto:%s?Subject=%s&Cc=%s' %(
May 14 14:53:00 localhost email2trac:   File "urllib.py", line 1110, in quote     res = map(safe_map.__getitem__, s)
May 14 14:53:00 localhost email2trac: KeyError: u'\xdc'

I use email2trac with fetchmail + procmail fetching mails from exchange. If i deactivate "mailto_link" everything works fine. Enclosed is a mail header that leads to that problem described above:

Received: from mail.exchange.local ([192.168.0.101]) by mail.exchange.local
 ([192.168.0.101]) with mapi; Wed, 14 May 2008 12:30:38 +0200
From: XXX
To: support 
Date: Wed, 14 May 2008 12:30:37 +0200
Subject: =?Windows-1252?Q?=DCberTestTicket2?=
Thread-Topic: =?Windows-1252?Q?=DCberTestTicket2?=
Thread-Index: AQHIta2Mj/TcnoIsRUu4khLyH1a30A==
Message-ID: <1E80D902A0C956449784BCD6BCDF18157FB6DB62DC@mail.exchange.local>
Accept-Language: en-US, de-DE
Content-Language: en-US
X-MS-Exchange-Organization-AuthAs: Internal
X-MS-Exchange-Organization-AuthMechanism: 04
X-MS-Exchange-Organization-AuthSource: mail.exchange.local
X-MS-Has-Attach:
X-MS-Exchange-Organization-SCL: -1
X-MS-TNEF-Correlator:
acceptlanguage: en-US, de-DE
Content-Type: text/plain; charset="Windows-1252"
Content-Transfer-Encoding: quoted-printable
MIME-Version: 1.0

Is there a possible workaround?

Thanks for the help,

alex

Note: See TracQuery for help on using queries.