Modify

Opened 12 years ago

Closed 12 years ago

#134 closed setup (fixed)

Email2Trac and Fetchmail

Reported by: Avale Owned by: bas
Priority: blocker Milestone:
Component: email2trac Version: 0.80
Keywords: Cc:

Description

I'm trying to get Email2Trac to work with Fetchmail but I'm having issues.

The setup is currently using CentOS 5, Trac 0.11.4 and Email2Trac 0.80.

I have it configure with the MTA as root and the Trac user as apache.

When I do the test: email2trac --project=tracproj < msg.txt

It works fine. The ticket is created.

But when I run it through Fetchmail, I get this error: fetchmail: Error writing to MDA: Broken pipe

not flushed

Can anyone help me fix this? I would really like to get this working since it makes things a lot easier.

Attachments (0)

Change History (4)

comment:1 Changed 12 years ago by bas

I have no experience with fetchmail at all. Did you follow the procedure mentioned in:

comment:2 Changed 12 years ago by Avale

Yes, I followed the instructions.

I also tried it on Sendmail but I get the same error ("Broken pipe").

The program "email2trac" works fine. It's the program "run_email2trac" that doesn't.

fetchmail: IMAP< A0007 OK Fetch completed.
fetchmail: IMAP> A0008 FETCH 1 RFC822.HEADER
fetchmail: IMAP< * 1 FETCH (RFC822.HEADER {1063}
reading message trac@test.com@pop.test.com:1 of 1 (1063 header octets)
#
fetchmail: IMAP< )
fetchmail: IMAP< A0008 OK Fetch completed.
fetchmail: IMAP> A0009 FETCH 1 BODY.PEEK[TEXT]
fetchmail: IMAP< * 1 FETCH (BODY[TEXT] {591}
 (591 body octets)*************
fetchmail: IMAP< )
fetchmail: IMAP< A0009 OK Fetch completed.
fetchmail: Error writing to MDA: Broken pipe
 not flushed
fetchmail: IMAP> A0010 LOGOUT
fetchmail: IMAP< * BYE Logging out
fetchmail: IMAP< A0010 OK Logout completed.

I've tried the following:

       mda "/usr/local/bin/run_email2trac"

After creating a symlink in the Sendmail example

       mda "run_email2trac"

Same error for both.

Fetchmail config

poll pop.test.com
proto imap
user "trac@test.com"
pass "test"
is trac
keep
mda "/usr/local/bin/run_email2trac"

comment:3 Changed 12 years ago by bas

Just for clearifaction. You need only run_email2trac if the userid of the user that runs fetchmail has no write permissions in the TRAC environment. Else you can run email2trac. You can find out your user id.

mds "/usr/local/bin/id"

/usr/local/bin/id:
{{{
#/bin/sh
id > /var/tmp/fetchmail.id
}}}

Under which id runs fetchmail and what is the userid of trac? Did you give those users as option to configure?

comment:4 Changed 12 years ago by Avale

  • Resolution set to fixed
  • Status changed from new to closed

Alright! Thanks a lot!

I created the Fetchmail user to use Apache and it seems to work fine now. Thanks a lot!

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.