Modify

Opened 12 years ago

Closed 12 years ago

#140 closed defect (duplicate)

email2trac not parsing emails

Reported by: delpheye@… Owned by: bas
Priority: major Milestone: Release 1.1.0
Component: run_emailtrac Version: 0.80
Keywords: Cc:

Description

I have fetchmail and procmail installed and configured correctly(I assume) to process mail sent to trac for the mta_user.

[mta_user@boxbox ~]$ cat .procmailrc PATH=/bin:/usr/bin:/usr/bin MAILDIR=$HOME/Mail #better make sure it exists DEFAULT=$MAILDIR/mbox #completely optional LOGFILE=$MAILDIR/from #recommended

:0 h b

  • ^FROM_DAEMON
  • ^X-Loop: mta_user@… | /usr/bin/run_email2trac

[mta_user@boxbox ~]$ cat .fetchmailrc poll imap.mydomain.com proto pop3 user mta_user pass "password" mda "/usr/bin/procmail"

[root@boxbox ~]# cat /etc/email2trac.conf [DEFAULT] project: /var/www/html/trac debug: 0 umask: 022 spam_level: 5 reply_all : 0 mailto_link: 0 umask: 022 email_header: 0 trac_version: 0.11 enable_syslog : 1 alternate_notify_template : alternate_notify_template_update : drop_spam : 0 verbatim_format: 1 strip_signature: 0 email_quote: > strip_quotes: 0 ignore_trac_user_settings: 0 black_list: MAILER-DAEMON@

I have verified the paths in these two files and have verified that mail is being correctly delivered to the user's local mbox file.

strace on the run_email2trac binary doesn't return any errors so I assume it's working correctly.

Is there something else I'm missing?

Attachments (0)

Change History (8)

comment:1 Changed 12 years ago by bas

  • Status changed from new to assigned

I am not familiar with this setuo, but the error in most casses is the supplied values for mta_user or trac_user are wrong.

So first did you just test email2trac with the supplied sample email message? If this works then it is definitely worng user setup for run_email2trac

comment:2 Changed 12 years ago by delpheye@…

I see msg.txt, can I run run_email2trac on that file as "/path/to/run_email2trac /path/to/msg.txt"?

If so, then it doesn't process the test mail, but I've verified that the mta_user and and trac_user are correct. Here are the config options I used to install email2trac.

./configure --host=i686-redhat-linux-gnu --build=i686-redhat-linux-gnu --target=i386-redhat-linux --program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin --sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share --includedir=/usr/include --libdir=/usr/lib --libexecdir=/usr/libexec --localstatedir=/var --sharedstatedir=/usr/com --mandir=/usr/share/man --infodir=/usr/share/info --with-mta_user=labs --with-trac_user=apache

Should I have set this in configure.in as well prior to install?

comment:3 Changed 12 years ago by bas

Did you read:

Configure.in is used to generate configure so you have done the right thing with the configure command

comment:4 Changed 12 years ago by delpheye@…

The test message is delivered and processed. I had a problem in the mta_user's ./procmailrc file, but now I get egg-cache permissions errors when I run run_email2trac as the mta_user.

The following error occurred while trying to extract file(s) to the Python egg cache:

[Errno 13] Permission denied: '/home/mta_user/.python-eggs'

The Python egg cache directory is currently set to:

/home/mta_user/.python-eggs

The directory exists, so I believe the error is misleading. PYTHON_EGG_CACHE is set as shown:

[mta_user@boxbox .python-eggs]$ set | grep PYTHON PYTHON_EGG_CACHE=/home/zyvexlabs/.python-eggs/ _=PYTHON_EGG_CACHE

comment:5 Changed 12 years ago by bas

Did you also installed some other trac plugins. Some plugins use hardcoded paths. Tou can also try to set the PYTHON_EGG_CACHE in email2trac.conf. else you have to change the permissions of the python egg directory so ecerybody can write to it

comment:6 Changed 12 years ago by delpheye@…

Email2trac is the only plugin I have installed.

I've added "python_egg_cache: /home/mta_user/.python-eggs" to both the default and project configurations and the directory is writable by everyone, but I still get the same error.

Is there something I can put in the .python-eggs directory that it's trying to install to circumvent the error?

comment:7 Changed 12 years ago by bas

What webserver do you tun and email2trac is not a trac-plugin. I have enabled the following in my apache webserver:

SetEnv PYTHON_EGG_CACHE /var/www/eggs

comment:8 Changed 12 years ago by bas

  • Milestone set to Release 1.1.0
  • Resolution set to duplicate
  • Status changed from assigned to closed
  • Type changed from setup to defect

Did not hear anything and we solved the python_egg_cache setup in ticket #163

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.