Modify

Opened 11 years ago

Closed 11 years ago

#176 closed defect (worksforme)

Reporter receives no more notification after update

Reported by: hju@… Owned by: bas
Priority: major Milestone:
Component: email2trac Version: 1.0.0
Keywords: Cc:

Description

After successfully updating email2trac to version 1.0.0 we face a very odd behaviour.

The notification (we use alternate_notify_template - works as designed) is sent to the owner of the ticket (identified via componend) and the smtp_always_bcc adresses , but not to the reporter (who sent the mail).

There was nothing changed in the configuration (always_notify_reporter=true), the reporter_states = new,closed,reopened (from FlexibleReporterNotificationPlugin) are even unchanged.

If you later close the ticket, the reporter receives a mail as expected...

Are there any known issues on this?

Attachments (0)

Change History (13)

comment:1 Changed 11 years ago by bas

  • Status changed from new to assigned

Iy is new for me. Does the owner receive an email when th eticket is updated via email?

comment:2 Changed 11 years ago by hju@…

No. It's the same behaviour.

The alternate_notify_template_update ist used, but the reporter is not include. The mail is adressed to owner (an bcc-recipients) only.

comment:3 Changed 11 years ago by bas

I only use the standard notify function from trac. To enable mail for reporter you must set:

[notification]
always_notify_reporter = true
}}

I have no knowledge about which plugins are installed

comment:4 Changed 11 years ago by hju@…

I also tried it with this plugin disabled - no difference. (The always_notify_reporter = true is set)

I only use the standard notify function from trac.

Thats the point. I was looking in the code and thats what i saw.

But why is it no longer running (as it was before the update)?. Is it possible that the author field of the Ticket must be set in a special way?

If I ca do any further testing, let me know...

comment:5 Changed 11 years ago by basv@…

Not that i am aware of. This is a reply via email. So if you recieve
this
than there is something in you setup.

comment:6 Changed 11 years ago by hju@…

OK, I got a mail.

The Setup, hmmm, any idea where I can look at?

Closing the ticket works well: the reporter gets the standard-notification from trac. So far the setup is well running.

Seems I have to debug the communication between email2trac an trac...

comment:7 Changed 11 years ago by bas

Did you enabled workflow there is a fix for it in version 1.1. You can also check the mail.log maybe the message is sent to the wrong email address via email2trac. Enable trac.log and see if something strange happens.

comment:8 Changed 11 years ago by hju@…

thx. I'll have a look an the Workflow-fix and the mail.log trac.log has no entries (level: WARNING)

The first occurance of the problem was just after the update of email2trac. Very strange

comment:9 Changed 11 years ago by bas

Which trac version do you use. I use 0.11.5

comment:10 Changed 11 years ago by hju@…

It is called 0.11 running with python 2.4

The release is from 07.2008 (yes - I have to run an update sometimes)

comment:11 Changed 11 years ago by hju@…

There is one difference between the Reporter-field before and after the update:

Before the Reporter-email was stored as

"John Doe" <john.doe@example.com>

and the reporter got the Mail on creating the ticket. Now ist is stored as

john.doe@example.com

an the reporter does not receive any info.

Perhaps the way to this bug is anywhere in or arround these changes?

comment:12 Changed 11 years ago by hju@…

OK, thats the reason:

I'm using the !NeverNotifyUpdaterPlugin to remove the updater from the notification-list (because this is very annoying if you get always notifications about your own changes if you are owner of a ticket)

Before the email2trac-update, the "reporter" was stored as

"John Doe" <John.Doe@example.com>

whereas the updater was stored as

John Doe

in the change-history

Updater and reporter where different!

Nowadays the reporter and updater are stored as

John.Doe@example.com
{{{
and so the "updater" ist removed from the recipients-list...


My first idea is to introduce a litte patch to email2trac.py changing the "reporter" to
{{{
John.Doe@example.com via email2trac
}}}
This will make the notification work.


Perhaps there will be a better solution for this dilemma... any suggestions are welcome
}}}

comment:13 Changed 11 years ago by hju@…

  • Resolution set to worksforme
  • Status changed from assigned to closed

first of all: it is no bug in email2trac!

It "accidently" worked in our environment due to 2 circumstances:

  1. Every new ticket was updated (getting an entry in ticket_change table) with
     * id  set to 533
       This message has 2 attachment(s) 
    
    so the updater was always taken from the ticket_change author (and never set =reporter as normal for newly created tickets)
  2. the ticket_change author was different from the reporter (as I decribed above)

Now, this "bug" is "corrected" (look at #118)

The notification module works as desingned.

In our environment we strip the updater from the recipients list (using NeverNotifyUpdaterPlugin) - which now removes the reporter because they are now similar.

Now I have to find a way to add the updater to the recipients-list (or leave the adress in the list), if it was an update from email2trac... (currently I'm using the old "update-bug" as a workaround)

I'll close this ticket (sorry for bothering you) an file a new one if I have an idea.

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.