Modify

Opened 14 years ago

Closed 14 years ago

#23 closed defect (fixed)

Configuration problem

Reported by: Marc Zahnlecker <m.zahnlecker@…> Owned by: bas
Priority: minor Milestone:
Component: email2trac Version: 0.9.5
Keywords: Cc:

Description

Hello email2trac team,

I installed email2trac without the packet manager on a Suse 10.0
installation.
MTA and Trac users were specified by configure.

The email2trac.conf file looks this way:

[DEFAULT]
project: /usr/share/trac/projects/v3cms
debug: 10
umask: 022
spam_level: 5
reply_all : 0
mailto_link: 0
umask: 022
email_comment: >
email_header: 0
trac_version: 0.5
enable_syslog : 0
alternate_notify_template :
drop_spam : 0
verbatim_format: 1
strip_signature: 0


[v3cms]
debug: 10
project: /usr/share/trac/projects/v3cms
spam_level: 5
-----------------------------------------

But when I use email2trac --project=v3cms < msg.txt
to test the configuration I'm getting the following error:

Traceback (most recent call last):
  File "/usr/local/bin/email2trac", line 1060, in ?
    env = Environment(settings['project'], create=0)
NameError: name 'Environment' is not defined

I don't have any idea what's the problem, so please help me to get
email2trac working.

Thank you for your help.
Best regards
M. Zahnlecker

Attachments (0)

Change History (3)

comment:1 Changed 14 years ago by Marc Zahnlecker

  • id set to 23

This message has 0 attachment(s)

comment:2 Changed 14 years ago by bas

  • Priority changed from major to minor
  • Status changed from new to assigned

The problem is your trac_version, it must display a warning that this version is not supported. So it is also a bug:

trac_version: 0.5

must be trac_version: 0.9 or trac_version: 0.10

comment:3 Changed 14 years ago by bas

  • Resolution set to fixed
  • Status changed from assigned to closed

Added version check in SVN, so i close this ticket

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.