Modify

Opened 9 years ago

Closed 9 years ago

#304 closed defect (fixed)

None and None-1 encoding problem

Reported by: szybalski@… Owned by: bas
Priority: critical Milestone:
Component: email2trac Version: 1.6.0
Keywords: Cc:

Description

Hello, While using email2trac

ve been running a email2trac plugin for a while, and this is a first time I'm having trouble with trac not being able to decoded the attachment properly.

One of the users is using 3rd party web application to send an attachment. In trac it shows up as None-1 (236.7kb), but if I cc myself on the email "thunderbird" opens it without any problems. When I open the none-1 it looks like text/binary version of a pdf.

Here is a part of the email from thunderbird. Is anybody familiar with email content types to tell me what could be wrong with it? Is this a email2trac issue or formatting issue on the person that sends it. Note that if I forward the same email using Thunderbird it attaches just fine.:

..... ..email headers... Date: 3 Oct 2012 15:32:14 -0500 Content-Type: multipart/mixed; boundary=--boundary_4_cc760ab8-c89d-410d-9943-8117bbe33377 Message-ID: <AMC1IDk4JdxVHYEuZFk0000109b@…> X-OriginalArrivalTime?: 03 Oct 2012 20:32:21.0891 (UTC) FILETIME=[30CBAD30:01CDA1A6]


Content-Type: text/html; charset=us-ascii Content-Transfer-Encoding: quoted-printable

<html><body style=3D"font-family : arial, tahoma, sans-serif; fon= t-size : 10pt"></body></html>


Content-Type: application/octet-stream; name=CompanyApp?.pdf Content-Transfer-Encoding: base64 Content-Disposition: attachment

JVBERi0xLjYNCg0KODggMCBvYmoNCjw8DQovRSA2NjI2OQ0KL0ggWyA2NzQzIDQy NCBdDQovTCAyNDIzODQNCi9MaW5lYXJpemVkIDENCi9OIDENCi9PIDkyDQovVCAy NDA1NzMNCj4+ICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAgICAg ICAgICAgICAgICAgICAgICAgICAgICAgICAgIA0KZW5kb2JqDQoNCnhyZWYNCjg4 ....... ...... MCBuDQowMDAwMjM5ODE1IDAwMDAwIG4NCjAwMDAyNDAxODkgMDAwMDAg bg0KdHJhaWxlcg0KPDwNCi9TaXplIDg4DQo+Pg0Kc3RhcnR4cmVmDQoxODQNCiUl RU9GDQo=


And in trac the "comapnyapp.pdf" is called none-1 and when opened it shows:

%PDF-1.6 2 3 88 0 obj 4 << 5 /E 66269 6 /H [ 6743 424 ] 7 /L 242384 8 /Linearized 1 9 /N 1 10 /O 92 11 /T 240573 12 >> 13 endobj 14 15 xref 16 88 206 17 0000000012 00000 n ........


original header file that does not work.

<html><body style=3D"font-family : arial, tahoma, sans-serif; fon= t-size : 10pt"></body></html>


Content-Type: application/octet-stream; name=CompanyApp?.pdf Content-Transfer-Encoding: base64 Content-Disposition: attachment


header files from Thunderbird after I forward the email to truck from Thunderbird. This will be encoded correctly.

Content-Type: multipart/mixed;

boundary="------------020106040507050806030301"

This is a multi-part message in MIME format.


Content-Type: text/plain; charset=ISO-8859-1; format=flowed Content-Transfer-Encoding: 7bit


Content-Type: application/octet-stream;

name="CompanyApp?.pdf"

Content-Transfer-Encoding: base64 Content-Disposition: attachment;

filename="CompanyApp?.pdf"

Attachments (0)

Change History (7)

comment:1 Changed 9 years ago by szybalski@…

I'm trying to upload a file but it keeps telling me " No file uploaded"

comment:2 Changed 9 years ago by bas

  • Status changed from new to assigned

can you try it with you email address filled in the Author field? and then choose a file

comment:3 Changed 9 years ago by bas

I just tried you email.log file, but there is nothing in the pdf, but the two files are created properly with proper names:

 [mailto:"xxx%40example.com?Subject=Re%3A%20%23274%3A%20No%20Subject&cc="
 Reply to: xxx@example.com]'''To:''' underwriting@myserver.com,
  info@myserver.com
 '''Cc:''' xxx@example.com

 [attachment:"untitled-part.html"]

 [attachment:"CompanyApp.pdf"]

Which email2trac version do you use?

comment:4 Changed 9 years ago by szybalski@…

Debian Old Stable email2trac Version: 1.6.0-4

We have about 679,023 tickets since we started. We are planning on upgrading to newer version "debian stable" which I guess has a new package name "trac-email2trac"? It will be some time before we upgrade so I was hoping to identify what is the problem with this and either patch the code myself if its few lines, or notify the 3rd party to send correct encoding if we know that is where the problem is at.

[DEFAULT]
project: /xxx
debug: 0
umask: 022
spam_level: 5
reply_all : 0
mailto_link: 0
umask: 022
email_header: 0
trac_version: 0.11
enable_syslog : 1
alternate_notify_template :
alternate_notify_template_update :
drop_spam : 0
verbatim_format: 1
strip_signature: 0
email_quote: >
strip_quotes: 0
ignore_trac_user_settings: 0
black_list: MAILER-DAEMON@
drop_alternative_html_version: 1

Thanks Lucas

comment:5 Changed 9 years ago by bas

  • Version changed from 2.6.2 to 1.6.0

Lucas,

That are a lot of tickets!

A lot has been changed. The current version is 2.6.2 and i just tested it on debian squeeze and trac 0,12. You could download the source and build the package. There is a debian setup delivered with it. The debian setup is for postfix. If use other setup adjust it to your needs.

Just be sure to save the old email2trac debian package. I usually set-up a test enviroment in /usr/local:

  • ./configure; make install

And put the config:

  • /usr/local/etc

Now setup an test email address that uses the new binary.

comment:6 Changed 9 years ago by szybalski@…

Thank you. Before I did all that I've upgraded our production server to latest "stable" version in Debian over the weekend. This has resolved my problem and we are back in business. :) Thank you for all the work on this plugin. Its amazing and we are starting to use it more and more. 699,691 tickets in trac and going strong.

You can close this ticket.Version: 1.6.0-4 fixed the issue.

aptitude show email2trac

Package: email2trac New: yes State: installed Automatically installed: no Version: 1.6.0-4 Priority: optional Section: misc Maintainer: Bas van der Vlies <bas@…> Uncompressed Size: 180 k Depends: python, cdbs Description: Converts email to a trac ticket

Name says it All

comment:7 Changed 9 years ago by bas

  • Resolution set to fixed
  • Status changed from assigned to closed

Your welcome. I will close the ticket

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.