Modify

Opened 8 years ago

Closed 7 years ago

#316 closed setup (fixed)

error: option --project not recognized

Reported by: Vagelis Antoniadis <vanton@…> Owned by: bas
Priority: major Milestone:
Component: email2trac Version: 2.6.2
Keywords: Cc:

Description (last modified by bas)

Hi,

I am trying to use email2trac using your instructions for postfix from here: https://oss.trac.surfsara.nl/email2trac/wiki/Email2tracMta

The problem is that email2trac returns "error: option --project not recognized" and the ticket is not created. In addition, email fails and returns back to the sender with the output of email2trac.

I use the latest version and python 2.7.3

Any ideas?

Attachments (1)

output.txt (10.0 KB) - added by Vagelis Antoniadis <vanton@…> 8 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 8 years ago by bas

  • Status changed from new to assigned
  • Type changed from defect to setup

First question: How did you install email2trac?

Did you do a test on the command line without run_email2trac. There is a test message included in the source tarball:

  • email2trac -n -d --project <name_of_project> < msg.txt

This is a dry-run and some debug will appear in the console.

comment:2 Changed 8 years ago by Vagelis Antoniadis <vanton@…>

Thank you for your support. I found the problem. It was a conflict with TracPrivateTickets? plugin. Now my problem is that it creates the ticket but returns an email back that the email has failed with message : "Command died with status 1: "/usr/local/bin/email2trac --project=smsp --ticket_prefix=t-support"

I would appreciate your help.

comment:3 Changed 8 years ago by bas

Today is my day off. We have a new King in Holland ;-). But first of all in need some info why it crashes. Maybe there is something in your syslog or another file (trac.log). Without any info i can not find why it crashes.

Changed 8 years ago by Vagelis Antoniadis <vanton@…>

comment:4 Changed 8 years ago by Vagelis Antoniadis <vanton@…>

Enjoy your day off and I appreciate your prompt reply :-) I think I found the problem but not the solution yet. We use agilo for trac and it fails to create a ticket as you can see at the attached file I send. This is the output when I run email2trac with a modified version of the msg.txt as input. If you have any idea it is welcome. It is not so urgent though, we can discuss it after your King's coronation :-)

Thank you.

comment:5 Changed 8 years ago by anonymous

thanks. Last email for today. See ticket #305 for Agilo patch ;-)

comment:6 Changed 8 years ago by bas

Did you applied the patch? I can make an option for it so it will work for Agilo environments

comment:8 Changed 8 years ago by bas.vandervlies@…

thanks for reporting. I just fixed it ;-)

On 1 mei 2013, at 15:47, Vagelis Antoniadis <vanton@cytech.gr> wrote:


---
As of 1 January 2013, SARA has a new name: SURFsara.

Bas van der Vlies
| Operations, Support & Development | SURFsara | Science Park 140 | 1098 XG
Amsterdam
| T +31 (0) 20 592 30 00 | bas.vandervlies@surfsara.nl | www.surfsara.nl |

comment:9 Changed 7 years ago by bas

  • Description modified (diff)

can you test trunk version i have added support for agilo [622]

comment:10 Changed 7 years ago by bas

  • Resolution set to fixed
  • Status changed from assigned to closed

In 624:

addede -A/--agilo to the option help, closes #305,#316

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.