Modify

Opened 14 years ago

Closed 13 years ago

Last modified 13 years ago

#4 closed defect (fixed)

email sent to multiple recipients

Reported by: anonymous Owned by: bas
Priority: critical Milestone:
Component: email2trac Version: 0.9.5
Keywords: Cc: eric@…

Description

tickets created in trac get sent to user@… UNKNOWN@… and lastname@… bounces created by UNKNOWN@… cause a recursive ticket creation loop I don't know how to stop it but so far my 12 tickets have amounted to 50 I have turned off the mailserver to prevent anymore incoming tickets.

https://subtrac.sara.nl/oss/email2trac/changeset/61

Attachments (0)

Change History (8)

comment:1 Changed 14 years ago by anonymous

  • Cc eric@… added

comment:2 Changed 14 years ago by eric@…

to reproduce trac.ini may need

always_notify_owner = true

comment:3 Changed 14 years ago by eric@…

it doesn't seem logical to set the owner of an new ticket maybe there should be a setting in the conf file for default_assign_to for those who want an Assigned to: UNKNOWN on new tickets

I would prefer no one be assigned on new tickets.

comment:4 Changed 14 years ago by bas

  • Status changed from new to assigned

Michel Jouvin one of the developers have implemented a blacklist feature. It is not documented yet and is must be an option in the email2trac.conf.

     def blacklisted_from(self):
 	                FROM_RE = re.compile(r"""
 	                    MAILER-DAEMON@
 	                    """, re.VERBOSE)
 	                result =  FROM_RE.search(self.email_addr)
 	                if result:
 	                        return True
 	                else:
 	                        return False

So it can be adjusted by the user.

The owner is of a ticket is set to the default owner specified in trac.ini:

[ticket]
default_owner = unknown

No need to adjust the source, We have extend the blacklist to include unknown@<addr>. This is only triggered if notify_owner is set to true in trac.ini.

comment:5 Changed 14 years ago by anonymous

That sounds like a neet solution, However instead of 'just filling in bogus info' I changed the line 'ticketowner? = "UNKNOWN"' to 'pass' and this way there is no default null assignee which is not something I want a default on anyhow .

comment:6 Changed 14 years ago by bas

oke, this solution will not be implemented in the source, because it can also be specified in the trac.ini file

comment:7 Changed 14 years ago by anonymous

This is not right. The blacklist should include the address that the email comes in from. I use a special address bugs@… and this can not be added to the blacklist. If you are going to call it a blacklist there should be a file with a list of addresses that I can block.

comment:8 Changed 13 years ago by bas

  • Resolution set to fixed
  • Status changed from assigned to closed

Your are right i set owner of ticket to the default component owner. The function set_owner is removed from the trunk version. Because the code is also in trac API and does a better job

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.