Modify

Opened 13 years ago

Closed 13 years ago

#69 closed defect (fixed)

Mail Loop in Email To Trac

Reported by: anonymous Owned by: bas
Priority: critical Milestone:
Component: email2trac Version: 0.3
Keywords: Cc: gmcgrath@…

Description

I have been using email to trac for awhile and I recently got bit by a nasty mail loop. The problem was that a user CCed to the bug list instead of sending it in the To: field. When the script generated a mail upon ticket creation it sent it to bugs again causing the loop consuming massive amounts of disk before it could be killed.

email2trac should be checking that the trac.ini:smtp_from is not a destination address. I added this address to the blacklist function and the loop is gone.

Attachments (0)

Change History (7)

comment:1 Changed 13 years ago by bas

  • Status changed from new to assigned

\That is a good suggestion. which settings did you set in trac.ini or email2trac.conf. Because CC-addresses mostly do not get notifications.

comment:2 Changed 13 years ago by gmcgrath@…

  • Priority changed from major to critical

I just got bit by this on our general portal system, I'm using the trunk release (needed to be able to reactivate dead tickets). This issue pretty much crippled our server however, our trac DB was pumped up to 19 GB before we could stop the issue and our mail logs and other mail related files are equally huge due to this. If you've implemented a way to keep this from happening it would certainly be helpful.

comment:3 Changed 13 years ago by bas

  • Cc gmcgrath@… added

I don't think this feature cause the problem. It has to do that mail bounces. What kind of notification settings do you have and what kind of mail is in the ticket? You can black_list some senders, see https://subtrac.sara.nl/oss/email2trac/wiki/Email2tracConfiguration

comment:4 Changed 13 years ago by Garrett McGrath

I agree that it's a pile of different things that cause the problem,
but
the problem is being created by a loop generated from notifications
being sent out and them returning to the system.  Specifically in our
case the user CC'd our help address so every notification that went
out
emailed the help account again, generating more tickets going out and
coming back.  We plan to black list the help email address but we'd
like
to edit it out of any non 'To' fields to prevent anything like this
from
generating un necessary traffic in the future.
-Garrett

email2trac wrote:
> #69: Mail Loop in Email To Trac
> ----------------------+---------------------------------------------
--------
> Reporter:  anonymous  |        Owner:  bas
>     Type:  defect     |       Status:  assigned
> Priority:  critical   |    Component:  email2trac
>  Version:  0.30       |   Resolution:
> Keywords:             |
> ----------------------+---------------------------------------------
--------
> Changes (by bas):
>
>  * cc: gmcgrath@princeton.edu (added)
>
> Comment:
>
>  I don't think this feature cause the problem. It has to do that
mail
>  bounces. What kind of notification settings do you have and what
kind of
>  mail is in the ticket? You can black_list some senders, see
>  https://subtrac.sara.nl/oss/email2trac/wiki/Email2tracConfiguration
>
>

comment:5 Changed 13 years ago by gmcgrath@…

Is it possible to use black_list to match patterns (for instance to block all of a domains email?)

comment:6 Changed 13 years ago by anonymous

It is a regular expression and it searches for match. So you can block a domain:

  • sara.nl

code snippet email2trac:

FROM_RE = re.compile(entry, re.VERBOSE|re.IGNORECASE)
result =  FROM_RE.search(self.email_addr)

comment:7 Changed 13 years ago by bas

  • Resolution set to fixed
  • Status changed from assigned to closed

case

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.