Modify

Opened 13 years ago

Closed 13 years ago

#81 closed defect (fixed)

email2trac chokes if debug is on and From header has non-ASCII characters

Reported by: jsoderba@… Owned by: bas
Priority: major Milestone:
Component: email2trac Version: 0.3
Keywords: Cc:

Description

I sent a test mail with Mozilla Thunderbird with the sender set to "Jan Söderback <jsoderba@…>" in UTF-8. The server is CentOS 5.2 with Postfix 2.3.3 and trac 0.10.4

Raw mail header:

From: =?UTF-8?B?SmFuIFPDtmRlcmJhY2s=?= <jsoderba@llsdata.fi>

From syslog:

Sep  2 13:28:28 alfa email2trac: Traceback (most recent call last):
Sep  2 13:28:28 alfa email2trac:   File "/usr/local/bin/email2trac", line 1227, in ?     tktparser.parse(sys.stdin)
Sep  2 13:28:28 alfa email2trac:   File "/usr/local/bin/email2trac", line 807, in parse     self.new_ticket(m, spam_msg)
Sep  2 13:28:28 alfa email2trac:   File "/usr/local/bin/email2trac", line 683, in new_ticket     self.set_ticket_fields(tkt)
Sep  2 13:28:28 alfa email2trac:   File "/usr/local/bin/email2trac", line 665, in set_ticket_fields     print u'user_dict[%s] = %s' %(name, value)
Sep  2 13:28:28 alfa email2trac: UnicodeEncodeError: 'ascii' codec can't encode character u'\xe4' in position 35: ordinal not in range(128)

If debug is 0 everything works as expected.

Attachments (0)

Change History (4)

comment:1 Changed 13 years ago by anonymous

  • Owner changed from bas to anonymous
  • Status changed from new to assigned

which version of email2trac do you use? I am trying to reproduce it. My version of email2trac uses a different statement:

                        if self.DEBUG:
                                print 'user_dict[%s] = %s' %(name, value)

without the u'...'

comment:2 Changed 13 years ago by bas

  • Owner changed from anonymous to bas
  • Status changed from assigned to new

comment:3 Changed 13 years ago by bas

  • Status changed from new to assigned

comment:4 Changed 13 years ago by bas

  • Resolution set to fixed
  • Status changed from assigned to closed

Could not reproduce this error with trunk version

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.