Modify

Opened 13 years ago

Closed 11 years ago

Last modified 11 years ago

#84 closed defect (fixed)

New Tickets are created with resolution :fixed

Reported by: hju@… Owned by: bas
Priority: major Milestone:
Component: email2trac Version: 1.6.0
Keywords: Cc: mor@…

Description

Hope this is no RTFM problem, but I found nothing in the doku and have no more ideas where to look at.

email2trac is installed an working properly. The only problem is that new tickets are showing the resolution :fixed

example:Ticket #22 (new Fehler: fixed)

There is no default_value for this nor did I find a place to define / delete it.

Only workaround is to use del_resolution in the TicketWorkflow

trac.ini

[ticket]
default_component = nicht zugeordnet
default_milestone = 
default_priority = normal
default_severity = Mittel
default_type = 
default_version = 
restrict_owner = true
workflow = ConfigurableTicketWorkflow,TicketWorkflowOpOwnerReporter,TicketWorkflowOpOwnerPrevious,TicketWorkflowOpXRef

email2trac.conf

[DEFAULT]
project: /home/trac/ticket
debug: 0
umask: 022
spam_level: 5
reply_all : 0
mailto_link: 1
umask: 022
email_header: 0
trac_version: 0.11
enable_syslog: 1
alternate_notify_template:
drop_spam: 0
verbatim_format: 0
strip_signature: 1
email_quote: >
strip_quotes: 0
ignore_trac_user_settings: 0
ticket_update: 1
blacklist: MAILER-DAEMON@

[ticket]
project: /home/trac/ticket

Attachments (0)

Change History (17)

comment:1 follow-up: Changed 13 years ago by anonymous

  • Owner changed from bas to anonymous
  • Status changed from new to assigned

Can you check in the admin tab:

  • admin/ticket/resolution

which values are defined and which is the default.

You can set in email2trac.conf a default value for resolution, eg (Email2tracConfiguration#Defaultvaluesforticketfields)

default_resolution : new

depends on which values are allowed for resolutions. Maybe you have only one item in the resolution. Just a thought.

comment:2 Changed 13 years ago by bas

  • Owner changed from anonymous to bas
  • Status changed from assigned to new

comment:3 in reply to: ↑ 1 Changed 13 years ago by hju@…

Replying to anonymous:

Can you check in the admin tab:

  • admin/ticket/resolution

which values are defined and which is the default.

You can set in email2trac.conf a default value for resolution, eg (Email2tracConfiguration#Defaultvaluesforticketfields)

default_resolution : new

depends on which values are allowed for resolutions. Maybe you have only one item in the resolution. Just a thought.

well, thanks so long for this hint. The 'default resolution' in the Admin section is ideed set to fixed (And there ist no way to remove it - one of the resolutions stays as default).

But normaly this means nothing to new (created) tickets!

The default_resolution: in emai2trac.conf works to change to another resolution defined. I found no way to 'clear' the resolution using this config.

Though this is still not the expected behaviour (for me). I won't have ANY resolution set for a new ticket (as it is if you create an new ticket via trac).

I still think it is a bug.

comment:4 Changed 13 years ago by bas

  • Status changed from new to assigned

a bug in in email2trac or trac? email2trac just reads the defaut values form trac. In my trac environments have no defaults for resolution. SO it wil behave like the web-enviroment tickets submission. Some people what default setting for new tickets

comment:5 Changed 13 years ago by anonymous

In my opinion it is a bug in email2trac because email2trac behaves different from ticket-creation in the web-environment.

In the web-environment the resolution is only set via workflow.operation set_resolution. There is no resolution set fo a new ticket!

I'm using trac 0.11.

comment:6 Changed 13 years ago by bas

I just did some research and we at SARA we use the trunk version. In the trunk version the resolution field is skipped for default values ;-)

comment:7 Changed 13 years ago by anonymous

OK now we have the reason for the different behaviour.

When do you think, the next release will be published?

Or can you post the patch instead?

thx

comment:8 Changed 13 years ago by hju@…

Or can you post the patch instead?

found it in email2trac.py.in

r212   r218
 	654	 
 	655	                        # skip some fields like resolution 
 	656	                        # 
 	657	                        if name in [ 'resolution' ]: 
 	658	                                continue 

comment:9 Changed 13 years ago by bas

That is the patch ;-)

comment:10 Changed 13 years ago by hju@…

  • Resolution set to worksforme
  • Status changed from assigned to closed

As the bug is already fixed in the trunk version I'set this ticket to 'worksforme'.

We have installed the patch by updating to the trunk-version

comment:11 Changed 11 years ago by hju@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened
  • Version changed from 0.3 to 1.4.6

This bug is back again!

The patch is missing since version 1.4.6 - causing new tickets beeing created with resolution:fixed again.

(same procedure as last year ;-))

comment:12 Changed 11 years ago by bas

There was also a request to set this field, see #195. so we have to come with another solution

comment:13 Changed 11 years ago by bas

The problems is trac version 0.11 self. The default value for resolution is:

    default_resolution = Option('ticket', 'default_resolution', 'fixed',
        """Default resolution for resolving (closing) tickets
        (''since 0.11'').""")

That is why we get fixed back even if have nothing set in trac.ini. I will skip it for trac default values so we still can set in email2trac.conf

comment:14 Changed 11 years ago by bas

(In [472]) email2trac.py.in:

  • the default trac value for resolution is fixed ;-). This a 'temporarly patch' to disable this. You can override the behaviour in email2trac.conf, see #84

comment:15 follow-up: Changed 11 years ago by bas

  • Resolution set to fixed
  • Status changed from reopened to closed
  • Version changed from 1.4.6 to 1.6.0

fix is in 1.6.0

comment:16 in reply to: ↑ 15 Changed 11 years ago by anonymous

Replying to bas:

fix is in 1.6.0

I had specified ''default_resolution: None'' in ''email2trac.conf'' and still had the property ''resolution: fixed'' set for all new tickets created with email2trac (latest version).

Obviously, "None" is not an allowed value here.

comment:17 Changed 11 years ago by bas

Just back from vacation. what happens if you do not specify and value in email2trac.conf.

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.