Modify

Opened 13 years ago

Closed 11 years ago

Last modified 11 years ago

#86 closed enhancement (fixed)

Disable notificatiosn to reporter on a per-project basis

Reported by: saranl@… Owned by: bas
Priority: major Milestone:
Component: email2trac Version: 0.3
Keywords: Cc:

Description

I'd like to route some automatically generated emails (like a status report) to generate a ticket as usual but NOT have any notifications sent to the 'reporter' address when the ticket is created or updated (in fact ever).

Maybe there could be an option for this I could add to the project options in email2trac.conf - it's easy enough to route these mails to a particular address and have the project name set on the command line.

Attachments (0)

Change History (11)

comment:1 Changed 13 years ago by bas

  • Status changed from new to assigned

If i read it correctly you want an option to disable notifications for certain email addresses. This option can be added easily.

comment:2 Changed 13 years ago by hju@…

As I get your point it is more a question of the Notification module as you want to exclude special reporters from always_notify_reporter = true.

Perhaps you find a solution for your problem here: http://trac-hacks.org/wiki/AnnouncerPlugin

comment:3 follow-up: Changed 13 years ago by bas

Thanks for the suggestion. The problem is that email2trac knows nothing about which plugins are installed. And the announce plugin does not replace the notify function that is used in email2trac. Maybe we must add an option of find out that that the announcerplugin is installed and then use announcer entry function instead of the trac notify function:

The easiest implemtation for now is to setup other email address to the same project data notification : off set_:

  • no_notify_email2trac@…

[email2trac] notification : off

comment:4 in reply to: ↑ 3 Changed 13 years ago by hju@…

Replying to bas:

Maybe we must add an option of find out that that the announcerplugin is installed and then use announcer entry function instead of the trac notify function:

I think, this will not help. There are so many Plugins (written an not yet written) which should be checked. (i.e. http://www.trac-hacks.org/wiki/FlexibleReporterNotificationPlugin).

In my opinion it would be the best to focus on the basic classes and use options to enable or disable this features

comment:5 Changed 13 years ago by bas

oke i will make a option to disable notification

comment:6 Changed 11 years ago by bas

There are some fixes in newer versions of email2trac. There was an fix that prevented other notifications plugins to be enabled. I tested the announcerplugin and everythong worked as expected. So i think there is no need for this option.

comment:7 Changed 11 years ago by hju@…

didn't remember this ticket. I've implemented a little patch (look at #229) which is directly inserted in the trac.notification system i've overridden in #178.

With a little improvement of this patch (filtering the recipients) you may eliminate selected email-adresses from the notification-process.

If yout don't want to notify reporters or updaters at all I agree with bas to use the trac-plugins.

comment:8 Changed 11 years ago by bas

  • Resolution set to fixed
  • Status changed from assigned to closed

thanks. i will close this ticket

comment:9 Changed 11 years ago by anonymous

Last edited 11 years ago by bas (previous) (diff)

comment:10 Changed 11 years ago by anonymous

Last edited 11 years ago by bas (previous) (diff)

comment:11 Changed 11 years ago by anonymous

Last edited 11 years ago by bas (previous) (diff)

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.