Last change
on this file since 980 was
507,
checked in by bastiaans, 15 years ago
|
Dave Love's SGE code patches, see below:
Mon Dec 10 15:46:45 GMT 2007 Dave Love <fx@…>
Fri Dec 7 10:57:55 GMT 2007 Dave Love <fx@…>
- Add note about SGE tasks to overview template.
Fri Nov 9 15:39:41 GMT 2007 Dave Love <fx@…>
- Replace previous SGE implementation with a different one.
This provides the full set of monarch data.
There's some associated restructuring involving the PBS code.
Fri Nov 9 15:27:01 GMT 2007 Dave Love <fx@…>
- jobmond.conf comment fix.
Fri Nov 9 15:21:25 GMT 2007 Dave Love <fx@…>
- Somewhat modify RPM spec files.
Wed Nov 7 17:49:37 GMT 2007 Dave Love <fx@…>
- Modify jobmond for use with SGE.
|
File size:
1.2 KB
|
Line | |
---|
1 | Buildroot: |
---|
2 | Name: jobmonarch-jobarchived |
---|
3 | Version: |
---|
4 | Release: |
---|
5 | Summary: Job Archiving Daemon |
---|
6 | License: GPL |
---|
7 | Distribution: Fedora |
---|
8 | Group: Applications/System |
---|
9 | |
---|
10 | %define _rpmdir ../ |
---|
11 | %define _rpmfilename %%{NAME}-%%{VERSION}-%%{RELEASE}.rpm |
---|
12 | %define _unpackaged_files_terminate_build 0 |
---|
13 | |
---|
14 | %post |
---|
15 | #!/bin/sh |
---|
16 | |
---|
17 | PATH=/bin:/sbin:/usr/bin:/usr/sbin |
---|
18 | |
---|
19 | if [ -x /etc/init.d/jobarchived ] |
---|
20 | then |
---|
21 | |
---|
22 | chkconfig --add jobarchived |
---|
23 | chkconfig jobarchived on |
---|
24 | |
---|
25 | fi |
---|
26 | |
---|
27 | echo "" |
---|
28 | echo "Additional manual changes are required to setup jobarchived:" |
---|
29 | echo "" |
---|
30 | echo "1) Edit /etc/jobarchived.conf to reflect your local settings and setup:" |
---|
31 | echo " - ARCHIVE_DATASOURCES and ARCHIVE_PATH" |
---|
32 | echo "" |
---|
33 | echo "2) Create a 'jobarchive' database and create jobarchived's tables:" |
---|
34 | echo " - createdb jobarchive" |
---|
35 | echo " - psql -f /usr/share/jobarchived/job_dbase.sql jobarchive" |
---|
36 | echo "" |
---|
37 | |
---|
38 | |
---|
39 | %preun |
---|
40 | #!/bin/sh |
---|
41 | |
---|
42 | /etc/init.d/jobarchived stop |
---|
43 | chkconfig jobarchived off |
---|
44 | chkconfig --del jobarchived |
---|
45 | |
---|
46 | |
---|
47 | %description |
---|
48 | |
---|
49 | |
---|
50 | Job MonArch's archive daemon |
---|
51 | |
---|
52 | %files |
---|
53 | "/usr/sbin/jobarchived.py" |
---|
54 | "/usr/sbin/jobarchived" |
---|
55 | "/etc/init.d/jobarchived" |
---|
56 | %config "/etc/jobarchived.conf" |
---|
57 | %config "/etc/sysconfig/jobarchived" |
---|
58 | %dir "/usr/share/jobarchived/" |
---|
59 | "/usr/share/jobarchived/job_dbase.sql" |
---|
Note: See
TracBrowser
for help on using the repository browser.