source: branches/1.0/debian/jobmonarch-jobarchived.postinst @ 892

Last change on this file since 892 was 872, checked in by olahaye, 11 years ago

[debian packaging: jobmonarch-jobmond.postinst & jobmonarch-jobarchived.postinst] Add logic to prevent useless messages to appear during upgrade.

  • Property svn:executable set to *
File size: 1.2 KB
Line 
1#!/bin/sh
2
3PATH=/bin:/sbin:/usr/bin:/usr/sbin
4
5set -e
6
7case "$1" in
8    configure)
9        # Only on install (not during upgrade)
10
11        if [ -x /etc/init.d/jobarchived ]
12        then
13            update-rc.d -f jobarchived defaults
14        fi
15
16        echo ""
17        echo "Additional manual changes are required to setup jobarchived:"
18        echo ""
19        echo "1) Edit /etc/jobarchived.conf to reflect your local settings and setup:"
20        echo "   - ARCHIVE_DATASOURCES and ARCHIVE_PATH"
21        echo ""
22        echo "2) Create a 'jobarchive' database and create jobarchived's tables:" 
23        echo "   - createdb jobarchive"
24        echo "   - psql -f /usr/share/jobarchived/job_dbase.sql jobarchive"
25        echo "   - Update /var/lib/pgsql/data/pg_hba.conf by adding the following lines:"
26        echo "     local   jobarchive      jobarchive                              trust"
27        echo "     host    jobarchive      jobarchive      127.0.0.1/32            trust"
28        echo "     host    jobarchive      jobarchive      ::1/128                 trust"
29        echo "   - Restart the postgresql service"
30        echo ""
31
32        ;;
33    *)
34        ;;
35esac
36
37exit 0
38
39
Note: See TracBrowser for help on using the repository browser.