source: branches/1.0/debian/jobmonarch-jobmond.postinst @ 891

Last change on this file since 891 was 891, checked in by olahaye, 8 years ago

[deb packaging] fixed pbs-python requirement in postinst message. (python-pbs has nothing to do with the interface between torque and python)

  • Property svn:executable set to *
File size: 832 bytes
Line 
1#!/bin/sh
2
3PATH=/bin:/sbin:/usr/bin:/usr/sbin
4
5set -e
6
7case "$1" in
8    configure)
9        # Only on install (not during upgrade)
10
11        if [ -x /etc/init.d/jobmond ]
12        then
13            update-rc.d -f jobmond defaults
14        fi
15
16        echo ""
17        echo "Additional manual changes are required to setup jobmond:"
18        echo ""
19        echo "1) Edit /etc/jobmond.conf to reflect your local settings and setup:"
20        echo "   - BATCH_API: pbs, slurm, sge (experimental), lsf (experimental)"
21        echo "2) Install the python interface to the selected batch queuing system"
22        echo "   - pbs-python (for pbs or torque)"
23        echo "   - python-pyslurm (for slurm)"
24        echo "   - pythongrid (for sge)"
25        echo "   - python-pylsf (for lsf)"
26        echo ""
27
28        ;;
29    *)
30        ;;
31esac
32
33exit 0
Note: See TracBrowser for help on using the repository browser.