Last change
on this file since 871 was
871,
checked in by olahaye, 10 years ago
|
[debian packaging:jobmonarch.postinst] Add logic to generate a random password and set it up in web interface, jobarchived.conf and job_dbase.sql at install time.
|
-
Property svn:executable set to
*
|
File size:
914 bytes
|
Line | |
---|
1 | #!/bin/sh |
---|
2 | |
---|
3 | PATH=/bin:/sbin:/usr/bin:/usr/sbin |
---|
4 | |
---|
5 | set -e |
---|
6 | |
---|
7 | case "$1" in |
---|
8 | configure) |
---|
9 | # Only on install (not during upgrade) |
---|
10 | echo "Generating random password and updating apropriate files" |
---|
11 | # Generate a 8 char password for the database: |
---|
12 | export DB_PASSWD=$(tr -dc A-Za-z0-9_< /dev/urandom |head -c 8 | xargs) |
---|
13 | # Set the password in the SQL script |
---|
14 | sed -i -e '/^.*modify me:.*$/d' -e 's/^-- CREATE/CREATE/g' -e "s/'';/'$DB_PASSWD';/g" %{_datadir}/jobarchived/job_dbase.sql |
---|
15 | # Set the password in the jobarchived config. |
---|
16 | sed -i -e "s/^#JOB_SQL_PASSWORD.*$/JOB_SQL_PASSWORD\t\t: $DB_PASSWD/g" %{_sysconfdir}/jobarchived.conf |
---|
17 | # Set the password in the ganglia conf.php |
---|
18 | sed -i -e "s|^//\$JOB_ARCHIVE_SQL_PASSWORD.*|\$JOB_ARCHIVE_SQL_PASSWORD = \"$DB_PASSWD\"|g" %{gangliaaddonsdir}/job_monarch/conf.php |
---|
19 | ;; |
---|
20 | *) |
---|
21 | ;; |
---|
22 | esac |
---|
23 | |
---|
24 | exit 0 |
---|
Note: See
TracBrowser
for help on using the repository browser.