source: branches/1.0/debian/rules

Last change on this file was 919, checked in by ramonb, 11 years ago

Makefile:

  • removed install of Debian init.d, default file
  • first install .conf files and make sure DESTDIR/etc exists

debian/rules:

  • set DESTDIR as variable for all other dh_ calls
  • no longer need to override dh_install

pkg/deb/default/jobmond -> debian/jobmonarch-jobmond.default : moved
pkg/deb/init.d/jobmond -> debian/jobmonarch-jobmond.init : moved
pkg/deb/default/jobarchived -> debian/jobmonarch-jobarchived.default : moved
pkg/deb/init.d/jobarchived -> debian/jobmonarch-jobarchived.init : moved

  • Property svn:executable set to *
File size: 299 bytes
RevLine 
[846]1#!/usr/bin/make -f
2
[919]3BUILDDIR := debian/tmp
4DESTDIR := ${CURDIR}/${BUILDDIR}
5
[846]6%:
[848]7        dh $@ --with python2
[846]8
9override_dh_auto_install:
[919]10        $(MAKE) DESTDIR=$(DESTDIR)/ PREFIX=/usr GANGLIA_ROOT=/usr/share/ganglia-webfrontend GANGLIA_USER=ganglia HTTPD_USER=www-data JOBARCHIVE_RRDS=/var/lib/jobarchive install
Note: See TracBrowser for help on using the repository browser.