source: branches/1.1/debian/jobmonarch-jobarchived.postinst @ 942

Last change on this file since 942 was 937, checked in by ramonb, 11 years ago

debian:

  • corrected old init.d script names to new names

CHANGELOG:

  • updated
  • Property svn:executable set to *
File size: 1.1 KB
Line 
1#!/bin/sh
2
3PATH=/bin:/sbin:/usr/bin:/usr/sbin
4
5set -e
6
7if [ -z "$2" ]
8then
9    # Only on install (not during upgrade)
10
11    if [ -x /etc/init.d/jobmonarch-jobarchived ]
12    then
13        update-rc.d -f jobmonarch-jobarchived defaults
14    fi
15
16    echo ""
17    echo "Additional manual changes are required to setup jobarchived:"
18    echo ""
19    echo "1) Edit /etc/jobarchived.conf to reflect your local settings and setup:"
20    echo "   - ARCHIVE_DATASOURCES and ARCHIVE_PATH"
21    echo ""
22    echo "2) Create a 'jobarchive' database and create jobarchived's tables:" 
23    echo "   - createdb jobarchive"
24    echo "   - psql -f /usr/share/jobarchived/job_dbase.sql jobarchive"
25    echo "   - Update /var/lib/pgsql/data/pg_hba.conf by adding the following lines:"
26    echo "     local   jobarchive      jobarchive                              trust"
27    echo "     host    jobarchive      jobarchive      127.0.0.1/32            trust"
28    echo "     host    jobarchive      jobarchive      ::1/128                 trust"
29    echo "   - Restart the postgresql service"
30    echo ""
31else
32    # This is a upgrade
33    :
34fi
35
36exit 0
37
38
Note: See TracBrowser for help on using the repository browser.