Last change
on this file since 928 was
896,
checked in by ramonb, 10 years ago
|
debian/control:
debian/*.postinst:
- (de)configure is actually called on upgrade
- changed upgrade logic to check if $2 is empty
debian/jobmonarch-webfrontend.prerm:
- only print warning upon removal
debian/jobmonarch-jobmond.prerm, debian/jobmonarch-jobarchived.prerm:
- only disable runlevel symlinks on removal
|
-
Property svn:executable set to
*
|
File size:
726 bytes
|
Line | |
---|
1 | #!/bin/sh |
---|
2 | |
---|
3 | PATH=/bin:/sbin:/usr/bin:/usr/sbin |
---|
4 | |
---|
5 | set -e |
---|
6 | |
---|
7 | if [ -z "$2" ] |
---|
8 | then |
---|
9 | # Only on install (not during upgrade) |
---|
10 | |
---|
11 | if [ -x /etc/init.d/jobmond ] |
---|
12 | then |
---|
13 | update-rc.d -f jobmond defaults |
---|
14 | fi |
---|
15 | |
---|
16 | echo "" |
---|
17 | echo "Additional manual changes are required to setup jobmond:" |
---|
18 | echo "" |
---|
19 | echo "1) Edit /etc/jobmond.conf to reflect your local settings and setup:" |
---|
20 | echo " - BATCH_API: pbs, slurm, sge (experimental), lsf (experimental)" |
---|
21 | echo "2) Install the python interface to the selected batch queuing system" |
---|
22 | echo " - pbs-python (for pbs or torque)" |
---|
23 | echo " - python-pyslurm (for slurm)" |
---|
24 | echo " - python-pylsf (for lsf)" |
---|
25 | echo "" |
---|
26 | else |
---|
27 | # This is a upgrade |
---|
28 | : |
---|
29 | fi |
---|
30 | |
---|
31 | exit 0 |
---|
Note: See
TracBrowser
for help on using the repository browser.