Last change
on this file since 431 was
431,
checked in by bastiaans, 16 years ago
|
Makefile:
jobmond/jobmond.py:
- fix to pidfile arg parsing
- fix to native gmetric unit handling
pkg/rpm/init.d/jobmond:
- updated as a proper redhat based init script
pkg/rpm/jobmonarch-jobmond.spec:
- call chkconfig in preun not postun
|
File size:
746 bytes
|
Line | |
---|
1 | Buildroot: |
---|
2 | Name: jobmonarch-jobmond |
---|
3 | Version: |
---|
4 | Release: |
---|
5 | Summary: Job Monitoring Daemon |
---|
6 | License: see /usr/share/doc/jobmonarch-jobmond/copyright |
---|
7 | Distribution: Debian |
---|
8 | Group: Converted/misc |
---|
9 | |
---|
10 | %define _rpmdir ../ |
---|
11 | %define _rpmfilename %%{NAME}-%%{VERSION}-%%{RELEASE}.%%{ARCH}.rpm |
---|
12 | %define _unpackaged_files_terminate_build 0 |
---|
13 | |
---|
14 | %post |
---|
15 | #!/bin/sh |
---|
16 | |
---|
17 | PATH=/bin:/sbin:/usr/bin:/usr/sbin |
---|
18 | |
---|
19 | if [ -x /etc/init.d/jobmond ] && [ -x /usr/sbin/jobmond ] |
---|
20 | then |
---|
21 | |
---|
22 | chkconfig jobmond on |
---|
23 | |
---|
24 | fi |
---|
25 | |
---|
26 | /etc/init.d/jobmond restart |
---|
27 | |
---|
28 | |
---|
29 | %preun |
---|
30 | #!/bin/sh |
---|
31 | |
---|
32 | /etc/init.d/jobmond stop |
---|
33 | chkconfig jobmond off |
---|
34 | |
---|
35 | |
---|
36 | %description |
---|
37 | |
---|
38 | |
---|
39 | Job MonArch's monitoring daemon. |
---|
40 | |
---|
41 | %files |
---|
42 | "/etc/init.d/jobmond" |
---|
43 | %config "/etc/sysconfig/jobmond" |
---|
44 | "/usr/sbin/jobmond.py" |
---|
45 | "/usr/sbin/jobmond" |
---|
46 | %config "/etc/jobmond.conf" |
---|
Note: See
TracBrowser
for help on using the repository browser.