Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#17 closed defect (fixed)

Unhandled exception

Reported by: bastiaans Owned by: bastiaans
Priority: normal Milestone: 0.3
Component: jobarchived Version: 0.2
Keywords: Cc:
Estimated Number of Hours:

Description

Once in a while this error seems to come by.

Since the error is nicely cryptic it should be fun to debug where this exception is caused.

Unhandled exception in thread started by 

Change History (4)

comment:1 Changed 14 years ago by bastiaans

  • Owner changed from somebody to bastiaans
  • Status changed from new to assigned

it seems its a non-fatal exception which does not influence jobarchived's operation.

comment:2 Changed 14 years ago by bastiaans

Fri 08 Jun 2007 12:30:41 - ganglia_parse_thread(): started.
Fri 08 Jun 2007 12:30:41 - ganglia_parse_thread(): Parsing XML..
Fri 08 Jun 2007 12:30:46 - torque_xml_thread(): Parsing..
Fri 08 Jun 2007 12:30:48 - torque_xml_thread(): Storing..
Fri 08 Jun 2007 12:30:48 - torque_xml_thread(): Done storing.
Fri 08 Jun 2007 12:30:48 - torque_xml_thread(): Done parsing.
Fri 08 Jun 2007 12:30:48 - torque_xml_thread(): Sleeping.. (15s)
Fri 08 Jun 2007 12:30:54 - ganglia_store_thread(): Done sleeping.
Fri 08 Jun 2007 12:30:54 - ganglia_store_thread(): storemetricthread() still running, waiting to finish..
Fri 08 Jun 2007 12:30:56 - ganglia_xml_thread(): Done sleeping.
Fri 08 Jun 2007 12:30:56 - ganglia_xml_thread(): parsethread() still running, waiting (60s) to finish..
Fri 08 Jun 2007 12:31:03 - torque_xml_thread(): Parsing..
Fri 08 Jun 2007 12:31:11 - torque_xml_thread(): Storing..
Fri 08 Jun 2007 12:31:12 - torque_xml_thread(): Done storing.
Fri 08 Jun 2007 12:31:12 - torque_xml_thread(): Done parsing.
Fri 08 Jun 2007 12:31:12 - torque_xml_thread(): Sleeping.. (15s)
Fri 08 Jun 2007 12:31:15 - ganglia_parse_thread(): Done parsing.
Exception in thread parsethread:
Traceback (most recent call last):
  File "threading.py", line 442, in __bootstrap
    self.run()
  File "threading.py", line 422, in run
    self.__target(*self.__args, **self.__kwargs)
  File "./jobarchived.py", line 1128, in parseThread
    xml.sax.parseString( my_data, self.myXMLHandler, self.myXMLError )
  File "xml/sax/__init__.py", line 49, in parseString
  File "xml/sax/expatreader.py", line 107, in parse
  File "xml/sax/xmlreader.py", line 123, in parse
  File "xml/sax/expatreader.py", line 207, in feed
  File "xml/sax/expatreader.py", line 300, in start_element
  File "./jobarchived.py", line 807, in startElement
    self.clusters[ self.clusterName ].memMetric( self.hostName, myMetric )
KeyError: u'Matrix Cluster'

Fri 08 Jun 2007 12:31:15 - ganglia_parse_thread(): finished.
Fri 08 Jun 2007 12:31:15 - ganglia_xml_thread(): Done waiting.
Fri 08 Jun 2007 12:31:15 - ganglia_xml_thread(): finished.
Fri 08 Jun 2007 12:31:16 - ganglia_xml_thread(): started.
Fri 08 Jun 2007 12:31:16 - ganglia_xml_thread(): Sleeping.. (15s)
Fri 08 Jun 2007 12:31:16 - ganglia_parse_thread(): started.
Fri 08 Jun 2007 12:31:16 - ganglia_parse_thread(): Parsing XML..
Fri 08 Jun 2007 12:31:27 - torque_xml_thread(): Parsing..
Fri 08 Jun 2007 12:31:32 - ganglia_xml_thread(): Done sleeping.
Fri 08 Jun 2007 12:31:32 - ganglia_xml_thread(): parsethread() still running, waiting (60s) to finish..

comment:3 Changed 14 years ago by bastiaans

  • Milestone set to 0.2.1
  • Resolution set to fixed
  • Status changed from assigned to closed

this was caused by the fact that all xml input strings are uniencoded.

fixed in changeset r372, all xml strings are now converted to proper strings.

Note: See TracTickets for help on using tickets.