Opened 8 years ago

Closed 8 years ago

#170 closed defect (fixed)

jobarchived runs wild after Non-recoverable XML error

Reported by: jaap.dijkshoorn@… Owned by: ramonb
Priority: normal Milestone: 1.1.1
Component: jobarchived Version: 1.1
Keywords: Cc:
Estimated Number of Hours:

Description

Jun 7 08:48:20 xtrac jobarchived: FATAL ERROR: Non-recoverable XML error <unknown>:33565:0: unclosed token Jun 7 08:48:21 xtrac jobarchived: FATAL ERROR: Non-recoverable XML error <unknown>:33565:0: unclosed token

After this the pyhton process runs wild. It also seems like hitting a memory leak. Python used 20% of memeory at time of killing

Change History (5)

comment:1 Changed 8 years ago by ramonb

  • Component changed from general to jobarchived
  • Milestone changed from 1.2 to 1.1.1
  • Owner changed from somebody to ramonb
  • Status changed from new to assigned

comment:2 Changed 8 years ago by ramonb

it should exit if that occurs, but I think sys.exit does not work while the error class is passed to SAX

comment:3 Changed 8 years ago by ramonb

the memory leak is probably a side effect of the failed parsing

comment:4 Changed 8 years ago by ramonb

In 926:

jobarchived/jobarchived.py:

  • changed XMLErrorHandler so that fatal error's are remembered for later use
  • exit daemon if fatal XML error occurs
  • see #170

comment:5 Changed 8 years ago by ramonb

  • Resolution set to fixed
  • Status changed from assigned to closed

This is unfortunately very hard to test/reproduce since it is near impossible to (re)create XML error's in Ganglia's XML stream.

Nevertheless this should fix it.

Note: See TracTickets for help on using tickets.