Opened 13 years ago

Closed 12 years ago

#27 closed defect (wontfix)

OMSA + PERC4e/DC problem with latest kernels (>2.6.24.7)

Reported by: Peter Owned by:
Priority: critical Milestone:
Version: 5.5.0 Keywords: OMSA PERC4e/DC tried to access /dev/mem
Cc:

Description

It looks, that there's strange problem with latest kernel (tested on 2.6.28.3). The 'instsvcdrv' starts but when I try omreport storage controller - I see there my Perc5i controller but SCSI Perc4e/DC not :( In dmesg I can find lot of this " kernel: Program dsm_sa_datamgr3 tried to access /dev/mem between 8059000->805a000" with different address. I have found also this: http://lists.us.dell.com/pipermail/linux-poweredge/2008-September/037390.html but ipmi_si with parameters and disabling pnpacpi didn't help. Any idea? thnx much. Peter

Change History (4)

comment:1 follow-up: Changed 12 years ago by bas

Did not enecounter this problems. Just a question is the module mptctl loaded. else:

  • modprobe -v mptctl
  • /etc/init.d/dataeng restart

comment:2 in reply to: ↑ 1 Changed 12 years ago by anonymous

I have now it compiled in kernel, but also tested as module and it was the same. btw, /dev/mptctl exist..

Replying to bas:

Did not enecounter this problems. Just a question is the module mptctl loaded. else:

  • modprobe -v mptctl
  • /etc/init.d/dataeng restart

comment:3 Changed 12 years ago by Thomas

Same problem here with Perc 4e/Di (in Dell PowerEdge? 2850), Debian Lenny, OMSA works fully except storage, omreport cannot find controller. mptctl is loaded, no difference. On other machines with Debian Etch it works fine.

Presumably this is an incompatibility with the new kernel, can OMSA be updated for this? That would be better than having to wait for and then maintain a testing/unstable kernel with a fix and/or waiting for the next Debian major release (12-18 months?) - if the problem is fixed in that.

comment:4 Changed 12 years ago by bas

  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.