Opened 14 years ago

Closed 14 years ago

Last modified 13 years ago

#9 closed defect (fixed)

broken omsa 5.3 installer script for amd64

Reported by: kota Owned by: bas
Priority: major Milestone:
Version: 5.3.0 Keywords:
Cc:

Description

Hi,

I have PowerEdge? SC1430 with Ubuntu 6.06.2 LTS(AMD64) installed, and tried to install OMSA 5.3 amd64 package. But, at default, it didn't work. I noticed that the installer failed to create /etc/ld.so.conf.d/dellomsa.conf which indicates paths for OMSA, because there was no /etc/ld.so.conf.d/ directory. I made /etc/ld.so.conf.d/ and tried to install again, but it still doesn't work. Is there any workaround?

Below is the output of my installer(Sorry, it contains some Japanese).

# sudo apt-get install dellomsa

...

Checking that /etc/ld.so.conf.d/dell-omsa.conf contains required paths...
Adding to /etc/ld.so.conf.d/dell-omsa.conf: /opt/dell/srvadmin/dataeng/bin
Adding to /etc/ld.so.conf.d/dell-omsa.conf: /opt/dell/srvadmin/hapi/bin
Adding to /etc/ld.so.conf.d/dell-omsa.conf: /opt/dell/srvadmin/oma/bin
Adding to /etc/ld.so.conf.d/dell-omsa.conf: /opt/dell/srvadmin/omsa/bin
Adding to /etc/ld.so.conf.d/dell-omsa.conf: /opt/dell/srvadmin/shared/bin
Adding to /etc/ld.so.conf.d/dell-omsa.conf: /opt/dell/srvadmin/sm
Adding to /etc/ld.so.conf.d/dell-omsa.conf: /opt/dell/srvadmin/sm/dellvl
Stopping & Starting dellomsa...
Stopping Systems Management Device Drivers:
Starting Systems Management Device Drivers:
Starting ipmi driver:  *
invoke-rc.d: initscript instsvcdrv, action "start" failed.
dpkg: dellomsa の読み込みエラーです(--configure):
 サブプロセス post-installation script はエラー終了ステータス 1 を返しました。。
以下のパッケージの処理中にエラーが発生しました:
 dellomsa
E: Sub-process /usr/bin/dpkg returned an error code (1)

Change History (2)

comment:1 Changed 14 years ago by bas

  • Owner set to bas
  • Status changed from new to assigned

dellomsa is for debian etch and higher. Ubuntu 6.06.2 is equivalent with sarge which does not support the ld.so.conf.d directory setup. You must copy the dell-omsa.conf lines in ld.so.conf and rerun ldconfig.

If this fails put a exit in 'instsvcdrv' so the postinst script succeeded and you do not get dpkg error.

comment:2 Changed 14 years ago by kota

  • Resolution set to fixed
  • Status changed from assigned to closed

Thanks!

Just copying lines in dell-omsa.conf to ld.so.conf and ldconfig worked fine!

Note: See TracTickets for help on using tickets.