source: trunk/debian/changelog @ 237

Last change on this file since 237 was 237, checked in by bas, 14 years ago

New version 4.1.0:

  • see CHANGES file, closes #20
File size: 8.0 KB
Line 
1pbs-python (4.1.0-1) lenny; urgency=low
2
3  * See CHANGES file
4
5 -- bas van der Vlies <bas@sara.nl>  Thu, 29 Apr 2010 13:24:24 +0200
6
7pbs-python (4.0.2-1) lenny; urgency=low
8
9  * See CHANGES file
10
11 -- bas van der Vlies <bas@sara.nl>  Fri, 23 Apr 2010 10:27:58 +0200
12
13pbs-python (4.0.1-1) lenny; urgency=low
14
15  * See CHANGES file
16
17 -- bas van der Vlies <bas@sara.nl>  Wed, 21 Apr 2010 08:26:02 +0200
18
19pbs-python (4.0.0-1) lenny; urgency=low
20
21  * See CHANGES file
22
23 -- Bas van der Vlies <basv@sara.nl>  Fri, 09 Apr 2010 09:43:24 +0200
24
25pbs-python (3.6.0-1) lenny; urgency=low
26
27  * New generated files pbs_wrap.c and pbs.py fixes an error in pbs_runjob()
28
29 -- Bas van der Vlies <basv@sara.nl>  Fri, 15 Jan 2010 04:40:35 +0100
30
31pbs-python (3.5.0-1) lenny; urgency=low
32
33  * PBSQuery
34        The class functions of node, job and queue support old and new data
35        structure.
36
37    Changed the behaviour of the new data stucture, We can use it as
38    dictionary and as class attribute, this is equivalent, eg:
39      - print node['np'] and print node.np
40
41    for a node we parse the 'status' line and split on '=' char, You now can
42    use these statements, eg
43     - print node.status.arch     (node['status'].arch or node['status']['arch'])
44     - print node.status.nsession
45
46    for a job we parse the 'Variable_List' line and split on '=' char, You now can
47    use the statements, eg:
48     - print job.Variable_List.PBS_O_WORKDIR
49     - print job.Variable_List.PBS_O_HOME
50
51    for more info see examples/new_interface.py
52
53    Author: Bas van der Vlies
54
55  * new_rack_pbsmon.py
56    Rewrite to new data structure and automatically determine how many nodes
57    and racks cluster has and skip printing of empty racks (default), use -w/--wide
58    for old behaviour.
59
60    Author: Bas van der Vlies
61
62 -- Bas van der Vlies <bas@sara.nl>  Mon, 12 Nov 2009 15:03:16 +0200
63
64pbs-python (3.2.0-1) intrepid; urgency=low
65
66  *  PBSQuery:
67     New data structure. In the old structure it is a dictionary
68     with a value and the value is a string. This is changed that
69     dictionary values are now of type list or dictionary depends
70     on the value of keyword, eg for a node:
71       - np = 2:
72       - node['np'] = [ '2' ]
73       - properties = cores2, mem4gb, parallel
74       - node['properties'] = [ 'cores2', 'mem4gb', 'parallel' ]
75       - status = arch=x86_64,sessions=22599,,size=70627864kb, ...
76       - node['status']['arch'] = [ 'x86_64' ]
77       - node['status']['sessions'] = [ '222599' ]
78       - ...
79
80         The data structure is activated by the function:
81          - new_data_structure()
82
83         In a future release it will be come the default.
84         example:
85         p = PBSQuery()
86         p.new_data_structure()
87
88        nodes = p.getnodes()
89        print nodes.np, nodes['np']
90
91         Author: Bas van der Vlies
92
93  *  PBSQuery:
94        For old and new data structure we now can use another syntax:
95     - node['np'] and node.np are equivalent
96
97        This new syntax works for all keywords.
98        Author: Bas van der Vlies
99
100  *  PBSQuery:
101        Added iter object for job, node, queue and server objects, eg:
102        node = p.getnode('gb-r1n1')
103        print node.name
104        for attrib in node:
105           print '%\t%s = %s' %(attrib, node[attrib])
106        Author: Bas van der Vlies
107
108  *  PBSQuery:
109        fixed an error in getnode, getqueue and getjob, return
110        empty dictionary if not found.
111        Author: Bas van der Vlies
112
113  *  PBSQuery:
114        New build system for rpm packages, make -f Makefile.rpm
115        Author: Michel Jouvin <jouvin add lal dot in2p3 dot fr>
116        Applied: Bas van der Vlies
117
118 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 14 May 2009 13:41:00 +0200
119
120pbs-python (3.0.1-2) intrepid; urgency=low
121
122  * adjust number of nodes to 32
123
124 -- root <root@rc.sara.nl>  Tue, 17 Mar 2009 18:17:18 +0100
125
126pbs-python (3.0.1-1) intrepid; urgency=low
127
128  * Small bug fix
129
130 -- root <root@rc.sara.nl>  Wed, 28 Jan 2009 13:58:43 +0100
131
132pbs-python (3.0.0-1) intrepid; urgency=low
133
134  * New api for PBSQuery and build on any architecture
135
136 -- Bas van der Vlies <bas@sara.nl>  Tue, 11 Nov 2008 12:48:39 +0100
137
138pbs-python (2.9.8-3) intrepid; urgency=low
139
140  * New functions added to PBSQuery
141
142 -- Bas van der Vlies <basv@sara.nl>  Fri, 10 Oct 2008 11:18:38 +0200
143
144pbs-python (2.9.8-2) intrepid; urgency=low
145
146  * New PBSQuery module
147
148 -- Bas van der Vlies <bas@sara.nl>  Wed,  8 Oct 2008 14:05:44 +0200
149
150pbs-python (2.9.8-1) intrepid; urgency=low
151
152  * New version with updated torque header file (version 2.X)
153
154 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 24 Sep 2008 12:32:29 +0200
155
156pbs-python (2.9.6-1) intrepid; urgency=low
157
158  * pbs_python.spec file patch added libdir and python defines so it
159    will build for RHEL5.1/CentOS 5.1 (by Michael Sternberg) and some
160    minor changes to the pbs_ifl.h file
161
162 -- Dennis Stam <dennis.stam@sara.nl>  Thu, 18 Sep 2008 11:23:16 +0200
163
164pbs-python (2.9.4-1) unstable; urgency=low
165
166  * New version with all the fixes as mentioned below
167
168 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 16 Nov 2006 14:29:16 +0100
169
170pbs-python (2.9.2-4) unstable; urgency=low
171
172  * PBSQuery: Make use of UserDict module
173
174 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 18 Oct 2006 11:46:34 +0200
175
176pbs-python (2.9.2-3) unstable; urgency=low
177
178  *  Fixed a has_key bug must return zero instead of None
179     Thanks to Ramon Bastiaans for reporting
180
181 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 13 Oct 2006 15:33:25 +0200
182
183pbs-python (2.9.2-2) unstable; urgency=low
184
185  * new_rack_pbsmon.py fixes serial/parallel calculations
186
187 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 10 Oct 2006 12:13:25 +0200
188
189pbs-python (2.9.2-1) unstable; urgency=low
190
191  * New upstream version, read CHANGES file
192
193 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 19 Sep 2006 16:17:54 +0200
194
195pbs-python (2.9.1-6) unstable; urgency=low
196
197  *  New torque build system
198
199 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 21 Jul 2006 10:41:31 +0200
200
201pbs-python (2.9.1-5) unstable; urgency=low
202
203  * Down state has most priority. So display it
204
205 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 16 Jun 2006 14:44:48 +0200
206
207pbs-python (2.9.1-4) unstable; urgency=low
208
209  *  Added sara_install to Makefile.in. Else
210     no new pbsmon for SARA
211
212 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 15 Jun 2006 12:23:54 +0200
213
214pbs-python (2.9.1-3) unstable; urgency=low
215
216  * New version adjusted new_rack_pbsmon.py to 39 racks
217
218 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Jun 2006 11:56:26 +0200
219
220pbs-python (2.9.1-2) unstable; urgency=low
221
222  * Fixed a bug in new_rack_pbsmon.py
223
224 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 26 May 2006 16:41:35 +0200
225
226pbs-python (2.9.0-1) unstable; urgency=low
227
228  * Added new build system for torque 2.1.0 and higher
229
230 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 20 Apr 2006 14:25:21 +0200
231
232pbs-python (2.8.2-3) unstable; urgency=low
233
234  * Changed new_rack_pbsmon.py script by walter
235
236 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 13 Apr 2006 14:10:36 +0200
237
238pbs-python (2.8.2-2) unstable; urgency=low
239
240  *  Fixed Makefile.in, now right script
241
242 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  7 Apr 2006 10:59:35 +0200
243
244pbs-python (2.8.2-1) unstable; urgency=low
245
246  *  Added new pbsmon example: new_rack_pbsmon.py uses PBSQuery
247
248 -- Bas van der Vlies <bas@rc.sara.nl>  Thu,  6 Apr 2006 15:12:03 +0200
249
250pbs-python (2.8.0-2) unstable; urgency=medium
251
252  * Used swig 1.3.24 with python2.1 works also on higher python versions
253
254 -- Bas van der Vlies <bas@rc.sara.nl>  Mon,  7 Nov 2005 14:55:00 +0100
255
256pbs-python (2.8.0-1) unstable; urgency=low
257
258  * New pbs_python release, See CHANGES
259
260 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  4 Nov 2005 15:58:44 +0100
261
262pbs-python (2.7.10-1) unstable; urgency=low
263
264  * Added examples/LICENSE.sara to /usr/share/doc directory
265  * Made an sara_install section for pbsmon --> examples/rack_pbsmon.py
266
267 -- Bas van der Vlies <basv@sara.nl>  Mon, 26 Sep 2005 16:32:06 +0200
268
269pbs-python (2.7.9-2) unstable; urgency=low
270
271  * Bumped up version
272  * Fixed  DEBUG mode
273
274 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 24 Jun 2005 11:23:30 +0200
275
276pbs-python (2.7.5-1) unstable; urgency=low
277
278  * Initial version
279
280 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 1 Nov 2004 12:13:08 -0400
281
Note: See TracBrowser for help on using the repository browser.