source: trunk/debian/changelog @ 270

Last change on this file since 270 was 270, checked in by bas, 13 years ago

fixed an error in examples/sara_nodes.py

File size: 8.7 KB
Line 
1pbs-python (4.3.1-1) lenny; urgency=low
2
3  * see CHANGES
4
5 -- Bas van der Vlies <bas@sara.nl>  Wed, 24 Aug 2011 14:08:09 +0200
6
7pbs-python (4.3.0-1) lenny; urgency=low
8
9  * See CHANGES
10
11 -- Bas van der Vlies <bas@sara.nl>  Fri, 05 Nov 2010 09:04:29 +0100
12
13pbs-python (4.2.0-2) lenny; urgency=low
14
15  * Update LICENSE file to LGPLV3
16  * patched pbsmon.py for torque 2.5
17  * see CHANGES for complete list
18
19 -- Bas van der Vlies <bas@sara.nl>  Thu, 10 Jun 2010 10:27:43 +0200
20
21pbs-python (4.1.2-1) lenny; urgency=low
22
23  * See changes not yes finishedm but some important fixes
24
25 -- bas van der Vlies <basv@sara.nl>  Thu, 20 May 2010 11:11:21 +0200
26
27pbs-python (4.1.0-1) lenny; urgency=low
28
29  * See CHANGES file
30
31 -- bas van der Vlies <bas@sara.nl>  Thu, 29 Apr 2010 13:24:24 +0200
32
33pbs-python (4.0.2-1) lenny; urgency=low
34
35  * See CHANGES file
36
37 -- bas van der Vlies <bas@sara.nl>  Fri, 23 Apr 2010 10:27:58 +0200
38
39pbs-python (4.0.1-1) lenny; urgency=low
40
41  * See CHANGES file
42
43 -- bas van der Vlies <bas@sara.nl>  Wed, 21 Apr 2010 08:26:02 +0200
44
45pbs-python (4.0.0-1) lenny; urgency=low
46
47  * See CHANGES file
48
49 -- Bas van der Vlies <basv@sara.nl>  Fri, 09 Apr 2010 09:43:24 +0200
50
51pbs-python (3.6.0-1) lenny; urgency=low
52
53  * New generated files pbs_wrap.c and pbs.py fixes an error in pbs_runjob()
54
55 -- Bas van der Vlies <basv@sara.nl>  Fri, 15 Jan 2010 04:40:35 +0100
56
57pbs-python (3.5.0-1) lenny; urgency=low
58
59  * PBSQuery
60        The class functions of node, job and queue support old and new data
61        structure.
62
63    Changed the behaviour of the new data stucture, We can use it as
64    dictionary and as class attribute, this is equivalent, eg:
65      - print node['np'] and print node.np
66
67    for a node we parse the 'status' line and split on '=' char, You now can
68    use these statements, eg
69     - print node.status.arch     (node['status'].arch or node['status']['arch'])
70     - print node.status.nsession
71
72    for a job we parse the 'Variable_List' line and split on '=' char, You now can
73    use the statements, eg:
74     - print job.Variable_List.PBS_O_WORKDIR
75     - print job.Variable_List.PBS_O_HOME
76
77    for more info see examples/new_interface.py
78
79    Author: Bas van der Vlies
80
81  * new_rack_pbsmon.py
82    Rewrite to new data structure and automatically determine how many nodes
83    and racks cluster has and skip printing of empty racks (default), use -w/--wide
84    for old behaviour.
85
86    Author: Bas van der Vlies
87
88 -- Bas van der Vlies <bas@sara.nl>  Mon, 12 Nov 2009 15:03:16 +0200
89
90pbs-python (3.2.0-1) intrepid; urgency=low
91
92  *  PBSQuery:
93     New data structure. In the old structure it is a dictionary
94     with a value and the value is a string. This is changed that
95     dictionary values are now of type list or dictionary depends
96     on the value of keyword, eg for a node:
97       - np = 2:
98       - node['np'] = [ '2' ]
99       - properties = cores2, mem4gb, parallel
100       - node['properties'] = [ 'cores2', 'mem4gb', 'parallel' ]
101       - status = arch=x86_64,sessions=22599,,size=70627864kb, ...
102       - node['status']['arch'] = [ 'x86_64' ]
103       - node['status']['sessions'] = [ '222599' ]
104       - ...
105
106         The data structure is activated by the function:
107          - new_data_structure()
108
109         In a future release it will be come the default.
110         example:
111         p = PBSQuery()
112         p.new_data_structure()
113
114        nodes = p.getnodes()
115        print nodes.np, nodes['np']
116
117         Author: Bas van der Vlies
118
119  *  PBSQuery:
120        For old and new data structure we now can use another syntax:
121     - node['np'] and node.np are equivalent
122
123        This new syntax works for all keywords.
124        Author: Bas van der Vlies
125
126  *  PBSQuery:
127        Added iter object for job, node, queue and server objects, eg:
128        node = p.getnode('gb-r1n1')
129        print node.name
130        for attrib in node:
131           print '%\t%s = %s' %(attrib, node[attrib])
132        Author: Bas van der Vlies
133
134  *  PBSQuery:
135        fixed an error in getnode, getqueue and getjob, return
136        empty dictionary if not found.
137        Author: Bas van der Vlies
138
139  *  PBSQuery:
140        New build system for rpm packages, make -f Makefile.rpm
141        Author: Michel Jouvin <jouvin add lal dot in2p3 dot fr>
142        Applied: Bas van der Vlies
143
144 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 14 May 2009 13:41:00 +0200
145
146pbs-python (3.0.1-2) intrepid; urgency=low
147
148  * adjust number of nodes to 32
149
150 -- root <root@rc.sara.nl>  Tue, 17 Mar 2009 18:17:18 +0100
151
152pbs-python (3.0.1-1) intrepid; urgency=low
153
154  * Small bug fix
155
156 -- root <root@rc.sara.nl>  Wed, 28 Jan 2009 13:58:43 +0100
157
158pbs-python (3.0.0-1) intrepid; urgency=low
159
160  * New api for PBSQuery and build on any architecture
161
162 -- Bas van der Vlies <bas@sara.nl>  Tue, 11 Nov 2008 12:48:39 +0100
163
164pbs-python (2.9.8-3) intrepid; urgency=low
165
166  * New functions added to PBSQuery
167
168 -- Bas van der Vlies <basv@sara.nl>  Fri, 10 Oct 2008 11:18:38 +0200
169
170pbs-python (2.9.8-2) intrepid; urgency=low
171
172  * New PBSQuery module
173
174 -- Bas van der Vlies <bas@sara.nl>  Wed,  8 Oct 2008 14:05:44 +0200
175
176pbs-python (2.9.8-1) intrepid; urgency=low
177
178  * New version with updated torque header file (version 2.X)
179
180 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 24 Sep 2008 12:32:29 +0200
181
182pbs-python (2.9.6-1) intrepid; urgency=low
183
184  * pbs_python.spec file patch added libdir and python defines so it
185    will build for RHEL5.1/CentOS 5.1 (by Michael Sternberg) and some
186    minor changes to the pbs_ifl.h file
187
188 -- Dennis Stam <dennis.stam@sara.nl>  Thu, 18 Sep 2008 11:23:16 +0200
189
190pbs-python (2.9.4-1) unstable; urgency=low
191
192  * New version with all the fixes as mentioned below
193
194 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 16 Nov 2006 14:29:16 +0100
195
196pbs-python (2.9.2-4) unstable; urgency=low
197
198  * PBSQuery: Make use of UserDict module
199
200 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 18 Oct 2006 11:46:34 +0200
201
202pbs-python (2.9.2-3) unstable; urgency=low
203
204  *  Fixed a has_key bug must return zero instead of None
205     Thanks to Ramon Bastiaans for reporting
206
207 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 13 Oct 2006 15:33:25 +0200
208
209pbs-python (2.9.2-2) unstable; urgency=low
210
211  * new_rack_pbsmon.py fixes serial/parallel calculations
212
213 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 10 Oct 2006 12:13:25 +0200
214
215pbs-python (2.9.2-1) unstable; urgency=low
216
217  * New upstream version, read CHANGES file
218
219 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 19 Sep 2006 16:17:54 +0200
220
221pbs-python (2.9.1-6) unstable; urgency=low
222
223  *  New torque build system
224
225 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 21 Jul 2006 10:41:31 +0200
226
227pbs-python (2.9.1-5) unstable; urgency=low
228
229  * Down state has most priority. So display it
230
231 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 16 Jun 2006 14:44:48 +0200
232
233pbs-python (2.9.1-4) unstable; urgency=low
234
235  *  Added sara_install to Makefile.in. Else
236     no new pbsmon for SARA
237
238 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 15 Jun 2006 12:23:54 +0200
239
240pbs-python (2.9.1-3) unstable; urgency=low
241
242  * New version adjusted new_rack_pbsmon.py to 39 racks
243
244 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Jun 2006 11:56:26 +0200
245
246pbs-python (2.9.1-2) unstable; urgency=low
247
248  * Fixed a bug in new_rack_pbsmon.py
249
250 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 26 May 2006 16:41:35 +0200
251
252pbs-python (2.9.0-1) unstable; urgency=low
253
254  * Added new build system for torque 2.1.0 and higher
255
256 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 20 Apr 2006 14:25:21 +0200
257
258pbs-python (2.8.2-3) unstable; urgency=low
259
260  * Changed new_rack_pbsmon.py script by walter
261
262 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 13 Apr 2006 14:10:36 +0200
263
264pbs-python (2.8.2-2) unstable; urgency=low
265
266  *  Fixed Makefile.in, now right script
267
268 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  7 Apr 2006 10:59:35 +0200
269
270pbs-python (2.8.2-1) unstable; urgency=low
271
272  *  Added new pbsmon example: new_rack_pbsmon.py uses PBSQuery
273
274 -- Bas van der Vlies <bas@rc.sara.nl>  Thu,  6 Apr 2006 15:12:03 +0200
275
276pbs-python (2.8.0-2) unstable; urgency=medium
277
278  * Used swig 1.3.24 with python2.1 works also on higher python versions
279
280 -- Bas van der Vlies <bas@rc.sara.nl>  Mon,  7 Nov 2005 14:55:00 +0100
281
282pbs-python (2.8.0-1) unstable; urgency=low
283
284  * New pbs_python release, See CHANGES
285
286 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  4 Nov 2005 15:58:44 +0100
287
288pbs-python (2.7.10-1) unstable; urgency=low
289
290  * Added examples/LICENSE.sara to /usr/share/doc directory
291  * Made an sara_install section for pbsmon --> examples/rack_pbsmon.py
292
293 -- Bas van der Vlies <basv@sara.nl>  Mon, 26 Sep 2005 16:32:06 +0200
294
295pbs-python (2.7.9-2) unstable; urgency=low
296
297  * Bumped up version
298  * Fixed  DEBUG mode
299
300 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 24 Jun 2005 11:23:30 +0200
301
302pbs-python (2.7.5-1) unstable; urgency=low
303
304  * Initial version
305
306 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 1 Nov 2004 12:13:08 -0400
307
Note: See TracBrowser for help on using the repository browser.