source: trunk/debian/changelog @ 290

Last change on this file since 290 was 290, checked in by bas, 11 years ago

changes sara to SURFsara

File size: 9.4 KB
Line 
1pbs-python (4.3.5-1) lenny; urgency=low
2
3  * sara is now surfsara.nl, changed all references
4  * added a new code example for EVENT node parsing
5  * See Changes
6
7 -- Bas van der Vlies <bas.vandervlies@surfsara.nl>  Mon, 29 Apr 2013 17:21:39 +0200
8
9pbs-python (4.3.4-2) lenny; urgency=low
10
11  * Removed gb- from REGEX new_rack
12
13 -- Dennis Stam <dennis.stam@surfsara.nl>  Tue, 19 Feb 2013 16:54:39 +0100
14
15pbs-python (4.3.4-1) lenny; urgency=low
16
17  * See CHANGES
18  * install pbs_jobmonitor and pbs_joblogin in /usr/bin
19
20 -- Bas van der Vlies <basv@sara.nl>  Fri, 27 Apr 2012 09:54:54 +0200
21
22pbs-python (4.3.3-1) lenny; urgency=low
23
24  * see CHANGES
25
26 -- Bas van der Vlies <basv@sara.nl>  Tue, 03 Jan 2012 12:01:15 +0100
27
28pbs-python (4.3.1-1) lenny; urgency=low
29
30  * see CHANGES
31
32 -- Bas van der Vlies <bas@sara.nl>  Wed, 24 Aug 2011 14:08:09 +0200
33
34pbs-python (4.3.0-1) lenny; urgency=low
35
36  * See CHANGES
37
38 -- Bas van der Vlies <bas@sara.nl>  Fri, 05 Nov 2010 09:04:29 +0100
39
40pbs-python (4.2.0-2) lenny; urgency=low
41
42  * Update LICENSE file to LGPLV3
43  * patched pbsmon.py for torque 2.5
44  * see CHANGES for complete list
45
46 -- Bas van der Vlies <bas@sara.nl>  Thu, 10 Jun 2010 10:27:43 +0200
47
48pbs-python (4.1.2-1) lenny; urgency=low
49
50  * See changes not yes finishedm but some important fixes
51
52 -- bas van der Vlies <basv@sara.nl>  Thu, 20 May 2010 11:11:21 +0200
53
54pbs-python (4.1.0-1) lenny; urgency=low
55
56  * See CHANGES file
57
58 -- bas van der Vlies <bas@sara.nl>  Thu, 29 Apr 2010 13:24:24 +0200
59
60pbs-python (4.0.2-1) lenny; urgency=low
61
62  * See CHANGES file
63
64 -- bas van der Vlies <bas@sara.nl>  Fri, 23 Apr 2010 10:27:58 +0200
65
66pbs-python (4.0.1-1) lenny; urgency=low
67
68  * See CHANGES file
69
70 -- bas van der Vlies <bas@sara.nl>  Wed, 21 Apr 2010 08:26:02 +0200
71
72pbs-python (4.0.0-1) lenny; urgency=low
73
74  * See CHANGES file
75
76 -- Bas van der Vlies <basv@sara.nl>  Fri, 09 Apr 2010 09:43:24 +0200
77
78pbs-python (3.6.0-1) lenny; urgency=low
79
80  * New generated files pbs_wrap.c and pbs.py fixes an error in pbs_runjob()
81
82 -- Bas van der Vlies <basv@sara.nl>  Fri, 15 Jan 2010 04:40:35 +0100
83
84pbs-python (3.5.0-1) lenny; urgency=low
85
86  * PBSQuery
87        The class functions of node, job and queue support old and new data
88        structure.
89
90    Changed the behaviour of the new data stucture, We can use it as
91    dictionary and as class attribute, this is equivalent, eg:
92      - print node['np'] and print node.np
93
94    for a node we parse the 'status' line and split on '=' char, You now can
95    use these statements, eg
96     - print node.status.arch     (node['status'].arch or node['status']['arch'])
97     - print node.status.nsession
98
99    for a job we parse the 'Variable_List' line and split on '=' char, You now can
100    use the statements, eg:
101     - print job.Variable_List.PBS_O_WORKDIR
102     - print job.Variable_List.PBS_O_HOME
103
104    for more info see examples/new_interface.py
105
106    Author: Bas van der Vlies
107
108  * new_rack_pbsmon.py
109    Rewrite to new data structure and automatically determine how many nodes
110    and racks cluster has and skip printing of empty racks (default), use -w/--wide
111    for old behaviour.
112
113    Author: Bas van der Vlies
114
115 -- Bas van der Vlies <bas@sara.nl>  Mon, 12 Nov 2009 15:03:16 +0200
116
117pbs-python (3.2.0-1) intrepid; urgency=low
118
119  *  PBSQuery:
120     New data structure. In the old structure it is a dictionary
121     with a value and the value is a string. This is changed that
122     dictionary values are now of type list or dictionary depends
123     on the value of keyword, eg for a node:
124       - np = 2:
125       - node['np'] = [ '2' ]
126       - properties = cores2, mem4gb, parallel
127       - node['properties'] = [ 'cores2', 'mem4gb', 'parallel' ]
128       - status = arch=x86_64,sessions=22599,,size=70627864kb, ...
129       - node['status']['arch'] = [ 'x86_64' ]
130       - node['status']['sessions'] = [ '222599' ]
131       - ...
132
133         The data structure is activated by the function:
134          - new_data_structure()
135
136         In a future release it will be come the default.
137         example:
138         p = PBSQuery()
139         p.new_data_structure()
140
141        nodes = p.getnodes()
142        print nodes.np, nodes['np']
143
144         Author: Bas van der Vlies
145
146  *  PBSQuery:
147        For old and new data structure we now can use another syntax:
148     - node['np'] and node.np are equivalent
149
150        This new syntax works for all keywords.
151        Author: Bas van der Vlies
152
153  *  PBSQuery:
154        Added iter object for job, node, queue and server objects, eg:
155        node = p.getnode('gb-r1n1')
156        print node.name
157        for attrib in node:
158           print '%\t%s = %s' %(attrib, node[attrib])
159        Author: Bas van der Vlies
160
161  *  PBSQuery:
162        fixed an error in getnode, getqueue and getjob, return
163        empty dictionary if not found.
164        Author: Bas van der Vlies
165
166  *  PBSQuery:
167        New build system for rpm packages, make -f Makefile.rpm
168        Author: Michel Jouvin <jouvin add lal dot in2p3 dot fr>
169        Applied: Bas van der Vlies
170
171 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 14 May 2009 13:41:00 +0200
172
173pbs-python (3.0.1-2) intrepid; urgency=low
174
175  * adjust number of nodes to 32
176
177 -- root <root@rc.sara.nl>  Tue, 17 Mar 2009 18:17:18 +0100
178
179pbs-python (3.0.1-1) intrepid; urgency=low
180
181  * Small bug fix
182
183 -- root <root@rc.sara.nl>  Wed, 28 Jan 2009 13:58:43 +0100
184
185pbs-python (3.0.0-1) intrepid; urgency=low
186
187  * New api for PBSQuery and build on any architecture
188
189 -- Bas van der Vlies <bas@sara.nl>  Tue, 11 Nov 2008 12:48:39 +0100
190
191pbs-python (2.9.8-3) intrepid; urgency=low
192
193  * New functions added to PBSQuery
194
195 -- Bas van der Vlies <basv@sara.nl>  Fri, 10 Oct 2008 11:18:38 +0200
196
197pbs-python (2.9.8-2) intrepid; urgency=low
198
199  * New PBSQuery module
200
201 -- Bas van der Vlies <bas@sara.nl>  Wed,  8 Oct 2008 14:05:44 +0200
202
203pbs-python (2.9.8-1) intrepid; urgency=low
204
205  * New version with updated torque header file (version 2.X)
206
207 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 24 Sep 2008 12:32:29 +0200
208
209pbs-python (2.9.6-1) intrepid; urgency=low
210
211  * pbs_python.spec file patch added libdir and python defines so it
212    will build for RHEL5.1/CentOS 5.1 (by Michael Sternberg) and some
213    minor changes to the pbs_ifl.h file
214
215 -- Dennis Stam <dennis.stam@sara.nl>  Thu, 18 Sep 2008 11:23:16 +0200
216
217pbs-python (2.9.4-1) unstable; urgency=low
218
219  * New version with all the fixes as mentioned below
220
221 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 16 Nov 2006 14:29:16 +0100
222
223pbs-python (2.9.2-4) unstable; urgency=low
224
225  * PBSQuery: Make use of UserDict module
226
227 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 18 Oct 2006 11:46:34 +0200
228
229pbs-python (2.9.2-3) unstable; urgency=low
230
231  *  Fixed a has_key bug must return zero instead of None
232     Thanks to Ramon Bastiaans for reporting
233
234 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 13 Oct 2006 15:33:25 +0200
235
236pbs-python (2.9.2-2) unstable; urgency=low
237
238  * new_rack_pbsmon.py fixes serial/parallel calculations
239
240 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 10 Oct 2006 12:13:25 +0200
241
242pbs-python (2.9.2-1) unstable; urgency=low
243
244  * New upstream version, read CHANGES file
245
246 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 19 Sep 2006 16:17:54 +0200
247
248pbs-python (2.9.1-6) unstable; urgency=low
249
250  *  New torque build system
251
252 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 21 Jul 2006 10:41:31 +0200
253
254pbs-python (2.9.1-5) unstable; urgency=low
255
256  * Down state has most priority. So display it
257
258 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 16 Jun 2006 14:44:48 +0200
259
260pbs-python (2.9.1-4) unstable; urgency=low
261
262  *  Added sara_install to Makefile.in. Else
263     no new pbsmon for SARA
264
265 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 15 Jun 2006 12:23:54 +0200
266
267pbs-python (2.9.1-3) unstable; urgency=low
268
269  * New version adjusted new_rack_pbsmon.py to 39 racks
270
271 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Jun 2006 11:56:26 +0200
272
273pbs-python (2.9.1-2) unstable; urgency=low
274
275  * Fixed a bug in new_rack_pbsmon.py
276
277 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 26 May 2006 16:41:35 +0200
278
279pbs-python (2.9.0-1) unstable; urgency=low
280
281  * Added new build system for torque 2.1.0 and higher
282
283 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 20 Apr 2006 14:25:21 +0200
284
285pbs-python (2.8.2-3) unstable; urgency=low
286
287  * Changed new_rack_pbsmon.py script by walter
288
289 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 13 Apr 2006 14:10:36 +0200
290
291pbs-python (2.8.2-2) unstable; urgency=low
292
293  *  Fixed Makefile.in, now right script
294
295 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  7 Apr 2006 10:59:35 +0200
296
297pbs-python (2.8.2-1) unstable; urgency=low
298
299  *  Added new pbsmon example: new_rack_pbsmon.py uses PBSQuery
300
301 -- Bas van der Vlies <bas@rc.sara.nl>  Thu,  6 Apr 2006 15:12:03 +0200
302
303pbs-python (2.8.0-2) unstable; urgency=medium
304
305  * Used swig 1.3.24 with python2.1 works also on higher python versions
306
307 -- Bas van der Vlies <bas@rc.sara.nl>  Mon,  7 Nov 2005 14:55:00 +0100
308
309pbs-python (2.8.0-1) unstable; urgency=low
310
311  * New pbs_python release, See CHANGES
312
313 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  4 Nov 2005 15:58:44 +0100
314
315pbs-python (2.7.10-1) unstable; urgency=low
316
317  * Added examples/LICENSE.sara to /usr/share/doc directory
318  * Made an sara_install section for pbsmon --> examples/rack_pbsmon.py
319
320 -- Bas van der Vlies <basv@sara.nl>  Mon, 26 Sep 2005 16:32:06 +0200
321
322pbs-python (2.7.9-2) unstable; urgency=low
323
324  * Bumped up version
325  * Fixed  DEBUG mode
326
327 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 24 Jun 2005 11:23:30 +0200
328
329pbs-python (2.7.5-1) unstable; urgency=low
330
331  * Initial version
332
333 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 1 Nov 2004 12:13:08 -0400
334
Note: See TracBrowser for help on using the repository browser.