source: trunk/debian/changelog @ 295

Last change on this file since 295 was 295, checked in by dennis, 11 years ago

Bumped version number to 4.3.6, modified debian/control file to ensure a dependicy
for python-argparse when your are using Python 2.6 or lower.

File size: 9.5 KB
Line 
1pbs-python (4.3.6-1) lenny; urgency=low
2
3  * See Changes
4
5 -- Dennis Stam <dennis.stam@surfsara.nl>  Thu, 16 May 2013 09:07:03 +0200
6
7pbs-python (4.3.5-1) lenny; urgency=low
8
9  * sara is now surfsara.nl, changed all references
10  * added a new code example for EVENT node parsing
11  * See Changes
12
13 -- Bas van der Vlies <bas.vandervlies@surfsara.nl>  Mon, 29 Apr 2013 17:21:39 +0200
14
15pbs-python (4.3.4-2) lenny; urgency=low
16
17  * Removed gb- from REGEX new_rack
18
19 -- Dennis Stam <dennis.stam@surfsara.nl>  Tue, 19 Feb 2013 16:54:39 +0100
20
21pbs-python (4.3.4-1) lenny; urgency=low
22
23  * See CHANGES
24  * install pbs_jobmonitor and pbs_joblogin in /usr/bin
25
26 -- Bas van der Vlies <basv@sara.nl>  Fri, 27 Apr 2012 09:54:54 +0200
27
28pbs-python (4.3.3-1) lenny; urgency=low
29
30  * see CHANGES
31
32 -- Bas van der Vlies <basv@sara.nl>  Tue, 03 Jan 2012 12:01:15 +0100
33
34pbs-python (4.3.1-1) lenny; urgency=low
35
36  * see CHANGES
37
38 -- Bas van der Vlies <bas@sara.nl>  Wed, 24 Aug 2011 14:08:09 +0200
39
40pbs-python (4.3.0-1) lenny; urgency=low
41
42  * See CHANGES
43
44 -- Bas van der Vlies <bas@sara.nl>  Fri, 05 Nov 2010 09:04:29 +0100
45
46pbs-python (4.2.0-2) lenny; urgency=low
47
48  * Update LICENSE file to LGPLV3
49  * patched pbsmon.py for torque 2.5
50  * see CHANGES for complete list
51
52 -- Bas van der Vlies <bas@sara.nl>  Thu, 10 Jun 2010 10:27:43 +0200
53
54pbs-python (4.1.2-1) lenny; urgency=low
55
56  * See changes not yes finishedm but some important fixes
57
58 -- bas van der Vlies <basv@sara.nl>  Thu, 20 May 2010 11:11:21 +0200
59
60pbs-python (4.1.0-1) lenny; urgency=low
61
62  * See CHANGES file
63
64 -- bas van der Vlies <bas@sara.nl>  Thu, 29 Apr 2010 13:24:24 +0200
65
66pbs-python (4.0.2-1) lenny; urgency=low
67
68  * See CHANGES file
69
70 -- bas van der Vlies <bas@sara.nl>  Fri, 23 Apr 2010 10:27:58 +0200
71
72pbs-python (4.0.1-1) lenny; urgency=low
73
74  * See CHANGES file
75
76 -- bas van der Vlies <bas@sara.nl>  Wed, 21 Apr 2010 08:26:02 +0200
77
78pbs-python (4.0.0-1) lenny; urgency=low
79
80  * See CHANGES file
81
82 -- Bas van der Vlies <basv@sara.nl>  Fri, 09 Apr 2010 09:43:24 +0200
83
84pbs-python (3.6.0-1) lenny; urgency=low
85
86  * New generated files pbs_wrap.c and pbs.py fixes an error in pbs_runjob()
87
88 -- Bas van der Vlies <basv@sara.nl>  Fri, 15 Jan 2010 04:40:35 +0100
89
90pbs-python (3.5.0-1) lenny; urgency=low
91
92  * PBSQuery
93        The class functions of node, job and queue support old and new data
94        structure.
95
96    Changed the behaviour of the new data stucture, We can use it as
97    dictionary and as class attribute, this is equivalent, eg:
98      - print node['np'] and print node.np
99
100    for a node we parse the 'status' line and split on '=' char, You now can
101    use these statements, eg
102     - print node.status.arch     (node['status'].arch or node['status']['arch'])
103     - print node.status.nsession
104
105    for a job we parse the 'Variable_List' line and split on '=' char, You now can
106    use the statements, eg:
107     - print job.Variable_List.PBS_O_WORKDIR
108     - print job.Variable_List.PBS_O_HOME
109
110    for more info see examples/new_interface.py
111
112    Author: Bas van der Vlies
113
114  * new_rack_pbsmon.py
115    Rewrite to new data structure and automatically determine how many nodes
116    and racks cluster has and skip printing of empty racks (default), use -w/--wide
117    for old behaviour.
118
119    Author: Bas van der Vlies
120
121 -- Bas van der Vlies <bas@sara.nl>  Mon, 12 Nov 2009 15:03:16 +0200
122
123pbs-python (3.2.0-1) intrepid; urgency=low
124
125  *  PBSQuery:
126     New data structure. In the old structure it is a dictionary
127     with a value and the value is a string. This is changed that
128     dictionary values are now of type list or dictionary depends
129     on the value of keyword, eg for a node:
130       - np = 2:
131       - node['np'] = [ '2' ]
132       - properties = cores2, mem4gb, parallel
133       - node['properties'] = [ 'cores2', 'mem4gb', 'parallel' ]
134       - status = arch=x86_64,sessions=22599,,size=70627864kb, ...
135       - node['status']['arch'] = [ 'x86_64' ]
136       - node['status']['sessions'] = [ '222599' ]
137       - ...
138
139         The data structure is activated by the function:
140          - new_data_structure()
141
142         In a future release it will be come the default.
143         example:
144         p = PBSQuery()
145         p.new_data_structure()
146
147        nodes = p.getnodes()
148        print nodes.np, nodes['np']
149
150         Author: Bas van der Vlies
151
152  *  PBSQuery:
153        For old and new data structure we now can use another syntax:
154     - node['np'] and node.np are equivalent
155
156        This new syntax works for all keywords.
157        Author: Bas van der Vlies
158
159  *  PBSQuery:
160        Added iter object for job, node, queue and server objects, eg:
161        node = p.getnode('gb-r1n1')
162        print node.name
163        for attrib in node:
164           print '%\t%s = %s' %(attrib, node[attrib])
165        Author: Bas van der Vlies
166
167  *  PBSQuery:
168        fixed an error in getnode, getqueue and getjob, return
169        empty dictionary if not found.
170        Author: Bas van der Vlies
171
172  *  PBSQuery:
173        New build system for rpm packages, make -f Makefile.rpm
174        Author: Michel Jouvin <jouvin add lal dot in2p3 dot fr>
175        Applied: Bas van der Vlies
176
177 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 14 May 2009 13:41:00 +0200
178
179pbs-python (3.0.1-2) intrepid; urgency=low
180
181  * adjust number of nodes to 32
182
183 -- root <root@rc.sara.nl>  Tue, 17 Mar 2009 18:17:18 +0100
184
185pbs-python (3.0.1-1) intrepid; urgency=low
186
187  * Small bug fix
188
189 -- root <root@rc.sara.nl>  Wed, 28 Jan 2009 13:58:43 +0100
190
191pbs-python (3.0.0-1) intrepid; urgency=low
192
193  * New api for PBSQuery and build on any architecture
194
195 -- Bas van der Vlies <bas@sara.nl>  Tue, 11 Nov 2008 12:48:39 +0100
196
197pbs-python (2.9.8-3) intrepid; urgency=low
198
199  * New functions added to PBSQuery
200
201 -- Bas van der Vlies <basv@sara.nl>  Fri, 10 Oct 2008 11:18:38 +0200
202
203pbs-python (2.9.8-2) intrepid; urgency=low
204
205  * New PBSQuery module
206
207 -- Bas van der Vlies <bas@sara.nl>  Wed,  8 Oct 2008 14:05:44 +0200
208
209pbs-python (2.9.8-1) intrepid; urgency=low
210
211  * New version with updated torque header file (version 2.X)
212
213 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 24 Sep 2008 12:32:29 +0200
214
215pbs-python (2.9.6-1) intrepid; urgency=low
216
217  * pbs_python.spec file patch added libdir and python defines so it
218    will build for RHEL5.1/CentOS 5.1 (by Michael Sternberg) and some
219    minor changes to the pbs_ifl.h file
220
221 -- Dennis Stam <dennis.stam@sara.nl>  Thu, 18 Sep 2008 11:23:16 +0200
222
223pbs-python (2.9.4-1) unstable; urgency=low
224
225  * New version with all the fixes as mentioned below
226
227 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 16 Nov 2006 14:29:16 +0100
228
229pbs-python (2.9.2-4) unstable; urgency=low
230
231  * PBSQuery: Make use of UserDict module
232
233 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 18 Oct 2006 11:46:34 +0200
234
235pbs-python (2.9.2-3) unstable; urgency=low
236
237  *  Fixed a has_key bug must return zero instead of None
238     Thanks to Ramon Bastiaans for reporting
239
240 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 13 Oct 2006 15:33:25 +0200
241
242pbs-python (2.9.2-2) unstable; urgency=low
243
244  * new_rack_pbsmon.py fixes serial/parallel calculations
245
246 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 10 Oct 2006 12:13:25 +0200
247
248pbs-python (2.9.2-1) unstable; urgency=low
249
250  * New upstream version, read CHANGES file
251
252 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 19 Sep 2006 16:17:54 +0200
253
254pbs-python (2.9.1-6) unstable; urgency=low
255
256  *  New torque build system
257
258 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 21 Jul 2006 10:41:31 +0200
259
260pbs-python (2.9.1-5) unstable; urgency=low
261
262  * Down state has most priority. So display it
263
264 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 16 Jun 2006 14:44:48 +0200
265
266pbs-python (2.9.1-4) unstable; urgency=low
267
268  *  Added sara_install to Makefile.in. Else
269     no new pbsmon for SARA
270
271 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 15 Jun 2006 12:23:54 +0200
272
273pbs-python (2.9.1-3) unstable; urgency=low
274
275  * New version adjusted new_rack_pbsmon.py to 39 racks
276
277 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Jun 2006 11:56:26 +0200
278
279pbs-python (2.9.1-2) unstable; urgency=low
280
281  * Fixed a bug in new_rack_pbsmon.py
282
283 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 26 May 2006 16:41:35 +0200
284
285pbs-python (2.9.0-1) unstable; urgency=low
286
287  * Added new build system for torque 2.1.0 and higher
288
289 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 20 Apr 2006 14:25:21 +0200
290
291pbs-python (2.8.2-3) unstable; urgency=low
292
293  * Changed new_rack_pbsmon.py script by walter
294
295 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 13 Apr 2006 14:10:36 +0200
296
297pbs-python (2.8.2-2) unstable; urgency=low
298
299  *  Fixed Makefile.in, now right script
300
301 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  7 Apr 2006 10:59:35 +0200
302
303pbs-python (2.8.2-1) unstable; urgency=low
304
305  *  Added new pbsmon example: new_rack_pbsmon.py uses PBSQuery
306
307 -- Bas van der Vlies <bas@rc.sara.nl>  Thu,  6 Apr 2006 15:12:03 +0200
308
309pbs-python (2.8.0-2) unstable; urgency=medium
310
311  * Used swig 1.3.24 with python2.1 works also on higher python versions
312
313 -- Bas van der Vlies <bas@rc.sara.nl>  Mon,  7 Nov 2005 14:55:00 +0100
314
315pbs-python (2.8.0-1) unstable; urgency=low
316
317  * New pbs_python release, See CHANGES
318
319 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  4 Nov 2005 15:58:44 +0100
320
321pbs-python (2.7.10-1) unstable; urgency=low
322
323  * Added examples/LICENSE.sara to /usr/share/doc directory
324  * Made an sara_install section for pbsmon --> examples/rack_pbsmon.py
325
326 -- Bas van der Vlies <basv@sara.nl>  Mon, 26 Sep 2005 16:32:06 +0200
327
328pbs-python (2.7.9-2) unstable; urgency=low
329
330  * Bumped up version
331  * Fixed  DEBUG mode
332
333 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 24 Jun 2005 11:23:30 +0200
334
335pbs-python (2.7.5-1) unstable; urgency=low
336
337  * Initial version
338
339 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 1 Nov 2004 12:13:08 -0400
340
Note: See TracBrowser for help on using the repository browser.