source: trunk/pbs_python.spec @ 345

Last change on this file since 345 was 345, checked in by dennis, 9 years ago

Fixed pbs_python for RPM, sara_nodes and pbsmon are now available

  • Property svn:executable set to *
File size: 1.8 KB
Line 
1%{!?python_sitearch: %define python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
2
3### Abstract ###
4
5Name: pbs_python
6Version: 4.6.0
7Release: 3%{?dist}
8License: See LICENSE
9Group: Development/Libraries
10Summary: This package contains the PBS python module.
11URL: https://oss.trac.surfsara.nl/pbs_python
12BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
13Source: ftp://ftp.sara.nl/pub/outgoing/pbs_python.tar.gz
14
15### Dependencies ###
16# None
17
18### Build Dependencies ###
19
20BuildRequires: torque-devel
21BuildRequires: python-devel >= %{python_version}
22
23%description
24This package contains the pbs python module.
25
26%prep
27%setup -q -n pbs_python-%{version}
28
29%build
30%configure
31%{__python} setup.py build
32
33%install
34%{__python} ./setup.py install --prefix $RPM_BUILD_ROOT%{_prefix} ;
35%{__mkdir_p} $RPM_BUILD_ROOT%{_prefix}/bin
36%{__install} -m0655 examples/sara_nodes.py ${RPM_BUILD_ROOT}%{_prefix}/bin/sara_nodes
37%{__install} -m0655 examples/new_rack_pbsmon.py ${RPM_BUILD_ROOT}%{_prefix}/bin/pbsmon
38
39%clean
40rm -rf $RPM_BUILD_ROOT
41
42%files
43%defattr(-,root,root,0755)
44%doc README TODO examples
45%{python_sitearch}/pbs.pth
46%{python_sitearch}/pbs/*
47%{_prefix}/bin/*
48
49%changelog
50* Tue Mar 24 2010 Ramon Bastiaans <ramon.bastiaans@sara.nl>
51- Updates for new version
52* Tue Oct 06 2009 Ramon Bastiaans <ramon.bastiaans@sara.nl>
53- Fixed tmppath, %setup sourcedir
54* Tue Mar 24 2009 David Chin <chindw@wfu.edu>
55- Fedora-ize
56* Sun Mar  9 2008 Michael Sternberg <sternberg@anl.gov>
57- libdir and python defines
58* Wed Nov 23 2005 Ramon Bastiaans <bastiaans@sara.nl>
59- Fixed missing prep setup and added configure
60* Tue Nov 22 2005 Martin Pels <pels@sara.nl>
61- Changed default directory permissions
62* Tue Nov 01 2005 Martin Pels <pels@sara.nl>
63- Initial version
64
Note: See TracBrowser for help on using the repository browser.