Changeset 316


Ignore:
Timestamp:
06/04/14 18:24:52 (9 years ago)
Author:
bas
Message:

Dennis Stam:

  • fixed docdir error, closes #39
  • added a new option to examples/new_rack_pbsmon.py -p/--property
  • improved the autoconf setup
Location:
trunk
Files:
10 edited

Legend:

Unmodified
Added
Removed
  • trunk/CHANGES

    r311 r316  
     1=========== 4.4.1
     2 * new_rack_pbsmon.py: Added option -p/--property to filter on torque node properties
     3 Requested by: Willem Vermin and Wim Rijks
     4 Author: Dennis Stam
     5
     6 * Fixed docdir bug in configure.in and Makefile.in, closes #39
     7 Author: Dennis Stam
     8
    19=========== 4.4.0
    210 * Drop support for versions older then 2.4
  • trunk/Makefile.in

    r306 r316  
    11TAR=tar
    22GZIP_ENV=--best
     3
     4PACKAGE_TARNAME=@PACKAGE_TARNAME@
    35
    46PREFIX=@prefix@
     
    68BINDIR=$(PREFIX)/bin
    79
    8 DOCDIR=@docdir@ 
    9 EXAMPLES=$(DOCDIR)/examples
     10DOCDIR=@docdir@
     11EXAMPLES=$(PREFIX)/$(DOCDIR)/examples
    1012
    1113.PHONY: install pythonlib
     
    1719install: pythonlib
    1820        python ./setup.py install --prefix $(DESTDIR)/$(exec_prefix) ;
    19         install -D LICENSE.openpbs $(DESTDIR)/$(DOCDIR)/LICENSE.openpbs
    20         install -D COPYING $(DESTDIR)/$(DOCDIR)/COPYING
    21         install -D COPYING.LESSER $(DESTDIR)/$(DOCDIR)/COPYING.LESSER
     21        install -D LICENSE.openpbs $(DESTDIR)/$(PREFIX)/$(DOCDIR)/LICENSE.openpbs
     22        install -D COPYING $(DESTDIR)/$(PREFIX)/$(DOCDIR)/COPYING
     23        install -D COPYING.LESSER $(DESTDIR)/$(PREFIX)/$(DOCDIR)/COPYING.LESSER
    2224        (cd examples; for i in *py; do install -D $$i  $(DESTDIR)/$(EXAMPLES)/$${i}; done)
    2325
  • trunk/configure

    r300 r316  
    11#! /bin/sh
    22# Guess values for system-dependent variables and create Makefiles.
    3 # Generated by GNU Autoconf 2.69.
     3# Generated by GNU Autoconf 2.69 for pbs-python 4.4.1.
    44#
    55#
     
    575575
    576576# Identity of this package.
    577 PACKAGE_NAME=
    578 PACKAGE_TARNAME=
    579 PACKAGE_VERSION=
    580 PACKAGE_STRING=
    581 PACKAGE_BUGREPORT=
    582 PACKAGE_URL=
    583 
    584 ac_unique_file="src/PBSQuery.py"
     577PACKAGE_NAME='pbs-python'
     578PACKAGE_TARNAME='pbs-python'
     579PACKAGE_VERSION='4.4.1'
     580PACKAGE_STRING='pbs-python 4.4.1'
     581PACKAGE_BUGREPORT=''
     582PACKAGE_URL=''
     583
     584ac_unique_file="src/C++/pbs_wrap.cxx"
    585585ac_subst_vars='LTLIBOBJS
    586586LIBOBJS
     
    685685includedir='${prefix}/include'
    686686oldincludedir='/usr/include'
    687 docdir='${datarootdir}/doc/${PACKAGE}'
     687docdir='${datarootdir}/doc/${PACKAGE_TARNAME}'
    688688infodir='${datarootdir}/info'
    689689htmldir='${docdir}'
     
    11851185  # This message is too long to be a string in the A/UX 3.1 sh.
    11861186  cat <<_ACEOF
    1187 \`configure' configures this package to adapt to many kinds of systems.
     1187\`configure' configures pbs-python 4.4.1 to adapt to many kinds of systems.
    11881188
    11891189Usage: $0 [OPTION]... [VAR=VALUE]...
     
    12331233  --localedir=DIR         locale-dependent data [DATAROOTDIR/locale]
    12341234  --mandir=DIR            man documentation [DATAROOTDIR/man]
    1235   --docdir=DIR            documentation root [DATAROOTDIR/doc/PACKAGE]
     1235  --docdir=DIR            documentation root [DATAROOTDIR/doc/pbs-python]
    12361236  --htmldir=DIR           html documentation [DOCDIR]
    12371237  --dvidir=DIR            dvi documentation [DOCDIR]
     
    12451245
    12461246if test -n "$ac_init_help"; then
    1247 
     1247  case $ac_init_help in
     1248     short | recursive ) echo "Configuration of pbs-python 4.4.1:";;
     1249   esac
    12481250  cat <<\_ACEOF
    12491251
     
    13161318if $ac_init_version; then
    13171319  cat <<\_ACEOF
    1318 configure
     1320pbs-python configure 4.4.1
    13191321generated by GNU Autoconf 2.69
    13201322
     
    13331335running configure, to aid debugging if configure makes a mistake.
    13341336
    1335 It was created by $as_me, which was
     1337It was created by pbs-python $as_me 4.4.1, which was
    13361338generated by GNU Autoconf 2.69.  Invocation command line was
    13371339
     
    16861688
    16871689
     1690
     1691
    16881692pbsdir_default=''
    16891693
     
    24232427# values after options handling.
    24242428ac_log="
    2425 This file was extended by $as_me, which was
     2429This file was extended by pbs-python $as_me 4.4.1, which was
    24262430generated by GNU Autoconf 2.69.  Invocation command line was
    24272431
     
    24762480ac_cs_config="`$as_echo "$ac_configure_args" | sed 's/^ //; s/[\\""\`\$]/\\\\&/g'`"
    24772481ac_cs_version="\\
    2478 config.status
     2482pbs-python config.status 4.4.1
    24792483configured by $0, generated by GNU Autoconf 2.69,
    24802484  with options \\"\$ac_cs_config\\"
  • trunk/configure.in

    r300 r316  
    1 AC_INIT(src/PBSQuery.py)
     1#AC_INIT(src/PBSQuery.py)
     2
     3AC_PREREQ([2.69])
     4AC_INIT([pbs-python], [4.4.1])
     5AC_CONFIG_SRCDIR([src/C++/pbs_wrap.cxx])
     6
    27AC_SUBST(prefix)
    38AC_SUBST(exec_prefix)
  • trunk/debian/changelog

    r304 r316  
    1 pbs-python (4.4.0-1) UNRELEASED; urgency=low
     1pbs-python (4.4.1-1) unstable; urgency=low
     2
     3  * See CHANGES
     4
     5 -- Dennis Stam <dennis.stam@surfsara.nl>  Wed, 04 Jun 2014 14:37:45 +0200
     6
     7pbs-python (4.4.0-1) unstable; urgency=low
    28
    39  * See CHANGES
  • trunk/examples/new_rack_pbsmon.py

    r315 r316  
    104104import curses
    105105curses.setupterm()
    106 if curses.tigetnum("colors") > 8:
     106if curses.tigetnum("colors") > 2:
    107107    TERMINAL_COLOR=True
    108108else:
  • trunk/pbs_python.spec

    r304 r316  
    44
    55Name: pbs_python
    6 Version: 4.4.0
     6Version: 4.4.1
    77Release: 1%{?dist}
    88License: See LICENSE
  • trunk/setup.py.in

    r313 r316  
    7070setup (
    7171    name = 'pbs_python',
    72     version = '4.4.0',
     72    version = '4.4.1',
    7373    description = 'openpbs/torque python interface',
    7474    license = 'LGPLV3',
  • trunk/src/C++/pbs.py

    r304 r316  
    952952  return d
    953953
    954 version_info = ( 4, 4, 0 )
    955 version = 'SARA pbs_python version 4.4.0'
     954version_info = ( 4, 4, 1 )
     955version = 'SARA pbs_python version 4.4.1'
    956956
    957957# A useful dict with error codes to text
  • trunk/src/C/pbs.py

    r304 r316  
    835835  return d
    836836
    837 version_info = ( 4, 4, 0 )
    838 version = 'SARA pbs_python version 4.4.0'
     837version_info = ( 4, 4, 1 )
     838version = 'SARA pbs_python version 4.4.1'
    839839
    840840# A useful dict with error codes to text
Note: See TracChangeset for help on using the changeset viewer.