Modify

Opened 7 years ago

Closed 6 years ago

Last modified 5 years ago

#34 closed enhancement (fixed)

pbs_python does not work with most recent TORQUE 4.2.0

Reported by: glen.beane@… Owned by: bas
Priority: blocker Milestone: Torque 4.X support
Component: pbs Version: 4.3.3
Keywords: Cc:

Description

TORQUE has switched to using g++ to compile. It appears there are some name mangling issues now as pbs_python is unable to find symbols:

ImportError?: /opt/compsci/python/2.7.3/lib/python2.7/site-packages/pbs/_pbs.so: undefined symbol: log_record

Attachments (0)

Change History (16)

comment:1 Changed 7 years ago by anonymous

I was able to get it to work by doing the following:

removing these functions from pbs_wrap.c and pbs.py in pbs_python:

log_record log_close log_open log_err log_event log_roll log_size chk_file_sec setup_env

comment:2 Changed 7 years ago by bas

Glen,

It is still on my todo list to port pbs_python to 4.2.0. The files are generated by swig. So i have to some work. It is good to know that some function do not exists anymore.

regards

PS) Currently we are evaluating slurm to replace our torque/maui setup

comment:3 Changed 7 years ago by bas

  • Type changed from defect to enhancement

comment:4 follow-up: Changed 6 years ago by glen.beane@…

If you do use Slurm to replace torque/maui is there a chance you could turn pbs_python over to someone that will be willing to maintain it and update it for recent versions of Torque? We have built a mission critical application around pbs_python and really need to see it maintained.

comment:5 in reply to: ↑ 4 Changed 6 years ago by bas

Replying to glen.beane@…:

If you do use Slurm to replace torque/maui is there a chance you could turn pbs_python over to someone that will be willing to maintain it and update it for recent versions of Torque? We have built a mission critical application around pbs_python and really need to see it maintained.

We still running torque/maui, but the old torque version. I have to setup torque 4.2 and then test the pbs_python stuff. I stiil make patches but that is also for the old toque versions.

Maybe there are volunteers to help port it to torque version 4.X

comment:6 Changed 6 years ago by glen.beane@…

there is no reason to call these functions from pbs_python anyway, so I think it would be safe to just remove them -- it shouldn't hurt anyone using an old version of torque.

comment:7 Changed 6 years ago by bas

Glen i am bit swamped lately but we use the log_ functions in our utilities. I need some time to port it to 4.X versions. we just upgraded to the latest 2.5 version. I know it is also end of release.

comment:8 Changed 6 years ago by anonymous

I think the porting issues to 4.2.4 are a little more involved.. I just noticed that calling get_mom_values against a worker causes pbs_mom to shut down.

Doesn't seem to be a crash.. it looks like a clean shutdown to me?

08/13/2013 16:15:47;0002; pbs_mom.29227;n/a;rm_request;shutdown 08/13/2013 16:15:47;0002; pbs_mom.29227;n/a;dep_cleanup;dependent cleanup 08/13/2013 16:15:47;0002; pbs_mom.29227;Svr;Log;Log closed

comment:9 Changed 6 years ago by anonymous

For what it is worth, I can confirm that the chages specified in the post regarding pbs_wrap.c and pbs.py for pbs_python fix pbs_python for Galaxy when using pbs_python-4.1.0 and pbs_python-4.3.5 for TORQUE 4.2.2 Some of the files appear to be named a little bit differently in the source folder (i.e. pbs_wrap_2.1.c and pbs_wrap_2.4.c). I could get this working by stripping out the functions from the files as described.

comment:10 Changed 6 years ago by anonymous

I'm the one that posted the work-around above.

pbs_wrap.c is a symlink that points to either pbs_wrap_2.1.c or pbs_wrap_2.4.c, so you need to edit the correct pbs_wrap_*.c and pbs*.py for your system (I think there was a bug in the version pbs_python TORQUE version detection that would cause it to chose pbs_wrap_2.1.c for modern versions of TORQUE. I'm not sure if this is still the case)

comment:11 Changed 6 years ago by anonymous

i posted some patches for 4.2 support in https://oss.trac.surfsara.nl/pbs_python/ticket/36. hope this helps things forward.

comment:12 Changed 6 years ago by bas

As today i have just installed 4.2-dev on a test node and succeeded in porting pbs_python to this torque release. I will release an updated pbs_python version shortly.

comment:13 Changed 6 years ago by bas

  • Status changed from new to assigned

comment:14 Changed 6 years ago by bas

  • Milestone set to Torque 4.X support

comment:15 Changed 6 years ago by bas

support is added in the trunk version that will shortly be released as version 4.4.0

comment:16 Changed 6 years ago by bas

  • Resolution set to fixed
  • Status changed from assigned to closed

Version 4.4.0 is released

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.