Modify

Opened 8 years ago

Closed 7 years ago

#44 closed task (fixed)

Make fail curl

Reported by: dmontaldo@dc.uba.ar Owned by: bas
Priority: major Milestone: SALI 1.6.0
Component: sali kernel/initrd Version: trunk
Keywords: debian, debian wheezy Cc:

Description

Compiling SALI in wheezy

libtool: link: gcc -g0 -O2 -Wno-system-headers -o .libs/curl hugehelp.o tool_binmode.o tool_bname.o tool_cb_dbg.o tool_cb_hdr.o tool_cb_prg.o tool_cb_rea.o tool_cb_see.o tool_cb_skt.o tool_cb_wrt.o tool_cfgable.o tool_convert.o tool_dirhie.o tool_doswin.o tool_easysrc.o tool_formparse.o tool_getparam.o tool_getpass.o tool_help.o tool_helpers.o tool_homedir.o tool_libinfo.o tool_main.o tool_mfiles.o tool_msgs.o tool_operate.o tool_operhlp.o tool_panykey.o tool_paramhlp.o tool_parsecfg.o tool_setopt.o tool_sleep.o tool_urlglob.o tool_util.o tool_vms.o tool_writeenv.o tool_writeout.o tool_xattr.o strtoofft.o strdup.o rawstr.o nonblock.o  -L/home/dmontaldo/sali/trunk/src/openssl-0.9.8r/lib ../lib/.libs/libcurl.so -lrt -lz
../lib/.libs/libcurl.so: undefined reference to `SSLv2_client_method'
collect2: error: ld returned 1 exit status
make[3]: *** [curl] Error 1
make[3]: Leaving directory `/home/dmontaldo/sali/trunk/src/curl-7.23.1/src'
make[2]: *** [install] Error 2
make[2]: Leaving directory `/home/dmontaldo/sali/trunk/src/curl-7.23.1/src'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/home/dmontaldo/sali/trunk/src/curl-7.23.1'
make: *** [/home/dmontaldo/sali/trunk/src/curl-7.23.1.install] Error 2

I don't know how to pass this error because despite of a bug report in debian, that version must work.
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=622016

Thanks.

Attachments (0)

Change History (6)

comment:1 Changed 8 years ago by dmontaldo@dc.uba.ar

With the latest version of curl I can confirm that in debian wheezy at least compiles.

# svn diff initrd/make.d/curl.rul
Index: initrd/make.d/curl.rul
===================================================================
--- initrd/make.d/curl.rul      (revision 511)
+++ initrd/make.d/curl.rul      (working copy)
@@ -3,11 +3,11 @@
 #   vi: set filetype=make:
 #
 
-CURL_VERSION   = 7.23.1
+CURL_VERSION   = 7.26.0
 CURL_TARBALL   = curl-$(CURL_VERSION).tar.bz2
 
 ### download = http://curl.haxx.se/download.html 
-CURL_URL       = ftp://ftp.sara.nl/pub/sali/sources/curl-$(CURL_VERSION).tar.bz2
+CURL_URL       = http://curl.haxx.se/download/curl-$(CURL_VERSION).tar.bz2
 CURL_INFO      = http://curl.haxx.se/
 
 CURL_DIR       = $(SRC_DIR)/curl-$(CURL_VERSION)

I still trying to get sali working.
Thanks.

comment:2 Changed 8 years ago by bas

  • Owner changed from somebody to bas
  • Status changed from new to accepted

Thanks we will switch to this version when we our build system is wheezy

comment:3 Changed 8 years ago by bas

  • Component changed from sali to sali kernel/initrd
  • Type changed from defect to task

comment:4 Changed 8 years ago by dennis

  • Priority changed from blocker to major

comment:5 Changed 8 years ago by dennis

  • Milestone set to SALI 1.6.0

comment:6 Changed 7 years ago by dennis

  • Resolution set to fixed
  • Status changed from accepted to closed

This has been fixed in the current trunk version, which will be released as version 1.6.0

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.