Opened 13 years ago

Closed 9 years ago

#58 closed defect (worksforme)

Error on php with 0.3.1

Reported by: leotavaneiro@… Owned by: ramonb
Priority: critical Milestone: 1.0
Component: web Version: 0.3
Keywords: Cc:
Estimated Number of Hours:

Description

Hi, I'm getting a blank image on cluster page on ganglia and it is not showing the running jobs.

[Fri Jul 04 13:45:52 2008] [error] [client 10.25.28.31] PHP Warning: Invalid argument supplied for foreach() in /var/www/html/mpet_linux/addons/job_monarch/libtoga.php on line 39, referer: http://ganglia2/mpet_linux/?m=load_one&r=hour&s=descending&c=MPET+Linux+bwr4&h=&sh=1&hc=4

Attachments (1)

jobmonarch.jpg (119.8 KB) - added by leotavaneiro@… 13 years ago.
Image of the graphics not updated

Download all attachments as: .zip

Change History (10)

comment:1 Changed 13 years ago by ramonb

  • Owner changed from somebody to ramonb
  • Status changed from new to assigned

comment:2 Changed 13 years ago by ramonb

what version of PHP are you using?

comment:3 Changed 13 years ago by ramonb

  • Cc leotavaneiro@… added

what version are you using of:

  • PHP
  • Ganglia

?

comment:4 Changed 13 years ago by ramonb

Ah I read your email on jobmonarch-users list, think this is PHP5 related.

comment:6 Changed 13 years ago by leotavaneiro@…

With the new version, the error is gone. Thanks.

comment:7 follow-up: Changed 13 years ago by leotavaneiro@…

I still got a strange behaviour on job monarch jobs page. The status are not updated on the pie chart graphic and on the nodes grid. I attached a image of the problem. I don't know if it is related to the previous problem... Thanks again for the help.

Changed 13 years ago by leotavaneiro@…

Image of the graphics not updated

comment:8 in reply to: ↑ 7 Changed 13 years ago by anonymous

Replying to leotavaneiro@gmail.com:

I still got a strange behaviour on job monarch jobs page. The status are not updated on the pie chart graphic and on the nodes grid. I attached a image of the problem. I don't know if it is related to the previous problem... Thanks again for the help.

Sorry, I forgot a detail. The graphics are not updated as the jobs runs, so, older jobs informations still there. Thanks.

comment:9 Changed 9 years ago by ramonb

  • Cc leotavaneiro@… removed
  • Milestone set to 1.0
  • Resolution set to worksforme
  • Status changed from assigned to closed

fixed in 1.0

Note: See TracTickets for help on using tickets.