Opened 13 years ago

Closed 13 years ago

#31 closed defect (fixed)

Upgrade of dellomsa clobbers changes to /etc/pam.d/omauth (packaging bug)

Reported by: davee@… Owned by: bas
Priority: minor Milestone: 5.5.0-5
Version: trunk Keywords:
Cc:

Description

I ran apt-get upgrade on my amd64 Debian system today, which pulled down an updated copy of dellomsa. I got 5.5.0-3, previously 5.5.0-1 I think.

Logins to the web interface immediately broke and I discovered this was due to the fact that the new package had clobbered the changes I'd made to /etc/pam.d/omauth as per the FAQ to allow it to work on amd64 systems.

The Debian package should treat config files as conffiles and only replace them if they are unmodified.

Change History (2)

comment:1 Changed 13 years ago by bas

  • Owner set to bas
  • Status changed from new to assigned

Your are right. We do not use the webnterface so we never encounter this problem. See #30 for other fixes for the amd64 package

comment:2 Changed 13 years ago by bas

  • Milestone set to 5.5.0-5
  • Resolution set to fixed
  • Status changed from assigned to closed
  • Version changed from 5.5.0 to trunk

omauth is now a config file

Note: See TracTickets for help on using tickets.