source: trunk/debian/changelog @ 264

Last change on this file since 264 was 264, checked in by bas, 13 years ago

COPYING:

  • added GPL3 version

COPYING.LESSER:

  • renamed LICENSE.SARA

debian/copyright:

  • added some more info about the different licenses

src/PBSQuery.py:

  • some real code changes ;-)
File size: 8.5 KB
RevLine 
[264]1pbs-python (4.3.0-1) lenny; urgency=low
2
3  * See CHANGES
4
5 -- Bas van der Vlies <bas@sara.nl>  Fri, 05 Nov 2010 09:04:29 +0100
6
[259]7pbs-python (4.2.0-2) lenny; urgency=low
[242]8
9  * Update LICENSE file to LGPLV3
10  * patched pbsmon.py for torque 2.5
[253]11  * see CHANGES for complete list
[242]12
[253]13 -- Bas van der Vlies <bas@sara.nl>  Thu, 10 Jun 2010 10:27:43 +0200
[242]14
[240]15pbs-python (4.1.2-1) lenny; urgency=low
16
17  * See changes not yes finishedm but some important fixes
18
19 -- bas van der Vlies <basv@sara.nl>  Thu, 20 May 2010 11:11:21 +0200
20
[237]21pbs-python (4.1.0-1) lenny; urgency=low
22
23  * See CHANGES file
24
25 -- bas van der Vlies <bas@sara.nl>  Thu, 29 Apr 2010 13:24:24 +0200
26
[233]27pbs-python (4.0.2-1) lenny; urgency=low
28
29  * See CHANGES file
30
31 -- bas van der Vlies <bas@sara.nl>  Fri, 23 Apr 2010 10:27:58 +0200
32
[231]33pbs-python (4.0.1-1) lenny; urgency=low
34
35  * See CHANGES file
36
37 -- bas van der Vlies <bas@sara.nl>  Wed, 21 Apr 2010 08:26:02 +0200
38
[219]39pbs-python (4.0.0-1) lenny; urgency=low
40
[231]41  * See CHANGES file
[219]42
43 -- Bas van der Vlies <basv@sara.nl>  Fri, 09 Apr 2010 09:43:24 +0200
44
[208]45pbs-python (3.6.0-1) lenny; urgency=low
46
47  * New generated files pbs_wrap.c and pbs.py fixes an error in pbs_runjob()
48
[215]49 -- Bas van der Vlies <basv@sara.nl>  Fri, 15 Jan 2010 04:40:35 +0100
[208]50
[205]51pbs-python (3.5.0-1) lenny; urgency=low
[196]52
53  * PBSQuery
[205]54        The class functions of node, job and queue support old and new data
[196]55        structure.
[205]56
[208]57    Changed the behaviour of the new data stucture, We can use it as
58    dictionary and as class attribute, this is equivalent, eg:
59      - print node['np'] and print node.np
[205]60
[208]61    for a node we parse the 'status' line and split on '=' char, You now can
62    use these statements, eg
63     - print node.status.arch     (node['status'].arch or node['status']['arch'])
64     - print node.status.nsession
[205]65
[208]66    for a job we parse the 'Variable_List' line and split on '=' char, You now can
67    use the statements, eg:
68     - print job.Variable_List.PBS_O_WORKDIR
69     - print job.Variable_List.PBS_O_HOME
[205]70
[208]71    for more info see examples/new_interface.py
[205]72
[196]73    Author: Bas van der Vlies
74
[208]75  * new_rack_pbsmon.py
76    Rewrite to new data structure and automatically determine how many nodes
77    and racks cluster has and skip printing of empty racks (default), use -w/--wide
78    for old behaviour.
[201]79
[208]80    Author: Bas van der Vlies
[196]81
[208]82 -- Bas van der Vlies <bas@sara.nl>  Mon, 12 Nov 2009 15:03:16 +0200
83
[189]84pbs-python (3.2.0-1) intrepid; urgency=low
85
86  *  PBSQuery:
[208]87     New data structure. In the old structure it is a dictionary
88     with a value and the value is a string. This is changed that
89     dictionary values are now of type list or dictionary depends
90     on the value of keyword, eg for a node:
91       - np = 2:
92       - node['np'] = [ '2' ]
93       - properties = cores2, mem4gb, parallel
94       - node['properties'] = [ 'cores2', 'mem4gb', 'parallel' ]
95       - status = arch=x86_64,sessions=22599,,size=70627864kb, ...
96       - node['status']['arch'] = [ 'x86_64' ]
97       - node['status']['sessions'] = [ '222599' ]
98       - ...
[189]99
100         The data structure is activated by the function:
101          - new_data_structure()
102
103         In a future release it will be come the default.
104         example:
[208]105         p = PBSQuery()
106         p.new_data_structure()
[189]107
[208]108        nodes = p.getnodes()
109        print nodes.np, nodes['np']
[189]110
111         Author: Bas van der Vlies
112
[191]113  *  PBSQuery:
114        For old and new data structure we now can use another syntax:
[208]115     - node['np'] and node.np are equivalent
[189]116
[191]117        This new syntax works for all keywords.
118        Author: Bas van der Vlies
[189]119
[191]120  *  PBSQuery:
121        Added iter object for job, node, queue and server objects, eg:
[208]122        node = p.getnode('gb-r1n1')
123        print node.name
124        for attrib in node:
125           print '%\t%s = %s' %(attrib, node[attrib])
[191]126        Author: Bas van der Vlies
[189]127
[196]128  *  PBSQuery:
129        fixed an error in getnode, getqueue and getjob, return
130        empty dictionary if not found.
131        Author: Bas van der Vlies
[191]132
133  *  PBSQuery:
[196]134        New build system for rpm packages, make -f Makefile.rpm
135        Author: Michel Jouvin <jouvin add lal dot in2p3 dot fr>
136        Applied: Bas van der Vlies
[191]137
138 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 14 May 2009 13:41:00 +0200
139
[186]140pbs-python (3.0.1-2) intrepid; urgency=low
141
142  * adjust number of nodes to 32
143
144 -- root <root@rc.sara.nl>  Tue, 17 Mar 2009 18:17:18 +0100
145
[184]146pbs-python (3.0.1-1) intrepid; urgency=low
147
148  * Small bug fix
149
150 -- root <root@rc.sara.nl>  Wed, 28 Jan 2009 13:58:43 +0100
151
[176]152pbs-python (3.0.0-1) intrepid; urgency=low
153
[178]154  * New api for PBSQuery and build on any architecture
[176]155
156 -- Bas van der Vlies <bas@sara.nl>  Tue, 11 Nov 2008 12:48:39 +0100
157
[172]158pbs-python (2.9.8-3) intrepid; urgency=low
159
160  * New functions added to PBSQuery
161
162 -- Bas van der Vlies <basv@sara.nl>  Fri, 10 Oct 2008 11:18:38 +0200
163
[168]164pbs-python (2.9.8-2) intrepid; urgency=low
165
166  * New PBSQuery module
167
168 -- Bas van der Vlies <bas@sara.nl>  Wed,  8 Oct 2008 14:05:44 +0200
169
[159]170pbs-python (2.9.8-1) intrepid; urgency=low
171
172  * New version with updated torque header file (version 2.X)
173
174 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 24 Sep 2008 12:32:29 +0200
175
[154]176pbs-python (2.9.6-1) intrepid; urgency=low
[152]177
[153]178  * pbs_python.spec file patch added libdir and python defines so it
179    will build for RHEL5.1/CentOS 5.1 (by Michael Sternberg) and some
180    minor changes to the pbs_ifl.h file
[152]181
[155]182 -- Dennis Stam <dennis.stam@sara.nl>  Thu, 18 Sep 2008 11:23:16 +0200
[152]183
[144]184pbs-python (2.9.4-1) unstable; urgency=low
185
186  * New version with all the fixes as mentioned below
187
188 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 16 Nov 2006 14:29:16 +0100
189
[143]190pbs-python (2.9.2-4) unstable; urgency=low
191
192  * PBSQuery: Make use of UserDict module
193
194 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 18 Oct 2006 11:46:34 +0200
195
[137]196pbs-python (2.9.2-3) unstable; urgency=low
197
198  *  Fixed a has_key bug must return zero instead of None
199     Thanks to Ramon Bastiaans for reporting
200
201 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 13 Oct 2006 15:33:25 +0200
202
[136]203pbs-python (2.9.2-2) unstable; urgency=low
204
205  * new_rack_pbsmon.py fixes serial/parallel calculations
206
207 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 10 Oct 2006 12:13:25 +0200
208
[129]209pbs-python (2.9.2-1) unstable; urgency=low
210
211  * New upstream version, read CHANGES file
212
213 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 19 Sep 2006 16:17:54 +0200
214
[116]215pbs-python (2.9.1-6) unstable; urgency=low
216
217  *  New torque build system
218
219 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 21 Jul 2006 10:41:31 +0200
220
[115]221pbs-python (2.9.1-5) unstable; urgency=low
222
223  * Down state has most priority. So display it
224
225 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 16 Jun 2006 14:44:48 +0200
226
[114]227pbs-python (2.9.1-4) unstable; urgency=low
228
229  *  Added sara_install to Makefile.in. Else
230     no new pbsmon for SARA
231
232 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 15 Jun 2006 12:23:54 +0200
233
[113]234pbs-python (2.9.1-3) unstable; urgency=low
235
236  * New version adjusted new_rack_pbsmon.py to 39 racks
237
238 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Jun 2006 11:56:26 +0200
239
[112]240pbs-python (2.9.1-2) unstable; urgency=low
241
242  * Fixed a bug in new_rack_pbsmon.py
243
244 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 26 May 2006 16:41:35 +0200
245
[110]246pbs-python (2.9.0-1) unstable; urgency=low
247
248  * Added new build system for torque 2.1.0 and higher
249
250 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 20 Apr 2006 14:25:21 +0200
251
[109]252pbs-python (2.8.2-3) unstable; urgency=low
253
254  * Changed new_rack_pbsmon.py script by walter
255
256 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 13 Apr 2006 14:10:36 +0200
257
[108]258pbs-python (2.8.2-2) unstable; urgency=low
259
260  *  Fixed Makefile.in, now right script
261
262 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  7 Apr 2006 10:59:35 +0200
263
[107]264pbs-python (2.8.2-1) unstable; urgency=low
[105]265
266  *  Added new pbsmon example: new_rack_pbsmon.py uses PBSQuery
267
268 -- Bas van der Vlies <bas@rc.sara.nl>  Thu,  6 Apr 2006 15:12:03 +0200
269
[92]270pbs-python (2.8.0-2) unstable; urgency=medium
271
272  * Used swig 1.3.24 with python2.1 works also on higher python versions
273
274 -- Bas van der Vlies <bas@rc.sara.nl>  Mon,  7 Nov 2005 14:55:00 +0100
275
[90]276pbs-python (2.8.0-1) unstable; urgency=low
277
278  * New pbs_python release, See CHANGES
279
280 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  4 Nov 2005 15:58:44 +0100
281
[86]282pbs-python (2.7.10-1) unstable; urgency=low
283
284  * Added examples/LICENSE.sara to /usr/share/doc directory
285  * Made an sara_install section for pbsmon --> examples/rack_pbsmon.py
286
287 -- Bas van der Vlies <basv@sara.nl>  Mon, 26 Sep 2005 16:32:06 +0200
288
[82]289pbs-python (2.7.9-2) unstable; urgency=low
290
291  * Bumped up version
292  * Fixed  DEBUG mode
293
294 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 24 Jun 2005 11:23:30 +0200
295
[72]296pbs-python (2.7.5-1) unstable; urgency=low
[64]297
298  * Initial version
299
300 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 1 Nov 2004 12:13:08 -0400
301
Note: See TracBrowser for help on using the repository browser.