source: trunk/debian/changelog @ 288

Last change on this file since 288 was 288, checked in by dennis, 11 years ago

Some minor changes

File size: 9.1 KB
RevLine 
[288]1pbs-python (4.3.4-2) lenny; urgency=low
2
3  * Removed gb- from REGEX new_rack
4
5 -- Dennis Stam <dennis.stam@surfsara.nl>  Tue, 19 Feb 2013 16:54:39 +0100
6
[279]7pbs-python (4.3.4-1) lenny; urgency=low
8
9  * See CHANGES
[282]10  * install pbs_jobmonitor and pbs_joblogin in /usr/bin
[279]11
12 -- Bas van der Vlies <basv@sara.nl>  Fri, 27 Apr 2012 09:54:54 +0200
13
[271]14pbs-python (4.3.3-1) lenny; urgency=low
15
16  * see CHANGES
17
18 -- Bas van der Vlies <basv@sara.nl>  Tue, 03 Jan 2012 12:01:15 +0100
19
[270]20pbs-python (4.3.1-1) lenny; urgency=low
21
22  * see CHANGES
23
24 -- Bas van der Vlies <bas@sara.nl>  Wed, 24 Aug 2011 14:08:09 +0200
25
[264]26pbs-python (4.3.0-1) lenny; urgency=low
27
28  * See CHANGES
29
30 -- Bas van der Vlies <bas@sara.nl>  Fri, 05 Nov 2010 09:04:29 +0100
31
[259]32pbs-python (4.2.0-2) lenny; urgency=low
[242]33
34  * Update LICENSE file to LGPLV3
35  * patched pbsmon.py for torque 2.5
[253]36  * see CHANGES for complete list
[242]37
[253]38 -- Bas van der Vlies <bas@sara.nl>  Thu, 10 Jun 2010 10:27:43 +0200
[242]39
[240]40pbs-python (4.1.2-1) lenny; urgency=low
41
42  * See changes not yes finishedm but some important fixes
43
44 -- bas van der Vlies <basv@sara.nl>  Thu, 20 May 2010 11:11:21 +0200
45
[237]46pbs-python (4.1.0-1) lenny; urgency=low
47
48  * See CHANGES file
49
50 -- bas van der Vlies <bas@sara.nl>  Thu, 29 Apr 2010 13:24:24 +0200
51
[233]52pbs-python (4.0.2-1) lenny; urgency=low
53
54  * See CHANGES file
55
56 -- bas van der Vlies <bas@sara.nl>  Fri, 23 Apr 2010 10:27:58 +0200
57
[231]58pbs-python (4.0.1-1) lenny; urgency=low
59
60  * See CHANGES file
61
62 -- bas van der Vlies <bas@sara.nl>  Wed, 21 Apr 2010 08:26:02 +0200
63
[219]64pbs-python (4.0.0-1) lenny; urgency=low
65
[231]66  * See CHANGES file
[219]67
68 -- Bas van der Vlies <basv@sara.nl>  Fri, 09 Apr 2010 09:43:24 +0200
69
[208]70pbs-python (3.6.0-1) lenny; urgency=low
71
72  * New generated files pbs_wrap.c and pbs.py fixes an error in pbs_runjob()
73
[215]74 -- Bas van der Vlies <basv@sara.nl>  Fri, 15 Jan 2010 04:40:35 +0100
[208]75
[205]76pbs-python (3.5.0-1) lenny; urgency=low
[196]77
78  * PBSQuery
[205]79        The class functions of node, job and queue support old and new data
[196]80        structure.
[205]81
[208]82    Changed the behaviour of the new data stucture, We can use it as
83    dictionary and as class attribute, this is equivalent, eg:
84      - print node['np'] and print node.np
[205]85
[208]86    for a node we parse the 'status' line and split on '=' char, You now can
87    use these statements, eg
88     - print node.status.arch     (node['status'].arch or node['status']['arch'])
89     - print node.status.nsession
[205]90
[208]91    for a job we parse the 'Variable_List' line and split on '=' char, You now can
92    use the statements, eg:
93     - print job.Variable_List.PBS_O_WORKDIR
94     - print job.Variable_List.PBS_O_HOME
[205]95
[208]96    for more info see examples/new_interface.py
[205]97
[196]98    Author: Bas van der Vlies
99
[208]100  * new_rack_pbsmon.py
101    Rewrite to new data structure and automatically determine how many nodes
102    and racks cluster has and skip printing of empty racks (default), use -w/--wide
103    for old behaviour.
[201]104
[208]105    Author: Bas van der Vlies
[196]106
[208]107 -- Bas van der Vlies <bas@sara.nl>  Mon, 12 Nov 2009 15:03:16 +0200
108
[189]109pbs-python (3.2.0-1) intrepid; urgency=low
110
111  *  PBSQuery:
[208]112     New data structure. In the old structure it is a dictionary
113     with a value and the value is a string. This is changed that
114     dictionary values are now of type list or dictionary depends
115     on the value of keyword, eg for a node:
116       - np = 2:
117       - node['np'] = [ '2' ]
118       - properties = cores2, mem4gb, parallel
119       - node['properties'] = [ 'cores2', 'mem4gb', 'parallel' ]
120       - status = arch=x86_64,sessions=22599,,size=70627864kb, ...
121       - node['status']['arch'] = [ 'x86_64' ]
122       - node['status']['sessions'] = [ '222599' ]
123       - ...
[189]124
125         The data structure is activated by the function:
126          - new_data_structure()
127
128         In a future release it will be come the default.
129         example:
[208]130         p = PBSQuery()
131         p.new_data_structure()
[189]132
[208]133        nodes = p.getnodes()
134        print nodes.np, nodes['np']
[189]135
136         Author: Bas van der Vlies
137
[191]138  *  PBSQuery:
139        For old and new data structure we now can use another syntax:
[208]140     - node['np'] and node.np are equivalent
[189]141
[191]142        This new syntax works for all keywords.
143        Author: Bas van der Vlies
[189]144
[191]145  *  PBSQuery:
146        Added iter object for job, node, queue and server objects, eg:
[208]147        node = p.getnode('gb-r1n1')
148        print node.name
149        for attrib in node:
150           print '%\t%s = %s' %(attrib, node[attrib])
[191]151        Author: Bas van der Vlies
[189]152
[196]153  *  PBSQuery:
154        fixed an error in getnode, getqueue and getjob, return
155        empty dictionary if not found.
156        Author: Bas van der Vlies
[191]157
158  *  PBSQuery:
[196]159        New build system for rpm packages, make -f Makefile.rpm
160        Author: Michel Jouvin <jouvin add lal dot in2p3 dot fr>
161        Applied: Bas van der Vlies
[191]162
163 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 14 May 2009 13:41:00 +0200
164
[186]165pbs-python (3.0.1-2) intrepid; urgency=low
166
167  * adjust number of nodes to 32
168
169 -- root <root@rc.sara.nl>  Tue, 17 Mar 2009 18:17:18 +0100
170
[184]171pbs-python (3.0.1-1) intrepid; urgency=low
172
173  * Small bug fix
174
175 -- root <root@rc.sara.nl>  Wed, 28 Jan 2009 13:58:43 +0100
176
[176]177pbs-python (3.0.0-1) intrepid; urgency=low
178
[178]179  * New api for PBSQuery and build on any architecture
[176]180
181 -- Bas van der Vlies <bas@sara.nl>  Tue, 11 Nov 2008 12:48:39 +0100
182
[172]183pbs-python (2.9.8-3) intrepid; urgency=low
184
185  * New functions added to PBSQuery
186
187 -- Bas van der Vlies <basv@sara.nl>  Fri, 10 Oct 2008 11:18:38 +0200
188
[168]189pbs-python (2.9.8-2) intrepid; urgency=low
190
191  * New PBSQuery module
192
193 -- Bas van der Vlies <bas@sara.nl>  Wed,  8 Oct 2008 14:05:44 +0200
194
[159]195pbs-python (2.9.8-1) intrepid; urgency=low
196
197  * New version with updated torque header file (version 2.X)
198
199 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 24 Sep 2008 12:32:29 +0200
200
[154]201pbs-python (2.9.6-1) intrepid; urgency=low
[152]202
[153]203  * pbs_python.spec file patch added libdir and python defines so it
204    will build for RHEL5.1/CentOS 5.1 (by Michael Sternberg) and some
205    minor changes to the pbs_ifl.h file
[152]206
[155]207 -- Dennis Stam <dennis.stam@sara.nl>  Thu, 18 Sep 2008 11:23:16 +0200
[152]208
[144]209pbs-python (2.9.4-1) unstable; urgency=low
210
211  * New version with all the fixes as mentioned below
212
213 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 16 Nov 2006 14:29:16 +0100
214
[143]215pbs-python (2.9.2-4) unstable; urgency=low
216
217  * PBSQuery: Make use of UserDict module
218
219 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 18 Oct 2006 11:46:34 +0200
220
[137]221pbs-python (2.9.2-3) unstable; urgency=low
222
223  *  Fixed a has_key bug must return zero instead of None
224     Thanks to Ramon Bastiaans for reporting
225
226 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 13 Oct 2006 15:33:25 +0200
227
[136]228pbs-python (2.9.2-2) unstable; urgency=low
229
230  * new_rack_pbsmon.py fixes serial/parallel calculations
231
232 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 10 Oct 2006 12:13:25 +0200
233
[129]234pbs-python (2.9.2-1) unstable; urgency=low
235
236  * New upstream version, read CHANGES file
237
238 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 19 Sep 2006 16:17:54 +0200
239
[116]240pbs-python (2.9.1-6) unstable; urgency=low
241
242  *  New torque build system
243
244 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 21 Jul 2006 10:41:31 +0200
245
[115]246pbs-python (2.9.1-5) unstable; urgency=low
247
248  * Down state has most priority. So display it
249
250 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 16 Jun 2006 14:44:48 +0200
251
[114]252pbs-python (2.9.1-4) unstable; urgency=low
253
254  *  Added sara_install to Makefile.in. Else
255     no new pbsmon for SARA
256
257 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 15 Jun 2006 12:23:54 +0200
258
[113]259pbs-python (2.9.1-3) unstable; urgency=low
260
261  * New version adjusted new_rack_pbsmon.py to 39 racks
262
263 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Jun 2006 11:56:26 +0200
264
[112]265pbs-python (2.9.1-2) unstable; urgency=low
266
267  * Fixed a bug in new_rack_pbsmon.py
268
269 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 26 May 2006 16:41:35 +0200
270
[110]271pbs-python (2.9.0-1) unstable; urgency=low
272
273  * Added new build system for torque 2.1.0 and higher
274
275 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 20 Apr 2006 14:25:21 +0200
276
[109]277pbs-python (2.8.2-3) unstable; urgency=low
278
279  * Changed new_rack_pbsmon.py script by walter
280
281 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 13 Apr 2006 14:10:36 +0200
282
[108]283pbs-python (2.8.2-2) unstable; urgency=low
284
285  *  Fixed Makefile.in, now right script
286
287 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  7 Apr 2006 10:59:35 +0200
288
[107]289pbs-python (2.8.2-1) unstable; urgency=low
[105]290
291  *  Added new pbsmon example: new_rack_pbsmon.py uses PBSQuery
292
293 -- Bas van der Vlies <bas@rc.sara.nl>  Thu,  6 Apr 2006 15:12:03 +0200
294
[92]295pbs-python (2.8.0-2) unstable; urgency=medium
296
297  * Used swig 1.3.24 with python2.1 works also on higher python versions
298
299 -- Bas van der Vlies <bas@rc.sara.nl>  Mon,  7 Nov 2005 14:55:00 +0100
300
[90]301pbs-python (2.8.0-1) unstable; urgency=low
302
303  * New pbs_python release, See CHANGES
304
305 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  4 Nov 2005 15:58:44 +0100
306
[86]307pbs-python (2.7.10-1) unstable; urgency=low
308
309  * Added examples/LICENSE.sara to /usr/share/doc directory
310  * Made an sara_install section for pbsmon --> examples/rack_pbsmon.py
311
312 -- Bas van der Vlies <basv@sara.nl>  Mon, 26 Sep 2005 16:32:06 +0200
313
[82]314pbs-python (2.7.9-2) unstable; urgency=low
315
316  * Bumped up version
317  * Fixed  DEBUG mode
318
319 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 24 Jun 2005 11:23:30 +0200
320
[72]321pbs-python (2.7.5-1) unstable; urgency=low
[64]322
323  * Initial version
324
325 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 1 Nov 2004 12:13:08 -0400
326
Note: See TracBrowser for help on using the repository browser.