source: trunk/debian/changelog @ 191

Last change on this file since 191 was 191, checked in by bas, 15 years ago

src/PBSQuery.py:

  • fixed an error in the getnode, getqueue and getjob functions

update changes

File size: 6.1 KB
Line 
1pbs-python (3.2.0-1) intrepid; urgency=low
2
3  *  PBSQuery:
4         New data structure. In the old structure it is a dictionary
5         with a value and the value is a string. This is changed that
6         dictionary values are now of type list or dictionary depends
7         on the value of keyword, eg for a node:
8          - np = 2:
9                - node['np'] = [ '2' ]
10          - properties = cores2, mem4gb, parallel
11                - node['properties'] = [ 'cores2', 'mem4gb', 'parallel' ]
12          - status = arch=x86_64,sessions=22599,,size=70627864kb, ...
13                - node['status']['arch'] = [ 'x86_64' ]
14                - node['status']['sessions'] = [ '222599' ]
15                - ...
16
17         The data structure is activated by the function:
18          - new_data_structure()
19
20         In a future release it will be come the default.
21         example:
22                p = PBSQuery()
23                p.new_data_structure()
24
25                nodes = p.getnodes()
26                print nodes.np, nodes['np']
27
28         Author: Bas van der Vlies
29
30  *  PBSQuery:
31        For old and new data structure we now can use another syntax:
32         - node['np'] and node.np are equivalent
33
34        This new syntax works for all keywords.
35        Author: Bas van der Vlies
36
37  *  PBSQuery:
38        Added iter object for job, node, queue and server objects, eg:
39                node = p.getnode('gb-r1n1')
40                print node.name
41                for attrib in node:
42                        print '%\t%s = %s' %(attrib, node[attrib])
43        Author: Bas van der Vlies
44
45  *  PBSQuery:
46        fixed an error in getnode, getqueue and getjob, return
47        empty dictionary if not found.
48        Author: Bas van der Vlies
49
50  *  PBSQuery:
51        New build system for rpm packages, make -f Makefile.rpm
52        Author: Michel Jouvin <jouvin add lal dot in2p3 dot fr>
53        Applied: Bas van der Vlies
54
55 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 14 May 2009 13:41:00 +0200
56
57pbs-python (3.0.1-2) intrepid; urgency=low
58
59  * adjust number of nodes to 32
60
61 -- root <root@rc.sara.nl>  Tue, 17 Mar 2009 18:17:18 +0100
62
63pbs-python (3.0.1-1) intrepid; urgency=low
64
65  * Small bug fix
66
67 -- root <root@rc.sara.nl>  Wed, 28 Jan 2009 13:58:43 +0100
68
69pbs-python (3.0.0-1) intrepid; urgency=low
70
71  * New api for PBSQuery and build on any architecture
72
73 -- Bas van der Vlies <bas@sara.nl>  Tue, 11 Nov 2008 12:48:39 +0100
74
75pbs-python (2.9.8-3) intrepid; urgency=low
76
77  * New functions added to PBSQuery
78
79 -- Bas van der Vlies <basv@sara.nl>  Fri, 10 Oct 2008 11:18:38 +0200
80
81pbs-python (2.9.8-2) intrepid; urgency=low
82
83  * New PBSQuery module
84
85 -- Bas van der Vlies <bas@sara.nl>  Wed,  8 Oct 2008 14:05:44 +0200
86
87pbs-python (2.9.8-1) intrepid; urgency=low
88
89  * New version with updated torque header file (version 2.X)
90
91 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 24 Sep 2008 12:32:29 +0200
92
93pbs-python (2.9.6-1) intrepid; urgency=low
94
95  * pbs_python.spec file patch added libdir and python defines so it
96    will build for RHEL5.1/CentOS 5.1 (by Michael Sternberg) and some
97    minor changes to the pbs_ifl.h file
98
99 -- Dennis Stam <dennis.stam@sara.nl>  Thu, 18 Sep 2008 11:23:16 +0200
100
101pbs-python (2.9.4-1) unstable; urgency=low
102
103  * New version with all the fixes as mentioned below
104
105 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 16 Nov 2006 14:29:16 +0100
106
107pbs-python (2.9.2-4) unstable; urgency=low
108
109  * PBSQuery: Make use of UserDict module
110
111 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 18 Oct 2006 11:46:34 +0200
112
113pbs-python (2.9.2-3) unstable; urgency=low
114
115  *  Fixed a has_key bug must return zero instead of None
116     Thanks to Ramon Bastiaans for reporting
117
118 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 13 Oct 2006 15:33:25 +0200
119
120pbs-python (2.9.2-2) unstable; urgency=low
121
122  * new_rack_pbsmon.py fixes serial/parallel calculations
123
124 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 10 Oct 2006 12:13:25 +0200
125
126pbs-python (2.9.2-1) unstable; urgency=low
127
128  * New upstream version, read CHANGES file
129
130 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 19 Sep 2006 16:17:54 +0200
131
132pbs-python (2.9.1-6) unstable; urgency=low
133
134  *  New torque build system
135
136 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 21 Jul 2006 10:41:31 +0200
137
138pbs-python (2.9.1-5) unstable; urgency=low
139
140  * Down state has most priority. So display it
141
142 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 16 Jun 2006 14:44:48 +0200
143
144pbs-python (2.9.1-4) unstable; urgency=low
145
146  *  Added sara_install to Makefile.in. Else
147     no new pbsmon for SARA
148
149 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 15 Jun 2006 12:23:54 +0200
150
151pbs-python (2.9.1-3) unstable; urgency=low
152
153  * New version adjusted new_rack_pbsmon.py to 39 racks
154
155 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Jun 2006 11:56:26 +0200
156
157pbs-python (2.9.1-2) unstable; urgency=low
158
159  * Fixed a bug in new_rack_pbsmon.py
160
161 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 26 May 2006 16:41:35 +0200
162
163pbs-python (2.9.0-1) unstable; urgency=low
164
165  * Added new build system for torque 2.1.0 and higher
166
167 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 20 Apr 2006 14:25:21 +0200
168
169pbs-python (2.8.2-3) unstable; urgency=low
170
171  * Changed new_rack_pbsmon.py script by walter
172
173 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 13 Apr 2006 14:10:36 +0200
174
175pbs-python (2.8.2-2) unstable; urgency=low
176
177  *  Fixed Makefile.in, now right script
178
179 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  7 Apr 2006 10:59:35 +0200
180
181pbs-python (2.8.2-1) unstable; urgency=low
182
183  *  Added new pbsmon example: new_rack_pbsmon.py uses PBSQuery
184
185 -- Bas van der Vlies <bas@rc.sara.nl>  Thu,  6 Apr 2006 15:12:03 +0200
186
187pbs-python (2.8.0-2) unstable; urgency=medium
188
189  * Used swig 1.3.24 with python2.1 works also on higher python versions
190
191 -- Bas van der Vlies <bas@rc.sara.nl>  Mon,  7 Nov 2005 14:55:00 +0100
192
193pbs-python (2.8.0-1) unstable; urgency=low
194
195  * New pbs_python release, See CHANGES
196
197 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  4 Nov 2005 15:58:44 +0100
198
199pbs-python (2.7.10-1) unstable; urgency=low
200
201  * Added examples/LICENSE.sara to /usr/share/doc directory
202  * Made an sara_install section for pbsmon --> examples/rack_pbsmon.py
203
204 -- Bas van der Vlies <basv@sara.nl>  Mon, 26 Sep 2005 16:32:06 +0200
205
206pbs-python (2.7.9-2) unstable; urgency=low
207
208  * Bumped up version
209  * Fixed  DEBUG mode
210
211 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 24 Jun 2005 11:23:30 +0200
212
213pbs-python (2.7.5-1) unstable; urgency=low
214
215  * Initial version
216
217 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 1 Nov 2004 12:13:08 -0400
218
Note: See TracBrowser for help on using the repository browser.