source: trunk/debian/changelog @ 196

Last change on this file since 196 was 196, checked in by bas, 15 years ago

list changes

File size: 6.4 KB
Line 
1pbs-python (3.2.5-1) intrepid; urgency=low
2
3  * PBSQuery
4        The class function of node, job and queue support old and new data
5        structure.
6    Author: Bas van der Vlies
7
8 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 18 May 2009 17:03:16 +0200
9
10pbs-python (3.2.0-1) intrepid; urgency=low
11
12  *  PBSQuery:
13         New data structure. In the old structure it is a dictionary
14         with a value and the value is a string. This is changed that
15         dictionary values are now of type list or dictionary depends
16         on the value of keyword, eg for a node:
17          - np = 2:
18                - node['np'] = [ '2' ]
19          - properties = cores2, mem4gb, parallel
20                - node['properties'] = [ 'cores2', 'mem4gb', 'parallel' ]
21          - status = arch=x86_64,sessions=22599,,size=70627864kb, ...
22                - node['status']['arch'] = [ 'x86_64' ]
23                - node['status']['sessions'] = [ '222599' ]
24                - ...
25
26         The data structure is activated by the function:
27          - new_data_structure()
28
29         In a future release it will be come the default.
30         example:
31                p = PBSQuery()
32                p.new_data_structure()
33
34                nodes = p.getnodes()
35                print nodes.np, nodes['np']
36
37         Author: Bas van der Vlies
38
39  *  PBSQuery:
40        For old and new data structure we now can use another syntax:
41         - node['np'] and node.np are equivalent
42
43        This new syntax works for all keywords.
44        Author: Bas van der Vlies
45
46  *  PBSQuery:
47        Added iter object for job, node, queue and server objects, eg:
48                node = p.getnode('gb-r1n1')
49                print node.name
50                for attrib in node:
51                        print '%\t%s = %s' %(attrib, node[attrib])
52        Author: Bas van der Vlies
53
54  *  PBSQuery:
55        fixed an error in getnode, getqueue and getjob, return
56        empty dictionary if not found.
57        Author: Bas van der Vlies
58
59  *  PBSQuery:
60        New build system for rpm packages, make -f Makefile.rpm
61        Author: Michel Jouvin <jouvin add lal dot in2p3 dot fr>
62        Applied: Bas van der Vlies
63
64 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 14 May 2009 13:41:00 +0200
65
66pbs-python (3.0.1-2) intrepid; urgency=low
67
68  * adjust number of nodes to 32
69
70 -- root <root@rc.sara.nl>  Tue, 17 Mar 2009 18:17:18 +0100
71
72pbs-python (3.0.1-1) intrepid; urgency=low
73
74  * Small bug fix
75
76 -- root <root@rc.sara.nl>  Wed, 28 Jan 2009 13:58:43 +0100
77
78pbs-python (3.0.0-1) intrepid; urgency=low
79
80  * New api for PBSQuery and build on any architecture
81
82 -- Bas van der Vlies <bas@sara.nl>  Tue, 11 Nov 2008 12:48:39 +0100
83
84pbs-python (2.9.8-3) intrepid; urgency=low
85
86  * New functions added to PBSQuery
87
88 -- Bas van der Vlies <basv@sara.nl>  Fri, 10 Oct 2008 11:18:38 +0200
89
90pbs-python (2.9.8-2) intrepid; urgency=low
91
92  * New PBSQuery module
93
94 -- Bas van der Vlies <bas@sara.nl>  Wed,  8 Oct 2008 14:05:44 +0200
95
96pbs-python (2.9.8-1) intrepid; urgency=low
97
98  * New version with updated torque header file (version 2.X)
99
100 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 24 Sep 2008 12:32:29 +0200
101
102pbs-python (2.9.6-1) intrepid; urgency=low
103
104  * pbs_python.spec file patch added libdir and python defines so it
105    will build for RHEL5.1/CentOS 5.1 (by Michael Sternberg) and some
106    minor changes to the pbs_ifl.h file
107
108 -- Dennis Stam <dennis.stam@sara.nl>  Thu, 18 Sep 2008 11:23:16 +0200
109
110pbs-python (2.9.4-1) unstable; urgency=low
111
112  * New version with all the fixes as mentioned below
113
114 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 16 Nov 2006 14:29:16 +0100
115
116pbs-python (2.9.2-4) unstable; urgency=low
117
118  * PBSQuery: Make use of UserDict module
119
120 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 18 Oct 2006 11:46:34 +0200
121
122pbs-python (2.9.2-3) unstable; urgency=low
123
124  *  Fixed a has_key bug must return zero instead of None
125     Thanks to Ramon Bastiaans for reporting
126
127 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 13 Oct 2006 15:33:25 +0200
128
129pbs-python (2.9.2-2) unstable; urgency=low
130
131  * new_rack_pbsmon.py fixes serial/parallel calculations
132
133 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 10 Oct 2006 12:13:25 +0200
134
135pbs-python (2.9.2-1) unstable; urgency=low
136
137  * New upstream version, read CHANGES file
138
139 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 19 Sep 2006 16:17:54 +0200
140
141pbs-python (2.9.1-6) unstable; urgency=low
142
143  *  New torque build system
144
145 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 21 Jul 2006 10:41:31 +0200
146
147pbs-python (2.9.1-5) unstable; urgency=low
148
149  * Down state has most priority. So display it
150
151 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 16 Jun 2006 14:44:48 +0200
152
153pbs-python (2.9.1-4) unstable; urgency=low
154
155  *  Added sara_install to Makefile.in. Else
156     no new pbsmon for SARA
157
158 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 15 Jun 2006 12:23:54 +0200
159
160pbs-python (2.9.1-3) unstable; urgency=low
161
162  * New version adjusted new_rack_pbsmon.py to 39 racks
163
164 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Jun 2006 11:56:26 +0200
165
166pbs-python (2.9.1-2) unstable; urgency=low
167
168  * Fixed a bug in new_rack_pbsmon.py
169
170 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 26 May 2006 16:41:35 +0200
171
172pbs-python (2.9.0-1) unstable; urgency=low
173
174  * Added new build system for torque 2.1.0 and higher
175
176 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 20 Apr 2006 14:25:21 +0200
177
178pbs-python (2.8.2-3) unstable; urgency=low
179
180  * Changed new_rack_pbsmon.py script by walter
181
182 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 13 Apr 2006 14:10:36 +0200
183
184pbs-python (2.8.2-2) unstable; urgency=low
185
186  *  Fixed Makefile.in, now right script
187
188 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  7 Apr 2006 10:59:35 +0200
189
190pbs-python (2.8.2-1) unstable; urgency=low
191
192  *  Added new pbsmon example: new_rack_pbsmon.py uses PBSQuery
193
194 -- Bas van der Vlies <bas@rc.sara.nl>  Thu,  6 Apr 2006 15:12:03 +0200
195
196pbs-python (2.8.0-2) unstable; urgency=medium
197
198  * Used swig 1.3.24 with python2.1 works also on higher python versions
199
200 -- Bas van der Vlies <bas@rc.sara.nl>  Mon,  7 Nov 2005 14:55:00 +0100
201
202pbs-python (2.8.0-1) unstable; urgency=low
203
204  * New pbs_python release, See CHANGES
205
206 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  4 Nov 2005 15:58:44 +0100
207
208pbs-python (2.7.10-1) unstable; urgency=low
209
210  * Added examples/LICENSE.sara to /usr/share/doc directory
211  * Made an sara_install section for pbsmon --> examples/rack_pbsmon.py
212
213 -- Bas van der Vlies <basv@sara.nl>  Mon, 26 Sep 2005 16:32:06 +0200
214
215pbs-python (2.7.9-2) unstable; urgency=low
216
217  * Bumped up version
218  * Fixed  DEBUG mode
219
220 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 24 Jun 2005 11:23:30 +0200
221
222pbs-python (2.7.5-1) unstable; urgency=low
223
224  * Initial version
225
226 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 1 Nov 2004 12:13:08 -0400
227
Note: See TracBrowser for help on using the repository browser.