source: trunk/debian/changelog @ 205

Last change on this file since 205 was 205, checked in by bas, 14 years ago

Preparing for new version 3.5

src/PBSQuery.py:

  • rewrite of dictionary code
File size: 7.2 KB
Line 
1pbs-python (3.5.0-1) lenny; urgency=low
2
3  * PBSQuery
4        The class functions of node, job and queue support old and new data
5        structure.
6
7        Changed the behaviour of the new data stucture, We can use it as
8        dictionary and as class attribute, this is equivalent, eg:
9          - print node['np'] and print node.np
10
11        for a node we parse the 'status' line and split on '=' char, You now can
12        use these statements, eg
13          - print node.status.arch     (node['status'].arch or node['status']['arch'])
14          - print node.status.nsession
15
16        for a job we parse the 'Variable_List' line and split on '=' char, You now can
17        use the statements, eg:
18          - print job.Variable_List.PBS_O_WORKDIR
19          - print job.Variable_List.PBS_O_HOME
20
21        For more info see examples/new_interface.py
22
23    Author: Bas van der Vlies
24
25 * new_rack_pbsmon.py
26        Rewrite to new data structure and automatically determine how many nodes
27        and racks cluster has and skip printing of empty racks (default), use -w/--wide
28        for old behaviour.
29       
30   Author: Bas van der Vlies
31
32 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Nov 2009 15:03:16 +0200
33
34pbs-python (3.2.0-1) intrepid; urgency=low
35
36  *  PBSQuery:
37         New data structure. In the old structure it is a dictionary
38         with a value and the value is a string. This is changed that
39         dictionary values are now of type list or dictionary depends
40         on the value of keyword, eg for a node:
41          - np = 2:
42                - node['np'] = [ '2' ]
43          - properties = cores2, mem4gb, parallel
44                - node['properties'] = [ 'cores2', 'mem4gb', 'parallel' ]
45          - status = arch=x86_64,sessions=22599,,size=70627864kb, ...
46                - node['status']['arch'] = [ 'x86_64' ]
47                - node['status']['sessions'] = [ '222599' ]
48                - ...
49
50         The data structure is activated by the function:
51          - new_data_structure()
52
53         In a future release it will be come the default.
54         example:
55                p = PBSQuery()
56                p.new_data_structure()
57
58                nodes = p.getnodes()
59                print nodes.np, nodes['np']
60
61         Author: Bas van der Vlies
62
63  *  PBSQuery:
64        For old and new data structure we now can use another syntax:
65         - node['np'] and node.np are equivalent
66
67        This new syntax works for all keywords.
68        Author: Bas van der Vlies
69
70  *  PBSQuery:
71        Added iter object for job, node, queue and server objects, eg:
72                node = p.getnode('gb-r1n1')
73                print node.name
74                for attrib in node:
75                        print '%\t%s = %s' %(attrib, node[attrib])
76        Author: Bas van der Vlies
77
78  *  PBSQuery:
79        fixed an error in getnode, getqueue and getjob, return
80        empty dictionary if not found.
81        Author: Bas van der Vlies
82
83  *  PBSQuery:
84        New build system for rpm packages, make -f Makefile.rpm
85        Author: Michel Jouvin <jouvin add lal dot in2p3 dot fr>
86        Applied: Bas van der Vlies
87
88 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 14 May 2009 13:41:00 +0200
89
90pbs-python (3.0.1-2) intrepid; urgency=low
91
92  * adjust number of nodes to 32
93
94 -- root <root@rc.sara.nl>  Tue, 17 Mar 2009 18:17:18 +0100
95
96pbs-python (3.0.1-1) intrepid; urgency=low
97
98  * Small bug fix
99
100 -- root <root@rc.sara.nl>  Wed, 28 Jan 2009 13:58:43 +0100
101
102pbs-python (3.0.0-1) intrepid; urgency=low
103
104  * New api for PBSQuery and build on any architecture
105
106 -- Bas van der Vlies <bas@sara.nl>  Tue, 11 Nov 2008 12:48:39 +0100
107
108pbs-python (2.9.8-3) intrepid; urgency=low
109
110  * New functions added to PBSQuery
111
112 -- Bas van der Vlies <basv@sara.nl>  Fri, 10 Oct 2008 11:18:38 +0200
113
114pbs-python (2.9.8-2) intrepid; urgency=low
115
116  * New PBSQuery module
117
118 -- Bas van der Vlies <bas@sara.nl>  Wed,  8 Oct 2008 14:05:44 +0200
119
120pbs-python (2.9.8-1) intrepid; urgency=low
121
122  * New version with updated torque header file (version 2.X)
123
124 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 24 Sep 2008 12:32:29 +0200
125
126pbs-python (2.9.6-1) intrepid; urgency=low
127
128  * pbs_python.spec file patch added libdir and python defines so it
129    will build for RHEL5.1/CentOS 5.1 (by Michael Sternberg) and some
130    minor changes to the pbs_ifl.h file
131
132 -- Dennis Stam <dennis.stam@sara.nl>  Thu, 18 Sep 2008 11:23:16 +0200
133
134pbs-python (2.9.4-1) unstable; urgency=low
135
136  * New version with all the fixes as mentioned below
137
138 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 16 Nov 2006 14:29:16 +0100
139
140pbs-python (2.9.2-4) unstable; urgency=low
141
142  * PBSQuery: Make use of UserDict module
143
144 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 18 Oct 2006 11:46:34 +0200
145
146pbs-python (2.9.2-3) unstable; urgency=low
147
148  *  Fixed a has_key bug must return zero instead of None
149     Thanks to Ramon Bastiaans for reporting
150
151 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 13 Oct 2006 15:33:25 +0200
152
153pbs-python (2.9.2-2) unstable; urgency=low
154
155  * new_rack_pbsmon.py fixes serial/parallel calculations
156
157 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 10 Oct 2006 12:13:25 +0200
158
159pbs-python (2.9.2-1) unstable; urgency=low
160
161  * New upstream version, read CHANGES file
162
163 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 19 Sep 2006 16:17:54 +0200
164
165pbs-python (2.9.1-6) unstable; urgency=low
166
167  *  New torque build system
168
169 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 21 Jul 2006 10:41:31 +0200
170
171pbs-python (2.9.1-5) unstable; urgency=low
172
173  * Down state has most priority. So display it
174
175 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 16 Jun 2006 14:44:48 +0200
176
177pbs-python (2.9.1-4) unstable; urgency=low
178
179  *  Added sara_install to Makefile.in. Else
180     no new pbsmon for SARA
181
182 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 15 Jun 2006 12:23:54 +0200
183
184pbs-python (2.9.1-3) unstable; urgency=low
185
186  * New version adjusted new_rack_pbsmon.py to 39 racks
187
188 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Jun 2006 11:56:26 +0200
189
190pbs-python (2.9.1-2) unstable; urgency=low
191
192  * Fixed a bug in new_rack_pbsmon.py
193
194 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 26 May 2006 16:41:35 +0200
195
196pbs-python (2.9.0-1) unstable; urgency=low
197
198  * Added new build system for torque 2.1.0 and higher
199
200 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 20 Apr 2006 14:25:21 +0200
201
202pbs-python (2.8.2-3) unstable; urgency=low
203
204  * Changed new_rack_pbsmon.py script by walter
205
206 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 13 Apr 2006 14:10:36 +0200
207
208pbs-python (2.8.2-2) unstable; urgency=low
209
210  *  Fixed Makefile.in, now right script
211
212 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  7 Apr 2006 10:59:35 +0200
213
214pbs-python (2.8.2-1) unstable; urgency=low
215
216  *  Added new pbsmon example: new_rack_pbsmon.py uses PBSQuery
217
218 -- Bas van der Vlies <bas@rc.sara.nl>  Thu,  6 Apr 2006 15:12:03 +0200
219
220pbs-python (2.8.0-2) unstable; urgency=medium
221
222  * Used swig 1.3.24 with python2.1 works also on higher python versions
223
224 -- Bas van der Vlies <bas@rc.sara.nl>  Mon,  7 Nov 2005 14:55:00 +0100
225
226pbs-python (2.8.0-1) unstable; urgency=low
227
228  * New pbs_python release, See CHANGES
229
230 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  4 Nov 2005 15:58:44 +0100
231
232pbs-python (2.7.10-1) unstable; urgency=low
233
234  * Added examples/LICENSE.sara to /usr/share/doc directory
235  * Made an sara_install section for pbsmon --> examples/rack_pbsmon.py
236
237 -- Bas van der Vlies <basv@sara.nl>  Mon, 26 Sep 2005 16:32:06 +0200
238
239pbs-python (2.7.9-2) unstable; urgency=low
240
241  * Bumped up version
242  * Fixed  DEBUG mode
243
244 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 24 Jun 2005 11:23:30 +0200
245
246pbs-python (2.7.5-1) unstable; urgency=low
247
248  * Initial version
249
250 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 1 Nov 2004 12:13:08 -0400
251
Note: See TracBrowser for help on using the repository browser.