source: trunk/debian/changelog @ 203

Last change on this file since 203 was 203, checked in by bas, 15 years ago

debian/changelog:

  • updated version
File size: 6.6 KB
Line 
1pbs-python (3.2.5-2) intrepid; urgency=low
2
3  * PBSQuery
4        The class function of node, job and queue support old and new data
5        structure.
6    Author: Bas van der Vlies
7
8 * new_rack_pbsmon.py
9        Rewrite to new data structure and automatically determine how many nodes
10        and racks cluster has and skip printing of empty racks (default), use -w/--wide
11        for old behaviour.
12       
13   Author: Bas van der Vlies
14
15 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 18 May 2009 17:03:16 +0200
16
17pbs-python (3.2.0-1) intrepid; urgency=low
18
19  *  PBSQuery:
20         New data structure. In the old structure it is a dictionary
21         with a value and the value is a string. This is changed that
22         dictionary values are now of type list or dictionary depends
23         on the value of keyword, eg for a node:
24          - np = 2:
25                - node['np'] = [ '2' ]
26          - properties = cores2, mem4gb, parallel
27                - node['properties'] = [ 'cores2', 'mem4gb', 'parallel' ]
28          - status = arch=x86_64,sessions=22599,,size=70627864kb, ...
29                - node['status']['arch'] = [ 'x86_64' ]
30                - node['status']['sessions'] = [ '222599' ]
31                - ...
32
33         The data structure is activated by the function:
34          - new_data_structure()
35
36         In a future release it will be come the default.
37         example:
38                p = PBSQuery()
39                p.new_data_structure()
40
41                nodes = p.getnodes()
42                print nodes.np, nodes['np']
43
44         Author: Bas van der Vlies
45
46  *  PBSQuery:
47        For old and new data structure we now can use another syntax:
48         - node['np'] and node.np are equivalent
49
50        This new syntax works for all keywords.
51        Author: Bas van der Vlies
52
53  *  PBSQuery:
54        Added iter object for job, node, queue and server objects, eg:
55                node = p.getnode('gb-r1n1')
56                print node.name
57                for attrib in node:
58                        print '%\t%s = %s' %(attrib, node[attrib])
59        Author: Bas van der Vlies
60
61  *  PBSQuery:
62        fixed an error in getnode, getqueue and getjob, return
63        empty dictionary if not found.
64        Author: Bas van der Vlies
65
66  *  PBSQuery:
67        New build system for rpm packages, make -f Makefile.rpm
68        Author: Michel Jouvin <jouvin add lal dot in2p3 dot fr>
69        Applied: Bas van der Vlies
70
71 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 14 May 2009 13:41:00 +0200
72
73pbs-python (3.0.1-2) intrepid; urgency=low
74
75  * adjust number of nodes to 32
76
77 -- root <root@rc.sara.nl>  Tue, 17 Mar 2009 18:17:18 +0100
78
79pbs-python (3.0.1-1) intrepid; urgency=low
80
81  * Small bug fix
82
83 -- root <root@rc.sara.nl>  Wed, 28 Jan 2009 13:58:43 +0100
84
85pbs-python (3.0.0-1) intrepid; urgency=low
86
87  * New api for PBSQuery and build on any architecture
88
89 -- Bas van der Vlies <bas@sara.nl>  Tue, 11 Nov 2008 12:48:39 +0100
90
91pbs-python (2.9.8-3) intrepid; urgency=low
92
93  * New functions added to PBSQuery
94
95 -- Bas van der Vlies <basv@sara.nl>  Fri, 10 Oct 2008 11:18:38 +0200
96
97pbs-python (2.9.8-2) intrepid; urgency=low
98
99  * New PBSQuery module
100
101 -- Bas van der Vlies <bas@sara.nl>  Wed,  8 Oct 2008 14:05:44 +0200
102
103pbs-python (2.9.8-1) intrepid; urgency=low
104
105  * New version with updated torque header file (version 2.X)
106
107 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 24 Sep 2008 12:32:29 +0200
108
109pbs-python (2.9.6-1) intrepid; urgency=low
110
111  * pbs_python.spec file patch added libdir and python defines so it
112    will build for RHEL5.1/CentOS 5.1 (by Michael Sternberg) and some
113    minor changes to the pbs_ifl.h file
114
115 -- Dennis Stam <dennis.stam@sara.nl>  Thu, 18 Sep 2008 11:23:16 +0200
116
117pbs-python (2.9.4-1) unstable; urgency=low
118
119  * New version with all the fixes as mentioned below
120
121 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 16 Nov 2006 14:29:16 +0100
122
123pbs-python (2.9.2-4) unstable; urgency=low
124
125  * PBSQuery: Make use of UserDict module
126
127 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 18 Oct 2006 11:46:34 +0200
128
129pbs-python (2.9.2-3) unstable; urgency=low
130
131  *  Fixed a has_key bug must return zero instead of None
132     Thanks to Ramon Bastiaans for reporting
133
134 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 13 Oct 2006 15:33:25 +0200
135
136pbs-python (2.9.2-2) unstable; urgency=low
137
138  * new_rack_pbsmon.py fixes serial/parallel calculations
139
140 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 10 Oct 2006 12:13:25 +0200
141
142pbs-python (2.9.2-1) unstable; urgency=low
143
144  * New upstream version, read CHANGES file
145
146 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 19 Sep 2006 16:17:54 +0200
147
148pbs-python (2.9.1-6) unstable; urgency=low
149
150  *  New torque build system
151
152 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 21 Jul 2006 10:41:31 +0200
153
154pbs-python (2.9.1-5) unstable; urgency=low
155
156  * Down state has most priority. So display it
157
158 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 16 Jun 2006 14:44:48 +0200
159
160pbs-python (2.9.1-4) unstable; urgency=low
161
162  *  Added sara_install to Makefile.in. Else
163     no new pbsmon for SARA
164
165 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 15 Jun 2006 12:23:54 +0200
166
167pbs-python (2.9.1-3) unstable; urgency=low
168
169  * New version adjusted new_rack_pbsmon.py to 39 racks
170
171 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Jun 2006 11:56:26 +0200
172
173pbs-python (2.9.1-2) unstable; urgency=low
174
175  * Fixed a bug in new_rack_pbsmon.py
176
177 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 26 May 2006 16:41:35 +0200
178
179pbs-python (2.9.0-1) unstable; urgency=low
180
181  * Added new build system for torque 2.1.0 and higher
182
183 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 20 Apr 2006 14:25:21 +0200
184
185pbs-python (2.8.2-3) unstable; urgency=low
186
187  * Changed new_rack_pbsmon.py script by walter
188
189 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 13 Apr 2006 14:10:36 +0200
190
191pbs-python (2.8.2-2) unstable; urgency=low
192
193  *  Fixed Makefile.in, now right script
194
195 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  7 Apr 2006 10:59:35 +0200
196
197pbs-python (2.8.2-1) unstable; urgency=low
198
199  *  Added new pbsmon example: new_rack_pbsmon.py uses PBSQuery
200
201 -- Bas van der Vlies <bas@rc.sara.nl>  Thu,  6 Apr 2006 15:12:03 +0200
202
203pbs-python (2.8.0-2) unstable; urgency=medium
204
205  * Used swig 1.3.24 with python2.1 works also on higher python versions
206
207 -- Bas van der Vlies <bas@rc.sara.nl>  Mon,  7 Nov 2005 14:55:00 +0100
208
209pbs-python (2.8.0-1) unstable; urgency=low
210
211  * New pbs_python release, See CHANGES
212
213 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  4 Nov 2005 15:58:44 +0100
214
215pbs-python (2.7.10-1) unstable; urgency=low
216
217  * Added examples/LICENSE.sara to /usr/share/doc directory
218  * Made an sara_install section for pbsmon --> examples/rack_pbsmon.py
219
220 -- Bas van der Vlies <basv@sara.nl>  Mon, 26 Sep 2005 16:32:06 +0200
221
222pbs-python (2.7.9-2) unstable; urgency=low
223
224  * Bumped up version
225  * Fixed  DEBUG mode
226
227 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 24 Jun 2005 11:23:30 +0200
228
229pbs-python (2.7.5-1) unstable; urgency=low
230
231  * Initial version
232
233 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 1 Nov 2004 12:13:08 -0400
234
Note: See TracBrowser for help on using the repository browser.