source: trunk/debian/changelog @ 219

Last change on this file since 219 was 219, checked in by bas, 14 years ago

Updated version number for deb and rpm

File size: 7.6 KB
Line 
1pbs-python (4.0.0-1) lenny; urgency=low
2
3  * See CHANGES files
4
5 -- Bas van der Vlies <basv@sara.nl>  Fri, 09 Apr 2010 09:43:24 +0200
6
7pbs-python (3.6.0-1) lenny; urgency=low
8
9  * New generated files pbs_wrap.c and pbs.py fixes an error in pbs_runjob()
10
11 -- Bas van der Vlies <basv@sara.nl>  Fri, 15 Jan 2010 04:40:35 +0100
12
13pbs-python (3.5.0-1) lenny; urgency=low
14
15  * PBSQuery
16        The class functions of node, job and queue support old and new data
17        structure.
18
19    Changed the behaviour of the new data stucture, We can use it as
20    dictionary and as class attribute, this is equivalent, eg:
21      - print node['np'] and print node.np
22
23    for a node we parse the 'status' line and split on '=' char, You now can
24    use these statements, eg
25     - print node.status.arch     (node['status'].arch or node['status']['arch'])
26     - print node.status.nsession
27
28    for a job we parse the 'Variable_List' line and split on '=' char, You now can
29    use the statements, eg:
30     - print job.Variable_List.PBS_O_WORKDIR
31     - print job.Variable_List.PBS_O_HOME
32
33    for more info see examples/new_interface.py
34
35    Author: Bas van der Vlies
36
37  * new_rack_pbsmon.py
38    Rewrite to new data structure and automatically determine how many nodes
39    and racks cluster has and skip printing of empty racks (default), use -w/--wide
40    for old behaviour.
41
42    Author: Bas van der Vlies
43
44 -- Bas van der Vlies <bas@sara.nl>  Mon, 12 Nov 2009 15:03:16 +0200
45
46pbs-python (3.2.0-1) intrepid; urgency=low
47
48  *  PBSQuery:
49     New data structure. In the old structure it is a dictionary
50     with a value and the value is a string. This is changed that
51     dictionary values are now of type list or dictionary depends
52     on the value of keyword, eg for a node:
53       - np = 2:
54       - node['np'] = [ '2' ]
55       - properties = cores2, mem4gb, parallel
56       - node['properties'] = [ 'cores2', 'mem4gb', 'parallel' ]
57       - status = arch=x86_64,sessions=22599,,size=70627864kb, ...
58       - node['status']['arch'] = [ 'x86_64' ]
59       - node['status']['sessions'] = [ '222599' ]
60       - ...
61
62         The data structure is activated by the function:
63          - new_data_structure()
64
65         In a future release it will be come the default.
66         example:
67         p = PBSQuery()
68         p.new_data_structure()
69
70        nodes = p.getnodes()
71        print nodes.np, nodes['np']
72
73         Author: Bas van der Vlies
74
75  *  PBSQuery:
76        For old and new data structure we now can use another syntax:
77     - node['np'] and node.np are equivalent
78
79        This new syntax works for all keywords.
80        Author: Bas van der Vlies
81
82  *  PBSQuery:
83        Added iter object for job, node, queue and server objects, eg:
84        node = p.getnode('gb-r1n1')
85        print node.name
86        for attrib in node:
87           print '%\t%s = %s' %(attrib, node[attrib])
88        Author: Bas van der Vlies
89
90  *  PBSQuery:
91        fixed an error in getnode, getqueue and getjob, return
92        empty dictionary if not found.
93        Author: Bas van der Vlies
94
95  *  PBSQuery:
96        New build system for rpm packages, make -f Makefile.rpm
97        Author: Michel Jouvin <jouvin add lal dot in2p3 dot fr>
98        Applied: Bas van der Vlies
99
100 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 14 May 2009 13:41:00 +0200
101
102pbs-python (3.0.1-2) intrepid; urgency=low
103
104  * adjust number of nodes to 32
105
106 -- root <root@rc.sara.nl>  Tue, 17 Mar 2009 18:17:18 +0100
107
108pbs-python (3.0.1-1) intrepid; urgency=low
109
110  * Small bug fix
111
112 -- root <root@rc.sara.nl>  Wed, 28 Jan 2009 13:58:43 +0100
113
114pbs-python (3.0.0-1) intrepid; urgency=low
115
116  * New api for PBSQuery and build on any architecture
117
118 -- Bas van der Vlies <bas@sara.nl>  Tue, 11 Nov 2008 12:48:39 +0100
119
120pbs-python (2.9.8-3) intrepid; urgency=low
121
122  * New functions added to PBSQuery
123
124 -- Bas van der Vlies <basv@sara.nl>  Fri, 10 Oct 2008 11:18:38 +0200
125
126pbs-python (2.9.8-2) intrepid; urgency=low
127
128  * New PBSQuery module
129
130 -- Bas van der Vlies <bas@sara.nl>  Wed,  8 Oct 2008 14:05:44 +0200
131
132pbs-python (2.9.8-1) intrepid; urgency=low
133
134  * New version with updated torque header file (version 2.X)
135
136 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 24 Sep 2008 12:32:29 +0200
137
138pbs-python (2.9.6-1) intrepid; urgency=low
139
140  * pbs_python.spec file patch added libdir and python defines so it
141    will build for RHEL5.1/CentOS 5.1 (by Michael Sternberg) and some
142    minor changes to the pbs_ifl.h file
143
144 -- Dennis Stam <dennis.stam@sara.nl>  Thu, 18 Sep 2008 11:23:16 +0200
145
146pbs-python (2.9.4-1) unstable; urgency=low
147
148  * New version with all the fixes as mentioned below
149
150 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 16 Nov 2006 14:29:16 +0100
151
152pbs-python (2.9.2-4) unstable; urgency=low
153
154  * PBSQuery: Make use of UserDict module
155
156 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 18 Oct 2006 11:46:34 +0200
157
158pbs-python (2.9.2-3) unstable; urgency=low
159
160  *  Fixed a has_key bug must return zero instead of None
161     Thanks to Ramon Bastiaans for reporting
162
163 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 13 Oct 2006 15:33:25 +0200
164
165pbs-python (2.9.2-2) unstable; urgency=low
166
167  * new_rack_pbsmon.py fixes serial/parallel calculations
168
169 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 10 Oct 2006 12:13:25 +0200
170
171pbs-python (2.9.2-1) unstable; urgency=low
172
173  * New upstream version, read CHANGES file
174
175 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 19 Sep 2006 16:17:54 +0200
176
177pbs-python (2.9.1-6) unstable; urgency=low
178
179  *  New torque build system
180
181 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 21 Jul 2006 10:41:31 +0200
182
183pbs-python (2.9.1-5) unstable; urgency=low
184
185  * Down state has most priority. So display it
186
187 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 16 Jun 2006 14:44:48 +0200
188
189pbs-python (2.9.1-4) unstable; urgency=low
190
191  *  Added sara_install to Makefile.in. Else
192     no new pbsmon for SARA
193
194 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 15 Jun 2006 12:23:54 +0200
195
196pbs-python (2.9.1-3) unstable; urgency=low
197
198  * New version adjusted new_rack_pbsmon.py to 39 racks
199
200 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Jun 2006 11:56:26 +0200
201
202pbs-python (2.9.1-2) unstable; urgency=low
203
204  * Fixed a bug in new_rack_pbsmon.py
205
206 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 26 May 2006 16:41:35 +0200
207
208pbs-python (2.9.0-1) unstable; urgency=low
209
210  * Added new build system for torque 2.1.0 and higher
211
212 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 20 Apr 2006 14:25:21 +0200
213
214pbs-python (2.8.2-3) unstable; urgency=low
215
216  * Changed new_rack_pbsmon.py script by walter
217
218 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 13 Apr 2006 14:10:36 +0200
219
220pbs-python (2.8.2-2) unstable; urgency=low
221
222  *  Fixed Makefile.in, now right script
223
224 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  7 Apr 2006 10:59:35 +0200
225
226pbs-python (2.8.2-1) unstable; urgency=low
227
228  *  Added new pbsmon example: new_rack_pbsmon.py uses PBSQuery
229
230 -- Bas van der Vlies <bas@rc.sara.nl>  Thu,  6 Apr 2006 15:12:03 +0200
231
232pbs-python (2.8.0-2) unstable; urgency=medium
233
234  * Used swig 1.3.24 with python2.1 works also on higher python versions
235
236 -- Bas van der Vlies <bas@rc.sara.nl>  Mon,  7 Nov 2005 14:55:00 +0100
237
238pbs-python (2.8.0-1) unstable; urgency=low
239
240  * New pbs_python release, See CHANGES
241
242 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  4 Nov 2005 15:58:44 +0100
243
244pbs-python (2.7.10-1) unstable; urgency=low
245
246  * Added examples/LICENSE.sara to /usr/share/doc directory
247  * Made an sara_install section for pbsmon --> examples/rack_pbsmon.py
248
249 -- Bas van der Vlies <basv@sara.nl>  Mon, 26 Sep 2005 16:32:06 +0200
250
251pbs-python (2.7.9-2) unstable; urgency=low
252
253  * Bumped up version
254  * Fixed  DEBUG mode
255
256 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 24 Jun 2005 11:23:30 +0200
257
258pbs-python (2.7.5-1) unstable; urgency=low
259
260  * Initial version
261
262 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 1 Nov 2004 12:13:08 -0400
263
Note: See TracBrowser for help on using the repository browser.