source: trunk/debian/changelog @ 231

Last change on this file since 231 was 231, checked in by bas, 14 years ago

New version 4.0.1 with a small fix, see #19

File size: 7.8 KB
Line 
1pbs-python (4.0.1-1) lenny; urgency=low
2
3  * See CHANGES file
4
5 -- bas van der Vlies <bas@sara.nl>  Wed, 21 Apr 2010 08:26:02 +0200
6
7pbs-python (4.0.0-1) lenny; urgency=low
8
9  * See CHANGES file
10
11 -- Bas van der Vlies <basv@sara.nl>  Fri, 09 Apr 2010 09:43:24 +0200
12
13pbs-python (3.6.0-1) lenny; urgency=low
14
15  * New generated files pbs_wrap.c and pbs.py fixes an error in pbs_runjob()
16
17 -- Bas van der Vlies <basv@sara.nl>  Fri, 15 Jan 2010 04:40:35 +0100
18
19pbs-python (3.5.0-1) lenny; urgency=low
20
21  * PBSQuery
22        The class functions of node, job and queue support old and new data
23        structure.
24
25    Changed the behaviour of the new data stucture, We can use it as
26    dictionary and as class attribute, this is equivalent, eg:
27      - print node['np'] and print node.np
28
29    for a node we parse the 'status' line and split on '=' char, You now can
30    use these statements, eg
31     - print node.status.arch     (node['status'].arch or node['status']['arch'])
32     - print node.status.nsession
33
34    for a job we parse the 'Variable_List' line and split on '=' char, You now can
35    use the statements, eg:
36     - print job.Variable_List.PBS_O_WORKDIR
37     - print job.Variable_List.PBS_O_HOME
38
39    for more info see examples/new_interface.py
40
41    Author: Bas van der Vlies
42
43  * new_rack_pbsmon.py
44    Rewrite to new data structure and automatically determine how many nodes
45    and racks cluster has and skip printing of empty racks (default), use -w/--wide
46    for old behaviour.
47
48    Author: Bas van der Vlies
49
50 -- Bas van der Vlies <bas@sara.nl>  Mon, 12 Nov 2009 15:03:16 +0200
51
52pbs-python (3.2.0-1) intrepid; urgency=low
53
54  *  PBSQuery:
55     New data structure. In the old structure it is a dictionary
56     with a value and the value is a string. This is changed that
57     dictionary values are now of type list or dictionary depends
58     on the value of keyword, eg for a node:
59       - np = 2:
60       - node['np'] = [ '2' ]
61       - properties = cores2, mem4gb, parallel
62       - node['properties'] = [ 'cores2', 'mem4gb', 'parallel' ]
63       - status = arch=x86_64,sessions=22599,,size=70627864kb, ...
64       - node['status']['arch'] = [ 'x86_64' ]
65       - node['status']['sessions'] = [ '222599' ]
66       - ...
67
68         The data structure is activated by the function:
69          - new_data_structure()
70
71         In a future release it will be come the default.
72         example:
73         p = PBSQuery()
74         p.new_data_structure()
75
76        nodes = p.getnodes()
77        print nodes.np, nodes['np']
78
79         Author: Bas van der Vlies
80
81  *  PBSQuery:
82        For old and new data structure we now can use another syntax:
83     - node['np'] and node.np are equivalent
84
85        This new syntax works for all keywords.
86        Author: Bas van der Vlies
87
88  *  PBSQuery:
89        Added iter object for job, node, queue and server objects, eg:
90        node = p.getnode('gb-r1n1')
91        print node.name
92        for attrib in node:
93           print '%\t%s = %s' %(attrib, node[attrib])
94        Author: Bas van der Vlies
95
96  *  PBSQuery:
97        fixed an error in getnode, getqueue and getjob, return
98        empty dictionary if not found.
99        Author: Bas van der Vlies
100
101  *  PBSQuery:
102        New build system for rpm packages, make -f Makefile.rpm
103        Author: Michel Jouvin <jouvin add lal dot in2p3 dot fr>
104        Applied: Bas van der Vlies
105
106 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 14 May 2009 13:41:00 +0200
107
108pbs-python (3.0.1-2) intrepid; urgency=low
109
110  * adjust number of nodes to 32
111
112 -- root <root@rc.sara.nl>  Tue, 17 Mar 2009 18:17:18 +0100
113
114pbs-python (3.0.1-1) intrepid; urgency=low
115
116  * Small bug fix
117
118 -- root <root@rc.sara.nl>  Wed, 28 Jan 2009 13:58:43 +0100
119
120pbs-python (3.0.0-1) intrepid; urgency=low
121
122  * New api for PBSQuery and build on any architecture
123
124 -- Bas van der Vlies <bas@sara.nl>  Tue, 11 Nov 2008 12:48:39 +0100
125
126pbs-python (2.9.8-3) intrepid; urgency=low
127
128  * New functions added to PBSQuery
129
130 -- Bas van der Vlies <basv@sara.nl>  Fri, 10 Oct 2008 11:18:38 +0200
131
132pbs-python (2.9.8-2) intrepid; urgency=low
133
134  * New PBSQuery module
135
136 -- Bas van der Vlies <bas@sara.nl>  Wed,  8 Oct 2008 14:05:44 +0200
137
138pbs-python (2.9.8-1) intrepid; urgency=low
139
140  * New version with updated torque header file (version 2.X)
141
142 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 24 Sep 2008 12:32:29 +0200
143
144pbs-python (2.9.6-1) intrepid; urgency=low
145
146  * pbs_python.spec file patch added libdir and python defines so it
147    will build for RHEL5.1/CentOS 5.1 (by Michael Sternberg) and some
148    minor changes to the pbs_ifl.h file
149
150 -- Dennis Stam <dennis.stam@sara.nl>  Thu, 18 Sep 2008 11:23:16 +0200
151
152pbs-python (2.9.4-1) unstable; urgency=low
153
154  * New version with all the fixes as mentioned below
155
156 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 16 Nov 2006 14:29:16 +0100
157
158pbs-python (2.9.2-4) unstable; urgency=low
159
160  * PBSQuery: Make use of UserDict module
161
162 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 18 Oct 2006 11:46:34 +0200
163
164pbs-python (2.9.2-3) unstable; urgency=low
165
166  *  Fixed a has_key bug must return zero instead of None
167     Thanks to Ramon Bastiaans for reporting
168
169 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 13 Oct 2006 15:33:25 +0200
170
171pbs-python (2.9.2-2) unstable; urgency=low
172
173  * new_rack_pbsmon.py fixes serial/parallel calculations
174
175 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 10 Oct 2006 12:13:25 +0200
176
177pbs-python (2.9.2-1) unstable; urgency=low
178
179  * New upstream version, read CHANGES file
180
181 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 19 Sep 2006 16:17:54 +0200
182
183pbs-python (2.9.1-6) unstable; urgency=low
184
185  *  New torque build system
186
187 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 21 Jul 2006 10:41:31 +0200
188
189pbs-python (2.9.1-5) unstable; urgency=low
190
191  * Down state has most priority. So display it
192
193 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 16 Jun 2006 14:44:48 +0200
194
195pbs-python (2.9.1-4) unstable; urgency=low
196
197  *  Added sara_install to Makefile.in. Else
198     no new pbsmon for SARA
199
200 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 15 Jun 2006 12:23:54 +0200
201
202pbs-python (2.9.1-3) unstable; urgency=low
203
204  * New version adjusted new_rack_pbsmon.py to 39 racks
205
206 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Jun 2006 11:56:26 +0200
207
208pbs-python (2.9.1-2) unstable; urgency=low
209
210  * Fixed a bug in new_rack_pbsmon.py
211
212 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 26 May 2006 16:41:35 +0200
213
214pbs-python (2.9.0-1) unstable; urgency=low
215
216  * Added new build system for torque 2.1.0 and higher
217
218 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 20 Apr 2006 14:25:21 +0200
219
220pbs-python (2.8.2-3) unstable; urgency=low
221
222  * Changed new_rack_pbsmon.py script by walter
223
224 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 13 Apr 2006 14:10:36 +0200
225
226pbs-python (2.8.2-2) unstable; urgency=low
227
228  *  Fixed Makefile.in, now right script
229
230 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  7 Apr 2006 10:59:35 +0200
231
232pbs-python (2.8.2-1) unstable; urgency=low
233
234  *  Added new pbsmon example: new_rack_pbsmon.py uses PBSQuery
235
236 -- Bas van der Vlies <bas@rc.sara.nl>  Thu,  6 Apr 2006 15:12:03 +0200
237
238pbs-python (2.8.0-2) unstable; urgency=medium
239
240  * Used swig 1.3.24 with python2.1 works also on higher python versions
241
242 -- Bas van der Vlies <bas@rc.sara.nl>  Mon,  7 Nov 2005 14:55:00 +0100
243
244pbs-python (2.8.0-1) unstable; urgency=low
245
246  * New pbs_python release, See CHANGES
247
248 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  4 Nov 2005 15:58:44 +0100
249
250pbs-python (2.7.10-1) unstable; urgency=low
251
252  * Added examples/LICENSE.sara to /usr/share/doc directory
253  * Made an sara_install section for pbsmon --> examples/rack_pbsmon.py
254
255 -- Bas van der Vlies <basv@sara.nl>  Mon, 26 Sep 2005 16:32:06 +0200
256
257pbs-python (2.7.9-2) unstable; urgency=low
258
259  * Bumped up version
260  * Fixed  DEBUG mode
261
262 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 24 Jun 2005 11:23:30 +0200
263
264pbs-python (2.7.5-1) unstable; urgency=low
265
266  * Initial version
267
268 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 1 Nov 2004 12:13:08 -0400
269
Note: See TracBrowser for help on using the repository browser.