source: trunk/debian/changelog @ 242

Last change on this file since 242 was 242, checked in by bas, 14 years ago

applied a patch for pbsmon.py

File size: 8.4 KB
Line 
1pbs-python (4.1.3-1) lenny; urgency=low
2
3  * Update LICENSE file to LGPLV3
4  * patched pbsmon.py for torque 2.5
5
6 -- bas van der Vlies <bas@sara.nl>  Thu, 10 Jun 2010 10:27:43 +0200
7
8pbs-python (4.1.2-1) lenny; urgency=low
9
10  * See changes not yes finishedm but some important fixes
11
12 -- bas van der Vlies <basv@sara.nl>  Thu, 20 May 2010 11:11:21 +0200
13
14pbs-python (4.1.0-1) lenny; urgency=low
15
16  * See CHANGES file
17
18 -- bas van der Vlies <bas@sara.nl>  Thu, 29 Apr 2010 13:24:24 +0200
19
20pbs-python (4.0.2-1) lenny; urgency=low
21
22  * See CHANGES file
23
24 -- bas van der Vlies <bas@sara.nl>  Fri, 23 Apr 2010 10:27:58 +0200
25
26pbs-python (4.0.1-1) lenny; urgency=low
27
28  * See CHANGES file
29
30 -- bas van der Vlies <bas@sara.nl>  Wed, 21 Apr 2010 08:26:02 +0200
31
32pbs-python (4.0.0-1) lenny; urgency=low
33
34  * See CHANGES file
35
36 -- Bas van der Vlies <basv@sara.nl>  Fri, 09 Apr 2010 09:43:24 +0200
37
38pbs-python (3.6.0-1) lenny; urgency=low
39
40  * New generated files pbs_wrap.c and pbs.py fixes an error in pbs_runjob()
41
42 -- Bas van der Vlies <basv@sara.nl>  Fri, 15 Jan 2010 04:40:35 +0100
43
44pbs-python (3.5.0-1) lenny; urgency=low
45
46  * PBSQuery
47        The class functions of node, job and queue support old and new data
48        structure.
49
50    Changed the behaviour of the new data stucture, We can use it as
51    dictionary and as class attribute, this is equivalent, eg:
52      - print node['np'] and print node.np
53
54    for a node we parse the 'status' line and split on '=' char, You now can
55    use these statements, eg
56     - print node.status.arch     (node['status'].arch or node['status']['arch'])
57     - print node.status.nsession
58
59    for a job we parse the 'Variable_List' line and split on '=' char, You now can
60    use the statements, eg:
61     - print job.Variable_List.PBS_O_WORKDIR
62     - print job.Variable_List.PBS_O_HOME
63
64    for more info see examples/new_interface.py
65
66    Author: Bas van der Vlies
67
68  * new_rack_pbsmon.py
69    Rewrite to new data structure and automatically determine how many nodes
70    and racks cluster has and skip printing of empty racks (default), use -w/--wide
71    for old behaviour.
72
73    Author: Bas van der Vlies
74
75 -- Bas van der Vlies <bas@sara.nl>  Mon, 12 Nov 2009 15:03:16 +0200
76
77pbs-python (3.2.0-1) intrepid; urgency=low
78
79  *  PBSQuery:
80     New data structure. In the old structure it is a dictionary
81     with a value and the value is a string. This is changed that
82     dictionary values are now of type list or dictionary depends
83     on the value of keyword, eg for a node:
84       - np = 2:
85       - node['np'] = [ '2' ]
86       - properties = cores2, mem4gb, parallel
87       - node['properties'] = [ 'cores2', 'mem4gb', 'parallel' ]
88       - status = arch=x86_64,sessions=22599,,size=70627864kb, ...
89       - node['status']['arch'] = [ 'x86_64' ]
90       - node['status']['sessions'] = [ '222599' ]
91       - ...
92
93         The data structure is activated by the function:
94          - new_data_structure()
95
96         In a future release it will be come the default.
97         example:
98         p = PBSQuery()
99         p.new_data_structure()
100
101        nodes = p.getnodes()
102        print nodes.np, nodes['np']
103
104         Author: Bas van der Vlies
105
106  *  PBSQuery:
107        For old and new data structure we now can use another syntax:
108     - node['np'] and node.np are equivalent
109
110        This new syntax works for all keywords.
111        Author: Bas van der Vlies
112
113  *  PBSQuery:
114        Added iter object for job, node, queue and server objects, eg:
115        node = p.getnode('gb-r1n1')
116        print node.name
117        for attrib in node:
118           print '%\t%s = %s' %(attrib, node[attrib])
119        Author: Bas van der Vlies
120
121  *  PBSQuery:
122        fixed an error in getnode, getqueue and getjob, return
123        empty dictionary if not found.
124        Author: Bas van der Vlies
125
126  *  PBSQuery:
127        New build system for rpm packages, make -f Makefile.rpm
128        Author: Michel Jouvin <jouvin add lal dot in2p3 dot fr>
129        Applied: Bas van der Vlies
130
131 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 14 May 2009 13:41:00 +0200
132
133pbs-python (3.0.1-2) intrepid; urgency=low
134
135  * adjust number of nodes to 32
136
137 -- root <root@rc.sara.nl>  Tue, 17 Mar 2009 18:17:18 +0100
138
139pbs-python (3.0.1-1) intrepid; urgency=low
140
141  * Small bug fix
142
143 -- root <root@rc.sara.nl>  Wed, 28 Jan 2009 13:58:43 +0100
144
145pbs-python (3.0.0-1) intrepid; urgency=low
146
147  * New api for PBSQuery and build on any architecture
148
149 -- Bas van der Vlies <bas@sara.nl>  Tue, 11 Nov 2008 12:48:39 +0100
150
151pbs-python (2.9.8-3) intrepid; urgency=low
152
153  * New functions added to PBSQuery
154
155 -- Bas van der Vlies <basv@sara.nl>  Fri, 10 Oct 2008 11:18:38 +0200
156
157pbs-python (2.9.8-2) intrepid; urgency=low
158
159  * New PBSQuery module
160
161 -- Bas van der Vlies <bas@sara.nl>  Wed,  8 Oct 2008 14:05:44 +0200
162
163pbs-python (2.9.8-1) intrepid; urgency=low
164
165  * New version with updated torque header file (version 2.X)
166
167 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 24 Sep 2008 12:32:29 +0200
168
169pbs-python (2.9.6-1) intrepid; urgency=low
170
171  * pbs_python.spec file patch added libdir and python defines so it
172    will build for RHEL5.1/CentOS 5.1 (by Michael Sternberg) and some
173    minor changes to the pbs_ifl.h file
174
175 -- Dennis Stam <dennis.stam@sara.nl>  Thu, 18 Sep 2008 11:23:16 +0200
176
177pbs-python (2.9.4-1) unstable; urgency=low
178
179  * New version with all the fixes as mentioned below
180
181 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 16 Nov 2006 14:29:16 +0100
182
183pbs-python (2.9.2-4) unstable; urgency=low
184
185  * PBSQuery: Make use of UserDict module
186
187 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 18 Oct 2006 11:46:34 +0200
188
189pbs-python (2.9.2-3) unstable; urgency=low
190
191  *  Fixed a has_key bug must return zero instead of None
192     Thanks to Ramon Bastiaans for reporting
193
194 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 13 Oct 2006 15:33:25 +0200
195
196pbs-python (2.9.2-2) unstable; urgency=low
197
198  * new_rack_pbsmon.py fixes serial/parallel calculations
199
200 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 10 Oct 2006 12:13:25 +0200
201
202pbs-python (2.9.2-1) unstable; urgency=low
203
204  * New upstream version, read CHANGES file
205
206 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 19 Sep 2006 16:17:54 +0200
207
208pbs-python (2.9.1-6) unstable; urgency=low
209
210  *  New torque build system
211
212 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 21 Jul 2006 10:41:31 +0200
213
214pbs-python (2.9.1-5) unstable; urgency=low
215
216  * Down state has most priority. So display it
217
218 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 16 Jun 2006 14:44:48 +0200
219
220pbs-python (2.9.1-4) unstable; urgency=low
221
222  *  Added sara_install to Makefile.in. Else
223     no new pbsmon for SARA
224
225 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 15 Jun 2006 12:23:54 +0200
226
227pbs-python (2.9.1-3) unstable; urgency=low
228
229  * New version adjusted new_rack_pbsmon.py to 39 racks
230
231 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Jun 2006 11:56:26 +0200
232
233pbs-python (2.9.1-2) unstable; urgency=low
234
235  * Fixed a bug in new_rack_pbsmon.py
236
237 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 26 May 2006 16:41:35 +0200
238
239pbs-python (2.9.0-1) unstable; urgency=low
240
241  * Added new build system for torque 2.1.0 and higher
242
243 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 20 Apr 2006 14:25:21 +0200
244
245pbs-python (2.8.2-3) unstable; urgency=low
246
247  * Changed new_rack_pbsmon.py script by walter
248
249 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 13 Apr 2006 14:10:36 +0200
250
251pbs-python (2.8.2-2) unstable; urgency=low
252
253  *  Fixed Makefile.in, now right script
254
255 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  7 Apr 2006 10:59:35 +0200
256
257pbs-python (2.8.2-1) unstable; urgency=low
258
259  *  Added new pbsmon example: new_rack_pbsmon.py uses PBSQuery
260
261 -- Bas van der Vlies <bas@rc.sara.nl>  Thu,  6 Apr 2006 15:12:03 +0200
262
263pbs-python (2.8.0-2) unstable; urgency=medium
264
265  * Used swig 1.3.24 with python2.1 works also on higher python versions
266
267 -- Bas van der Vlies <bas@rc.sara.nl>  Mon,  7 Nov 2005 14:55:00 +0100
268
269pbs-python (2.8.0-1) unstable; urgency=low
270
271  * New pbs_python release, See CHANGES
272
273 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  4 Nov 2005 15:58:44 +0100
274
275pbs-python (2.7.10-1) unstable; urgency=low
276
277  * Added examples/LICENSE.sara to /usr/share/doc directory
278  * Made an sara_install section for pbsmon --> examples/rack_pbsmon.py
279
280 -- Bas van der Vlies <basv@sara.nl>  Mon, 26 Sep 2005 16:32:06 +0200
281
282pbs-python (2.7.9-2) unstable; urgency=low
283
284  * Bumped up version
285  * Fixed  DEBUG mode
286
287 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 24 Jun 2005 11:23:30 +0200
288
289pbs-python (2.7.5-1) unstable; urgency=low
290
291  * Initial version
292
293 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 1 Nov 2004 12:13:08 -0400
294
Note: See TracBrowser for help on using the repository browser.