source: trunk/debian/changelog @ 253

Last change on this file since 253 was 253, checked in by bas, 14 years ago

Updated version to 4.2.0 and update CHANGES file

File size: 8.4 KB
Line 
1pbs-python (4.2.0-1) lenny; urgency=low
2
3  * Update LICENSE file to LGPLV3
4  * patched pbsmon.py for torque 2.5
5  * see CHANGES for complete list
6
7 -- Bas van der Vlies <bas@sara.nl>  Thu, 10 Jun 2010 10:27:43 +0200
8
9pbs-python (4.1.2-1) lenny; urgency=low
10
11  * See changes not yes finishedm but some important fixes
12
13 -- bas van der Vlies <basv@sara.nl>  Thu, 20 May 2010 11:11:21 +0200
14
15pbs-python (4.1.0-1) lenny; urgency=low
16
17  * See CHANGES file
18
19 -- bas van der Vlies <bas@sara.nl>  Thu, 29 Apr 2010 13:24:24 +0200
20
21pbs-python (4.0.2-1) lenny; urgency=low
22
23  * See CHANGES file
24
25 -- bas van der Vlies <bas@sara.nl>  Fri, 23 Apr 2010 10:27:58 +0200
26
27pbs-python (4.0.1-1) lenny; urgency=low
28
29  * See CHANGES file
30
31 -- bas van der Vlies <bas@sara.nl>  Wed, 21 Apr 2010 08:26:02 +0200
32
33pbs-python (4.0.0-1) lenny; urgency=low
34
35  * See CHANGES file
36
37 -- Bas van der Vlies <basv@sara.nl>  Fri, 09 Apr 2010 09:43:24 +0200
38
39pbs-python (3.6.0-1) lenny; urgency=low
40
41  * New generated files pbs_wrap.c and pbs.py fixes an error in pbs_runjob()
42
43 -- Bas van der Vlies <basv@sara.nl>  Fri, 15 Jan 2010 04:40:35 +0100
44
45pbs-python (3.5.0-1) lenny; urgency=low
46
47  * PBSQuery
48        The class functions of node, job and queue support old and new data
49        structure.
50
51    Changed the behaviour of the new data stucture, We can use it as
52    dictionary and as class attribute, this is equivalent, eg:
53      - print node['np'] and print node.np
54
55    for a node we parse the 'status' line and split on '=' char, You now can
56    use these statements, eg
57     - print node.status.arch     (node['status'].arch or node['status']['arch'])
58     - print node.status.nsession
59
60    for a job we parse the 'Variable_List' line and split on '=' char, You now can
61    use the statements, eg:
62     - print job.Variable_List.PBS_O_WORKDIR
63     - print job.Variable_List.PBS_O_HOME
64
65    for more info see examples/new_interface.py
66
67    Author: Bas van der Vlies
68
69  * new_rack_pbsmon.py
70    Rewrite to new data structure and automatically determine how many nodes
71    and racks cluster has and skip printing of empty racks (default), use -w/--wide
72    for old behaviour.
73
74    Author: Bas van der Vlies
75
76 -- Bas van der Vlies <bas@sara.nl>  Mon, 12 Nov 2009 15:03:16 +0200
77
78pbs-python (3.2.0-1) intrepid; urgency=low
79
80  *  PBSQuery:
81     New data structure. In the old structure it is a dictionary
82     with a value and the value is a string. This is changed that
83     dictionary values are now of type list or dictionary depends
84     on the value of keyword, eg for a node:
85       - np = 2:
86       - node['np'] = [ '2' ]
87       - properties = cores2, mem4gb, parallel
88       - node['properties'] = [ 'cores2', 'mem4gb', 'parallel' ]
89       - status = arch=x86_64,sessions=22599,,size=70627864kb, ...
90       - node['status']['arch'] = [ 'x86_64' ]
91       - node['status']['sessions'] = [ '222599' ]
92       - ...
93
94         The data structure is activated by the function:
95          - new_data_structure()
96
97         In a future release it will be come the default.
98         example:
99         p = PBSQuery()
100         p.new_data_structure()
101
102        nodes = p.getnodes()
103        print nodes.np, nodes['np']
104
105         Author: Bas van der Vlies
106
107  *  PBSQuery:
108        For old and new data structure we now can use another syntax:
109     - node['np'] and node.np are equivalent
110
111        This new syntax works for all keywords.
112        Author: Bas van der Vlies
113
114  *  PBSQuery:
115        Added iter object for job, node, queue and server objects, eg:
116        node = p.getnode('gb-r1n1')
117        print node.name
118        for attrib in node:
119           print '%\t%s = %s' %(attrib, node[attrib])
120        Author: Bas van der Vlies
121
122  *  PBSQuery:
123        fixed an error in getnode, getqueue and getjob, return
124        empty dictionary if not found.
125        Author: Bas van der Vlies
126
127  *  PBSQuery:
128        New build system for rpm packages, make -f Makefile.rpm
129        Author: Michel Jouvin <jouvin add lal dot in2p3 dot fr>
130        Applied: Bas van der Vlies
131
132 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 14 May 2009 13:41:00 +0200
133
134pbs-python (3.0.1-2) intrepid; urgency=low
135
136  * adjust number of nodes to 32
137
138 -- root <root@rc.sara.nl>  Tue, 17 Mar 2009 18:17:18 +0100
139
140pbs-python (3.0.1-1) intrepid; urgency=low
141
142  * Small bug fix
143
144 -- root <root@rc.sara.nl>  Wed, 28 Jan 2009 13:58:43 +0100
145
146pbs-python (3.0.0-1) intrepid; urgency=low
147
148  * New api for PBSQuery and build on any architecture
149
150 -- Bas van der Vlies <bas@sara.nl>  Tue, 11 Nov 2008 12:48:39 +0100
151
152pbs-python (2.9.8-3) intrepid; urgency=low
153
154  * New functions added to PBSQuery
155
156 -- Bas van der Vlies <basv@sara.nl>  Fri, 10 Oct 2008 11:18:38 +0200
157
158pbs-python (2.9.8-2) intrepid; urgency=low
159
160  * New PBSQuery module
161
162 -- Bas van der Vlies <bas@sara.nl>  Wed,  8 Oct 2008 14:05:44 +0200
163
164pbs-python (2.9.8-1) intrepid; urgency=low
165
166  * New version with updated torque header file (version 2.X)
167
168 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 24 Sep 2008 12:32:29 +0200
169
170pbs-python (2.9.6-1) intrepid; urgency=low
171
172  * pbs_python.spec file patch added libdir and python defines so it
173    will build for RHEL5.1/CentOS 5.1 (by Michael Sternberg) and some
174    minor changes to the pbs_ifl.h file
175
176 -- Dennis Stam <dennis.stam@sara.nl>  Thu, 18 Sep 2008 11:23:16 +0200
177
178pbs-python (2.9.4-1) unstable; urgency=low
179
180  * New version with all the fixes as mentioned below
181
182 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 16 Nov 2006 14:29:16 +0100
183
184pbs-python (2.9.2-4) unstable; urgency=low
185
186  * PBSQuery: Make use of UserDict module
187
188 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 18 Oct 2006 11:46:34 +0200
189
190pbs-python (2.9.2-3) unstable; urgency=low
191
192  *  Fixed a has_key bug must return zero instead of None
193     Thanks to Ramon Bastiaans for reporting
194
195 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 13 Oct 2006 15:33:25 +0200
196
197pbs-python (2.9.2-2) unstable; urgency=low
198
199  * new_rack_pbsmon.py fixes serial/parallel calculations
200
201 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 10 Oct 2006 12:13:25 +0200
202
203pbs-python (2.9.2-1) unstable; urgency=low
204
205  * New upstream version, read CHANGES file
206
207 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 19 Sep 2006 16:17:54 +0200
208
209pbs-python (2.9.1-6) unstable; urgency=low
210
211  *  New torque build system
212
213 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 21 Jul 2006 10:41:31 +0200
214
215pbs-python (2.9.1-5) unstable; urgency=low
216
217  * Down state has most priority. So display it
218
219 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 16 Jun 2006 14:44:48 +0200
220
221pbs-python (2.9.1-4) unstable; urgency=low
222
223  *  Added sara_install to Makefile.in. Else
224     no new pbsmon for SARA
225
226 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 15 Jun 2006 12:23:54 +0200
227
228pbs-python (2.9.1-3) unstable; urgency=low
229
230  * New version adjusted new_rack_pbsmon.py to 39 racks
231
232 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Jun 2006 11:56:26 +0200
233
234pbs-python (2.9.1-2) unstable; urgency=low
235
236  * Fixed a bug in new_rack_pbsmon.py
237
238 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 26 May 2006 16:41:35 +0200
239
240pbs-python (2.9.0-1) unstable; urgency=low
241
242  * Added new build system for torque 2.1.0 and higher
243
244 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 20 Apr 2006 14:25:21 +0200
245
246pbs-python (2.8.2-3) unstable; urgency=low
247
248  * Changed new_rack_pbsmon.py script by walter
249
250 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 13 Apr 2006 14:10:36 +0200
251
252pbs-python (2.8.2-2) unstable; urgency=low
253
254  *  Fixed Makefile.in, now right script
255
256 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  7 Apr 2006 10:59:35 +0200
257
258pbs-python (2.8.2-1) unstable; urgency=low
259
260  *  Added new pbsmon example: new_rack_pbsmon.py uses PBSQuery
261
262 -- Bas van der Vlies <bas@rc.sara.nl>  Thu,  6 Apr 2006 15:12:03 +0200
263
264pbs-python (2.8.0-2) unstable; urgency=medium
265
266  * Used swig 1.3.24 with python2.1 works also on higher python versions
267
268 -- Bas van der Vlies <bas@rc.sara.nl>  Mon,  7 Nov 2005 14:55:00 +0100
269
270pbs-python (2.8.0-1) unstable; urgency=low
271
272  * New pbs_python release, See CHANGES
273
274 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  4 Nov 2005 15:58:44 +0100
275
276pbs-python (2.7.10-1) unstable; urgency=low
277
278  * Added examples/LICENSE.sara to /usr/share/doc directory
279  * Made an sara_install section for pbsmon --> examples/rack_pbsmon.py
280
281 -- Bas van der Vlies <basv@sara.nl>  Mon, 26 Sep 2005 16:32:06 +0200
282
283pbs-python (2.7.9-2) unstable; urgency=low
284
285  * Bumped up version
286  * Fixed  DEBUG mode
287
288 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 24 Jun 2005 11:23:30 +0200
289
290pbs-python (2.7.5-1) unstable; urgency=low
291
292  * Initial version
293
294 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 1 Nov 2004 12:13:08 -0400
295
Note: See TracBrowser for help on using the repository browser.