Modify

Opened 12 years ago

Closed 12 years ago

#145 closed defect (fixed)

whitespace in ticket fields

Reported by: trumbitta@… Owned by: bas
Priority: major Milestone:
Component: email2trac Version: 0.80
Keywords: Cc:

Description

When I use a milestone like this: "milestone with spaces" or a version like this: "2.0 stable" the message will be parsed but no ticket will be added.

I think this affects other fields, too

Attachments (0)

Change History (7)

comment:1 Changed 12 years ago by bas

  • Status changed from new to assigned

Where do you define milestone or version:

  • in subject line
  • in email2trac.conf

can You provide an example?

comment:2 Changed 12 years ago by trumbitta@…

Sorry

The ticket is added but the field with spaces seems to be ignored

Example

in subject line: Test again #?owner=agile,milestone=milestone with spaces,version=1.0

will result in a ticket with:

  • Summary: Test again
  • owner: agile
  • milestone:
  • version: 1.0

Of course the milestone "milestone with spaces" exists in the target Trac

comment:3 Changed 12 years ago by bas

I just test it with the examle message file (msg.txt):

  • added #?owner=agile,milestone=milestone with spaces,version=1.0 to subject line
  • adjusted the debug level in email2trac.conf
  • added the milestone to allowed values with trac-admin
  • run email2trac --dry-run < msg.txt

So or the value is not allowed, The supplied args are checked with the one defined in trac. If it is not allowed then we will skip the supplied value. This must be documented

or you have an extra space when you added the milestone in trac-admin

comment:4 Changed 12 years ago by trumbitta@…

Thank you very much for testing this.

  • I repeated your test, and it works
  • I double-checked the name of the milestone in trax and there is no extra space
  • I then repeated my test sending an email with a client instead of using a txt, and it still doesn't fill the milestone field in the ticket

Maybe the problem is in the client I use to send the message (gmail webmail), or the one I use to retrieve it (fetchmail)...

Can you give an hint about how to trace this? Maybe something to enable in email2trac just to log what exact message it's going to parse before parsing it?

comment:5 Changed 12 years ago by bas

I just tested it with an email message and everything work as exxpected. If you set a dbug level it will dump the raw email message to th TMPDIR,

comment:6 Changed 12 years ago by trumbitta@…

Thank you.

  • I sent a message from Gmail with whitespaces in milestone as described in previous comments
  • The milestone did not appear in the fields of the ticket once imported in trac by email2trac
  • I then found the raw email message in TMPDIR and tried with the command line: email2trac < pleasego.txt
  • The milestone did appear in the ticket

So I'm almost sure it is a mail client problem, not an email2trac one.

Thank you very much for your precious support :)

comment:7 Changed 12 years ago by bas

  • Resolution set to fixed
  • Status changed from assigned to closed

thanks will close the ticket

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.