Modify

Opened 13 years ago

Closed 13 years ago

Last modified 11 years ago

#29 closed defect (wontfix)

email after ticket-creation with email2trac is not sent

Reported by: mrudolph@… Owned by: bas
Priority: major Milestone:
Component: email2trac Version: 0.1
Keywords: Cc:

Description

we use trac 0.10.4-2~feisty1 on an ubuntu server and have the following problem: we've configured under notification in the ini-file the option smtp_always_cc = ... (to three email adresses). If I create a new ticket manually, the mail regarding a new ticket is send. But if i add the new ticket by mailing it trough email2trac no mail will be sent but there is a ticket with the status new.

Attachments (0)

Change History (13)

comment:1 Changed 13 years ago by anonymous

  • Owner changed from bas to anonymous
  • Status changed from new to assigned

Is the trac attachment directory writable? If the trac uses apache it must be writable by apache userid

comment:2 Changed 13 years ago by anonymous

  • Owner changed from anonymous to bas
  • Status changed from assigned to new

Which is the trac attachment directory?

comment:3 Changed 13 years ago by bas

  • Status changed from new to assigned

The directoty in your project environment:

ls <project>

subtrac.irc.sara.nl:/data/trac/oss/project/email2trac
root# ls -l
total 8
-rw-r--r--  1 www-data www-data  98 Oct 17  2006 README
-rw-r--r--  1 www-data www-data  27 Oct 17  2006 VERSION
drwxr-xr-x  3 www-data www-data  19 Oct 17  2006 attachments
drwxr-xr-x  2 www-data www-data  43 Sep 25 14:23 conf
drwxr-xr-x  2 www-data www-data  54 Sep 25 14:24 db
drwxr-xr-x  2 www-data www-data   6 Oct 17  2006 htdocs
drwxr-xr-x  2 www-data www-data   6 Oct 17  2006 log
drwxr-xr-x  2 www-data www-data   6 Oct 17  2006 plugins
drwxr-xr-x  2 www-data www-data 103 Oct 17  2006 templates
drwxr-xr-x  2 www-data www-data   6 Oct 17  2006 wiki-macros

see the attachments directory

comment:4 Changed 13 years ago by mrudolph@…

the directory is writable by user and group of the apache service

/var/trac/ops/attachments/ticket# ll /var/trac/sandbox/
total 48
drwxrws--- 10 www-data www-data 4096 2007-04-30 10:31 .
drwxr-xr-x 13 root     root     4096 2007-07-09 12:14 ..
drwxrwx---  4 www-data www-data 4096 2007-08-09 13:11 attachments
drwxrwx---  2 www-data www-data 4096 2007-08-01 07:47 conf
drwxrwx---  2 www-data www-data 4096 2007-09-21 15:10 db
drwxrwx---  2 www-data www-data 4096 2007-02-16 11:32 htdocs
drwxrwx---  2 www-data www-data 4096 2007-04-30 10:31 log
drwxrwx---  2 www-data www-data 4096 2007-01-15 17:43 plugins
-rw-rw----  1 www-data www-data   98 2006-11-01 13:34 README
drwxrwx---  2 www-data www-data 4096 2007-02-16 11:32 templates
-rw-rw----  1 www-data www-data   27 2006-11-01 13:34 VERSION
drwxrwx---  2 www-data www-data 4096 2006-11-01 13:34 wiki-macros

comment:5 Changed 13 years ago by Bas van der Vlies

And there is no error message in the syslog?

comment:6 Changed 13 years ago by mrudolph@…

probably something wrong with the config file?

[DEFAULT]
project: /data/trac/test
debug: 2
umask: 022
spam_level: 4
reply_all : 1
mailto_link: 0
email_comment: >
email_header: 0
ticket_update: 1
trac_version: 0.10
enable_syslog : 1
alternate_notify_template :
drop_spam : 0
verbatim_format: 1
strip_signature: 1
use_textwrap: 70

[sandbox]
project: /var/trac/sandbox

comment:7 Changed 13 years ago by anonymous

Can you set:

reply_all : 0

and you test with out email2trac utility. In the package there is a test message included:

email2trac --project sandbox < msg.txt

Do you now receive email.

comment:8 Changed 13 years ago by mrudolph@…

by using the commando from the commandline everything works fine and I get the mail. Only when I forward the mail trough postfix to email2trac the cc-mail will not be sent.

Got the following output by running from commadnline:

TD: saving email to /tmp/msg.txt
TD: multipart container
TD: part1: Content-Type: text/plain
TD: part1: filename: None
TD: this part is not multipart
TD: writing part1 (/tmp/part1)
TD: part2: Content-Type: text/plain
TD: part2: filename: basje.txt
TD: this part is not multipart
TD: writing part2 (/tmp/part2)
/var/lib/python-support/python2.5/trac/web/clearsilver.py:128: RuntimeWarning: Python C API version mismatch for module neo_util: This Python has API version 1013, module neo_util has version 1012.
  import neo_cgi
/var/lib/python-support/python2.5/trac/web/clearsilver.py:128: RuntimeWarning: Python C API version mismatch for module neo_cs: This Python has API version 1013, module neo_cs has version 1012.
  import neo_cgi
/var/lib/python-support/python2.5/trac/web/clearsilver.py:128: RuntimeWarning: Python C API version mismatch for module neo_cgi: This Python has API version 1013, module neo_cgi has version 1012.
  import neo_cgi

comment:9 Changed 13 years ago by anonymous

That is strange. There is no error/warning somewhere in a another log, eg the mail.log. Can you also set debug: 0 in email2trac.conf.

For the moment i am clueless

comment:10 Changed 13 years ago by mrudolph@…

One last try: I use the following alias in the /etc/aliases

trac-sandbox: "|/usr/bin/run_email2trac --project=sandbox"

probably a problem with run_email2trac?

comment:11 Changed 13 years ago by anonymous

Can be how did you install email2trac by hand or with a package? You said that the ticket is created but there is no email. That is the stranged part of it.

The mta_user anf trac_user are important parameters, see ./configure --help

comment:12 Changed 13 years ago by bas

Is the ticket still valid

comment:13 Changed 13 years ago by anonymous

  • Resolution set to wontfix
  • Status changed from assigned to closed

the problem is still there, but we will use trac 0.11 and our programmer will change the function to our needs

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain bas.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.