source: trunk/debian/changelog @ 201

Last change on this file since 201 was 201, checked in by bas, 15 years ago

examples/new_rack_pbsmon.py:

  • use new data structure + automatically determine the size of the cluster:
    • number of racks
    • number of node per rack
File size: 6.5 KB
Line 
1pbs-python (3.2.5-1) intrepid; urgency=low
2
3  * PBSQuery
4        The class function of node, job and queue support old and new data
5        structure.
6    Author: Bas van der Vlies
7
8 * new_rack_pbsmon.py
9        Rewrite to new data structure and automatically determine how many nodes
10        and racks a cluster has.
11   Author: Bas van der Vlies
12
13 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 18 May 2009 17:03:16 +0200
14
15pbs-python (3.2.0-1) intrepid; urgency=low
16
17  *  PBSQuery:
18         New data structure. In the old structure it is a dictionary
19         with a value and the value is a string. This is changed that
20         dictionary values are now of type list or dictionary depends
21         on the value of keyword, eg for a node:
22          - np = 2:
23                - node['np'] = [ '2' ]
24          - properties = cores2, mem4gb, parallel
25                - node['properties'] = [ 'cores2', 'mem4gb', 'parallel' ]
26          - status = arch=x86_64,sessions=22599,,size=70627864kb, ...
27                - node['status']['arch'] = [ 'x86_64' ]
28                - node['status']['sessions'] = [ '222599' ]
29                - ...
30
31         The data structure is activated by the function:
32          - new_data_structure()
33
34         In a future release it will be come the default.
35         example:
36                p = PBSQuery()
37                p.new_data_structure()
38
39                nodes = p.getnodes()
40                print nodes.np, nodes['np']
41
42         Author: Bas van der Vlies
43
44  *  PBSQuery:
45        For old and new data structure we now can use another syntax:
46         - node['np'] and node.np are equivalent
47
48        This new syntax works for all keywords.
49        Author: Bas van der Vlies
50
51  *  PBSQuery:
52        Added iter object for job, node, queue and server objects, eg:
53                node = p.getnode('gb-r1n1')
54                print node.name
55                for attrib in node:
56                        print '%\t%s = %s' %(attrib, node[attrib])
57        Author: Bas van der Vlies
58
59  *  PBSQuery:
60        fixed an error in getnode, getqueue and getjob, return
61        empty dictionary if not found.
62        Author: Bas van der Vlies
63
64  *  PBSQuery:
65        New build system for rpm packages, make -f Makefile.rpm
66        Author: Michel Jouvin <jouvin add lal dot in2p3 dot fr>
67        Applied: Bas van der Vlies
68
69 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 14 May 2009 13:41:00 +0200
70
71pbs-python (3.0.1-2) intrepid; urgency=low
72
73  * adjust number of nodes to 32
74
75 -- root <root@rc.sara.nl>  Tue, 17 Mar 2009 18:17:18 +0100
76
77pbs-python (3.0.1-1) intrepid; urgency=low
78
79  * Small bug fix
80
81 -- root <root@rc.sara.nl>  Wed, 28 Jan 2009 13:58:43 +0100
82
83pbs-python (3.0.0-1) intrepid; urgency=low
84
85  * New api for PBSQuery and build on any architecture
86
87 -- Bas van der Vlies <bas@sara.nl>  Tue, 11 Nov 2008 12:48:39 +0100
88
89pbs-python (2.9.8-3) intrepid; urgency=low
90
91  * New functions added to PBSQuery
92
93 -- Bas van der Vlies <basv@sara.nl>  Fri, 10 Oct 2008 11:18:38 +0200
94
95pbs-python (2.9.8-2) intrepid; urgency=low
96
97  * New PBSQuery module
98
99 -- Bas van der Vlies <bas@sara.nl>  Wed,  8 Oct 2008 14:05:44 +0200
100
101pbs-python (2.9.8-1) intrepid; urgency=low
102
103  * New version with updated torque header file (version 2.X)
104
105 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 24 Sep 2008 12:32:29 +0200
106
107pbs-python (2.9.6-1) intrepid; urgency=low
108
109  * pbs_python.spec file patch added libdir and python defines so it
110    will build for RHEL5.1/CentOS 5.1 (by Michael Sternberg) and some
111    minor changes to the pbs_ifl.h file
112
113 -- Dennis Stam <dennis.stam@sara.nl>  Thu, 18 Sep 2008 11:23:16 +0200
114
115pbs-python (2.9.4-1) unstable; urgency=low
116
117  * New version with all the fixes as mentioned below
118
119 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 16 Nov 2006 14:29:16 +0100
120
121pbs-python (2.9.2-4) unstable; urgency=low
122
123  * PBSQuery: Make use of UserDict module
124
125 -- Bas van der Vlies <bas@rc.sara.nl>  Wed, 18 Oct 2006 11:46:34 +0200
126
127pbs-python (2.9.2-3) unstable; urgency=low
128
129  *  Fixed a has_key bug must return zero instead of None
130     Thanks to Ramon Bastiaans for reporting
131
132 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 13 Oct 2006 15:33:25 +0200
133
134pbs-python (2.9.2-2) unstable; urgency=low
135
136  * new_rack_pbsmon.py fixes serial/parallel calculations
137
138 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 10 Oct 2006 12:13:25 +0200
139
140pbs-python (2.9.2-1) unstable; urgency=low
141
142  * New upstream version, read CHANGES file
143
144 -- Bas van der Vlies <bas@rc.sara.nl>  Tue, 19 Sep 2006 16:17:54 +0200
145
146pbs-python (2.9.1-6) unstable; urgency=low
147
148  *  New torque build system
149
150 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 21 Jul 2006 10:41:31 +0200
151
152pbs-python (2.9.1-5) unstable; urgency=low
153
154  * Down state has most priority. So display it
155
156 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 16 Jun 2006 14:44:48 +0200
157
158pbs-python (2.9.1-4) unstable; urgency=low
159
160  *  Added sara_install to Makefile.in. Else
161     no new pbsmon for SARA
162
163 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 15 Jun 2006 12:23:54 +0200
164
165pbs-python (2.9.1-3) unstable; urgency=low
166
167  * New version adjusted new_rack_pbsmon.py to 39 racks
168
169 -- Bas van der Vlies <bas@rc.sara.nl>  Mon, 12 Jun 2006 11:56:26 +0200
170
171pbs-python (2.9.1-2) unstable; urgency=low
172
173  * Fixed a bug in new_rack_pbsmon.py
174
175 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 26 May 2006 16:41:35 +0200
176
177pbs-python (2.9.0-1) unstable; urgency=low
178
179  * Added new build system for torque 2.1.0 and higher
180
181 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 20 Apr 2006 14:25:21 +0200
182
183pbs-python (2.8.2-3) unstable; urgency=low
184
185  * Changed new_rack_pbsmon.py script by walter
186
187 -- Bas van der Vlies <bas@rc.sara.nl>  Thu, 13 Apr 2006 14:10:36 +0200
188
189pbs-python (2.8.2-2) unstable; urgency=low
190
191  *  Fixed Makefile.in, now right script
192
193 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  7 Apr 2006 10:59:35 +0200
194
195pbs-python (2.8.2-1) unstable; urgency=low
196
197  *  Added new pbsmon example: new_rack_pbsmon.py uses PBSQuery
198
199 -- Bas van der Vlies <bas@rc.sara.nl>  Thu,  6 Apr 2006 15:12:03 +0200
200
201pbs-python (2.8.0-2) unstable; urgency=medium
202
203  * Used swig 1.3.24 with python2.1 works also on higher python versions
204
205 -- Bas van der Vlies <bas@rc.sara.nl>  Mon,  7 Nov 2005 14:55:00 +0100
206
207pbs-python (2.8.0-1) unstable; urgency=low
208
209  * New pbs_python release, See CHANGES
210
211 -- Bas van der Vlies <bas@rc.sara.nl>  Fri,  4 Nov 2005 15:58:44 +0100
212
213pbs-python (2.7.10-1) unstable; urgency=low
214
215  * Added examples/LICENSE.sara to /usr/share/doc directory
216  * Made an sara_install section for pbsmon --> examples/rack_pbsmon.py
217
218 -- Bas van der Vlies <basv@sara.nl>  Mon, 26 Sep 2005 16:32:06 +0200
219
220pbs-python (2.7.9-2) unstable; urgency=low
221
222  * Bumped up version
223  * Fixed  DEBUG mode
224
225 -- Bas van der Vlies <bas@rc.sara.nl>  Fri, 24 Jun 2005 11:23:30 +0200
226
227pbs-python (2.7.5-1) unstable; urgency=low
228
229  * Initial version
230
231 -- Yaroslav Halchenko <debian@onerussian.com>  Mon, 1 Nov 2004 12:13:08 -0400
232
Note: See TracBrowser for help on using the repository browser.