Changeset 271


Ignore:
Timestamp:
01/03/12 12:25:00 (11 years ago)
Author:
bas
Message:

Changed debian dependencies. closes #30
and fixed some conflicts with SARA packages

Location:
trunk
Files:
6 edited
1 moved

Legend:

Unmodified
Added
Removed
  • trunk/CHANGES

    r270 r271  
    1 =========== 4.X.X
     1=========== 4.3.3
    22 * New generated files for pbs_wrap.c and pbs.py to support python 3.X versions
    33   Author: Bas van der Vlies
     
    1111   Author: Bas van der Vlies
    1212
     13 * Remove the debian dependency on AdvancedParser. We now have
     14   our own PBSAdvanceParser so it does not conflict with other SARA
     15   packages.
     16   Reported by: Ramon Bastiaans (SARA)
     17   Fixed by: Bas van der Vlies
     18
     19 * Make pbs_torque only dependend on libtorque instead of torque and adjusted
     20   the maintainer of the package, closes #30
     21   Reported by: Guillermo Marcus  <guillermo dot marcus add@gmail dot com>
     22   Fixed by: Bas van der Vlies
     23   
    1324=========== 4.3.0
    1425 * new_rack_pbsmon.py: For backward compatibility added -a/--all option.
  • trunk/debian/changelog

    r270 r271  
     1pbs-python (4.3.3-1) lenny; urgency=low
     2
     3  * see CHANGES
     4
     5 -- Bas van der Vlies <basv@sara.nl>  Tue, 03 Jan 2012 12:01:15 +0100
     6
    17pbs-python (4.3.1-1) lenny; urgency=low
    28
  • trunk/debian/control

    r256 r271  
    22Section: misc
    33Priority: optional
    4 Maintainer: Yaroslav Halchenko <debian@onerussian.com>
     4Maintainer: Bas van der Vlies <basv@sara.nl>
    55Build-Depends: debhelper (>> 4.0.0), cdbs, chrpath, python, torque
    66Standards-Version: 3.5.8
     
    99Section: misc
    1010Architecture: any
    11 Depends: torque, ${python:Depends}
    12 Provides: python-advancedparser
    13 Replaces: python-advancedparser
    14 Conflicts: python-advancedparser
     11Depends: libtorque2, ${python:Depends}
    1512Description: python API for the Torque library
    1613 PBS_PYTHON interface is a wrapper class for the OPENPBS/TORQUE C LIB API.
  • trunk/examples/new_rack_pbsmon.py

    r262 r271  
    3737
    3838import pbs
    39 from AdvancedParser import AdvancedParser
     39from PBSAdvancedParser import AdvancedParser
    4040from PBSQuery import PBSQuery
    4141from PBSQuery import PBSError
  • trunk/examples/sara_nodes.py

    r270 r271  
    1111#
    1212
    13 try:
    14     # import from the sara_python_modules
    15     import AdvancedParser
    16 except ImportError:
    17     from sara import AdvancedParser
    1813
    1914# imports of the pbs_python module
    2015import PBSQuery
     16import PBSAdvancedParser
    2117import pbs
    2218
     
    8682
    8783                self.obj_sara_nodes = sara_nodes()
    88                 self.parser = AdvancedParser.AdvancedParser(
     84                self.parser = PBSAdvancedParser.AdvancedParser(
    8985                option_list=self.option_list,
    9086                                version=pbs.version,
  • trunk/setup.py.in

    r254 r271  
    6767        extra_path = 'pbs',
    6868                package_dir = { '' : 'src' },
    69                 py_modules = [ 'pbs', 'PBSQuery', 'AdvancedParser' ],
     69                py_modules = [ 'pbs', 'PBSQuery', 'PBSAdvancedParser' ],
    7070
    7171        ext_modules = [
Note: See TracChangeset for help on using the changeset viewer.