Modify

Opened 12 years ago

Closed 12 years ago

#172 closed defect (fixed)

Prevent Mail-Loops

Reported by: otto@… Owned by: anonymous
Priority: major Milestone: Release 1.1.0
Component: email2trac Version: 1.0.0
Keywords: Cc:

Description

if someone replies to a notification and set by accident an additional CC to the ticketsystem-address a mail-loop is beeing generated...

the system should check if the cc or something else is set to the system-email-address.

or is there already a way to do prevent that?

Otto

Attachments (0)

Change History (13)

comment:1 Changed 12 years ago by bas

  • Milestone set to Release 1.1.0
  • Status changed from new to assigned

Good catch. We need to strip the ticket email address. in the function set_reply_fields.

comment:2 Changed 12 years ago by bas

  • Resolution set to fixed
  • Status changed from assigned to closed

(In [299]) prevent a mail loop for new tickets when reply_all is set and cc-address is also ticket mail address, closes #172

comment:3 Changed 12 years ago by bas

(In [300]) a better patch for handling mail loop in set_reply and cc-field, depends on smtp_from setting in trac.ini, see #172

comment:4 Changed 12 years ago by bas

  • Resolution fixed deleted
  • Status changed from closed to reopened

It is still possibel to set the tocket email address in CC via reply and then adjust the subject line

comment:5 Changed 12 years ago by bas

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [301]) prevent mail loop, closes #172

comment:6 Changed 12 years ago by otto@…

just tested [300] (and also [301]). I cannot reproduce loops anymore...

Otto

comment:7 Changed 12 years ago by bas

Thanks

comment:8 Changed 12 years ago by otto@…

Haaa, some other condition: Maybe check that also the from-address is not the same as the ticket-address...

we got that case in the beginning. Some developers posted with the ticket-address in "From:" to the ticket-system... ;)

Otto

comment:9 Changed 12 years ago by bas

  • Resolution fixed deleted
  • Status changed from closed to reopened

Closed to quick ;-) Your right (that for a monday!). I am will fix it.

comment:10 Changed 12 years ago by bas

See [304] for sulution

comment:11 Changed 12 years ago by bas

(In [305]) Prevent mail loops when from address is set, see #172

comment:12 Changed 12 years ago by otto@…

  • Owner changed from bas to anonymous
  • Status changed from reopened to new

works perfectly. thank you very much!

Otto

comment:13 Changed 12 years ago by bas

  • Resolution set to fixed
  • Status changed from new to closed

Your welcome. I will close the ticket and release a new version today

Add Comment

Modify Ticket

Change Properties
Action
as closed The owner will remain anonymous.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.